Update to 12.10.0
https://github.com/nodejs/node/blob/v12.10.0/doc/changelogs/CHANGELOG_V12.md#12.10.0 Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
23cd998628
commit
79a5087033
@ -1,4 +1,4 @@
|
|||||||
From 6139142ca617c9de7c802c75133ed536204f80e2 Mon Sep 17 00:00:00 2001
|
From eb4c49be960358e395ade13372f3790e6e41461b Mon Sep 17 00:00:00 2001
|
||||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
|||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index 58f4cc7a5795b80bb8b02efe28235a6b674d3204..960fb201c72432214fba1f1625fd6258ad9dc45a 100644
|
index 33d43798f52617797d787b4999317e258811c157..a59615648f49a72411ac086ad1bc0c2623b4a41f 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -139,13 +139,13 @@ with-code-cache:
|
@@ -139,13 +139,13 @@ with-code-cache:
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From a136a2d73ed3502600eb49ee4f93775f5dfe02ce Mon Sep 17 00:00:00 2001
|
From 0461fabf259b36a156c55dc402b1d66d09eb90ca Mon Sep 17 00:00:00 2001
|
||||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||||
@ -9,10 +9,10 @@ Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
|
|||||||
1 file changed, 54 deletions(-)
|
1 file changed, 54 deletions(-)
|
||||||
|
|
||||||
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
diff --git a/deps/npm/bin/npm-cli.js b/deps/npm/bin/npm-cli.js
|
||||||
index 705aa472e7e5502311f24767adfb0aebab396772..e8aebe644f610bb09c3748338fd70e6c8c422cea 100755
|
index 93eddc7a3c892b0f5d35c477c042a8e5087d7b01..ceb12b5d9a33ab7b98df05d7ef082c42f03eedb9 100755
|
||||||
--- a/deps/npm/bin/npm-cli.js
|
--- a/deps/npm/bin/npm-cli.js
|
||||||
+++ b/deps/npm/bin/npm-cli.js
|
+++ b/deps/npm/bin/npm-cli.js
|
||||||
@@ -66,69 +66,15 @@
|
@@ -67,69 +67,15 @@
|
||||||
if (conf.usage && npm.command !== 'help') {
|
if (conf.usage && npm.command !== 'help') {
|
||||||
npm.argv.unshift(npm.command)
|
npm.argv.unshift(npm.command)
|
||||||
npm.command = 'help'
|
npm.command = 'help'
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 4a32f1d071d7275d5b946047b5cc59116c46bab1 Mon Sep 17 00:00:00 2001
|
From f35fcd689dce64e7d6b5f3496e5e5358a24ae4e0 Mon Sep 17 00:00:00 2001
|
||||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||||
@ -13,7 +13,7 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
|||||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||||
|
|
||||||
diff --git a/configure.py b/configure.py
|
diff --git a/configure.py b/configure.py
|
||||||
index beab9ceccce9adc8ec564350a732382d186ffdf1..8d08988ed6245f43928ad65af02b7bd29f1d47a7 100755
|
index ce01a14566e65ad9d568e0cb8594b35bacd698c6..180f0b4861463e3d4fab979fce4b4c8dfc6ceee2 100755
|
||||||
--- a/configure.py
|
--- a/configure.py
|
||||||
+++ b/configure.py
|
+++ b/configure.py
|
||||||
@@ -554,10 +554,16 @@ parser.add_option('--shared',
|
@@ -554,10 +554,16 @@ parser.add_option('--shared',
|
||||||
@ -33,7 +33,7 @@ index beab9ceccce9adc8ec564350a732382d186ffdf1..8d08988ed6245f43928ad65af02b7bd2
|
|||||||
dest='without_v8_platform',
|
dest='without_v8_platform',
|
||||||
default=False,
|
default=False,
|
||||||
help='do not initialize v8 platform during node.js startup. ' +
|
help='do not initialize v8 platform during node.js startup. ' +
|
||||||
@@ -1093,10 +1099,11 @@ def configure_node(o):
|
@@ -1096,10 +1102,11 @@ def configure_node(o):
|
||||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||||
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
||||||
if o['variables']['want_separate_host_toolset'] == 0:
|
if o['variables']['want_separate_host_toolset'] == 0:
|
||||||
|
10
nodejs.spec
10
nodejs.spec
@ -19,7 +19,7 @@
|
|||||||
# than a Fedora release lifecycle.
|
# than a Fedora release lifecycle.
|
||||||
%global nodejs_epoch 1
|
%global nodejs_epoch 1
|
||||||
%global nodejs_major 12
|
%global nodejs_major 12
|
||||||
%global nodejs_minor 9
|
%global nodejs_minor 10
|
||||||
%global nodejs_patch 0
|
%global nodejs_patch 0
|
||||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||||
@ -102,7 +102,7 @@
|
|||||||
%global npm_epoch 1
|
%global npm_epoch 1
|
||||||
%global npm_major 6
|
%global npm_major 6
|
||||||
%global npm_minor 10
|
%global npm_minor 10
|
||||||
%global npm_patch 2
|
%global npm_patch 3
|
||||||
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
%global npm_version %{npm_major}.%{npm_minor}.%{npm_patch}
|
||||||
|
|
||||||
# In order to avoid needing to keep incrementing the release version for the
|
# In order to avoid needing to keep incrementing the release version for the
|
||||||
@ -619,7 +619,11 @@ end
|
|||||||
%{_pkgdocdir}/npm/doc
|
%{_pkgdocdir}/npm/doc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Aug 21 2019 Stephen Gallagher <sgallagh@redhat.com> - -
|
* Wed Sep 04 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.10.0-1
|
||||||
|
- Update to 12.10.0
|
||||||
|
- https://github.com/nodejs/node/blob/v12.10.0/doc/changelogs/CHANGELOG_V12.md#12.10.0
|
||||||
|
|
||||||
|
* Wed Aug 21 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.9.0-1
|
||||||
- Update to 12.9.0
|
- Update to 12.9.0
|
||||||
- https://github.com/nodejs/node/blob/v12.9.0/doc/changelogs/CHANGELOG_V12.md#12.9.0
|
- https://github.com/nodejs/node/blob/v12.9.0/doc/changelogs/CHANGELOG_V12.md#12.9.0
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (node-v12.9.0-stripped.tar.gz) = c82d9e7e76de928d9c7e2b05de6640efc91bf700a9594e744554a02a92d831d238489e7bf34f0beffd1573ed74298d8cd63dd75bf609f2c7d916da3bff50dd74
|
SHA512 (node-v12.10.0-stripped.tar.gz) = 4e99ffe8565f0bac1a2ce7c3797d5e734d42d11998c7c36033a6e4ddda7a432d1a4c7d02c1a606ebc28c1b7324caecf38c701fb2c8dafcc56af97eaf5f996318
|
||||||
|
Loading…
Reference in New Issue
Block a user