Update to 12.9.0
Signed-off-by: Stephen Gallagher <sgallagh@redhat.com>
This commit is contained in:
parent
a7660f795d
commit
23cd998628
@ -1,4 +1,4 @@
|
||||
From d8cdfcd680cbd728904c19b2eea7730c61b16c73 Mon Sep 17 00:00:00 2001
|
||||
From 6139142ca617c9de7c802c75133ed536204f80e2 Mon Sep 17 00:00:00 2001
|
||||
From: Zuzana Svetlikova <zsvetlik@redhat.com>
|
||||
Date: Thu, 27 Apr 2017 14:25:42 +0200
|
||||
Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
@ -8,7 +8,7 @@ Subject: [PATCH 1/3] Disable running gyp on shared deps
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 1e4915a6d2ebedc8af009d8505b5b8d11a53f5f7..cae1c3c1da9a440d84a6f86fa6353e81db535c71 100644
|
||||
index 58f4cc7a5795b80bb8b02efe28235a6b674d3204..960fb201c72432214fba1f1625fd6258ad9dc45a 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -139,13 +139,13 @@ with-code-cache:
|
||||
|
@ -1,4 +1,4 @@
|
||||
From ef6374e4ed159b719f465ecdb2e273019f134fb0 Mon Sep 17 00:00:00 2001
|
||||
From a136a2d73ed3502600eb49ee4f93775f5dfe02ce Mon Sep 17 00:00:00 2001
|
||||
From: Stephen Gallagher <sgallagh@redhat.com>
|
||||
Date: Tue, 1 May 2018 08:05:30 -0400
|
||||
Subject: [PATCH 2/3] Suppress NPM message to run global update
|
||||
|
@ -1,4 +1,4 @@
|
||||
From bc1d8e49a42cb88d86b2accba6ee1776baba4ca5 Mon Sep 17 00:00:00 2001
|
||||
From 4a32f1d071d7275d5b946047b5cc59116c46bab1 Mon Sep 17 00:00:00 2001
|
||||
From: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
Date: Tue, 19 Mar 2019 23:22:40 -0400
|
||||
Subject: [PATCH 3/3] Install both binaries and use libdir.
|
||||
@ -13,10 +13,10 @@ Signed-off-by: Elliott Sales de Andrade <quantum.analyst@gmail.com>
|
||||
2 files changed, 20 insertions(+), 16 deletions(-)
|
||||
|
||||
diff --git a/configure.py b/configure.py
|
||||
index cc805d3fd165fd2abe4c8581ffdb8829341ad2ba..64f50439bc09827f99786c3b0d574ba454954ca9 100755
|
||||
index beab9ceccce9adc8ec564350a732382d186ffdf1..8d08988ed6245f43928ad65af02b7bd29f1d47a7 100755
|
||||
--- a/configure.py
|
||||
+++ b/configure.py
|
||||
@@ -550,10 +550,16 @@ parser.add_option('--shared',
|
||||
@@ -554,10 +554,16 @@ parser.add_option('--shared',
|
||||
action='store_true',
|
||||
dest='shared',
|
||||
help='compile shared library for embedding node in another project. ' +
|
||||
@ -33,7 +33,7 @@ index cc805d3fd165fd2abe4c8581ffdb8829341ad2ba..64f50439bc09827f99786c3b0d574ba4
|
||||
dest='without_v8_platform',
|
||||
default=False,
|
||||
help='do not initialize v8 platform during node.js startup. ' +
|
||||
@@ -1094,10 +1100,11 @@ def configure_node(o):
|
||||
@@ -1093,10 +1099,11 @@ def configure_node(o):
|
||||
o['variables']['node_no_browser_globals'] = b(options.no_browser_globals)
|
||||
# TODO(refack): fix this when implementing embedded code-cache when cross-compiling.
|
||||
if o['variables']['want_separate_host_toolset'] == 0:
|
||||
|
18
nodejs.spec
18
nodejs.spec
@ -19,8 +19,8 @@
|
||||
# than a Fedora release lifecycle.
|
||||
%global nodejs_epoch 1
|
||||
%global nodejs_major 12
|
||||
%global nodejs_minor 8
|
||||
%global nodejs_patch 1
|
||||
%global nodejs_minor 9
|
||||
%global nodejs_patch 0
|
||||
%global nodejs_abi %{nodejs_major}.%{nodejs_minor}
|
||||
# nodejs_soversion - from NODE_MODULE_VERSION in src/node_version.h
|
||||
%global nodejs_soversion 72
|
||||
@ -32,9 +32,9 @@
|
||||
# Epoch is set to ensure clean upgrades from the old v8 package
|
||||
%global v8_epoch 2
|
||||
%global v8_major 7
|
||||
%global v8_minor 5
|
||||
%global v8_build 288
|
||||
%global v8_patch 22
|
||||
%global v8_minor 6
|
||||
%global v8_build 303
|
||||
%global v8_patch 29
|
||||
# V8 presently breaks ABI at least every x.y release while never bumping SONAME
|
||||
%global v8_abi %{v8_major}.%{v8_minor}
|
||||
%global v8_version %{v8_major}.%{v8_minor}.%{v8_build}.%{v8_patch}
|
||||
@ -61,8 +61,8 @@
|
||||
|
||||
# libuv - from deps/uv/include/uv/version.h
|
||||
%global libuv_major 1
|
||||
%global libuv_minor 30
|
||||
%global libuv_patch 1
|
||||
%global libuv_minor 31
|
||||
%global libuv_patch 0
|
||||
%global libuv_version %{libuv_major}.%{libuv_minor}.%{libuv_patch}
|
||||
|
||||
# nghttp2 - from deps/nghttp2/lib/includes/nghttp2/nghttp2ver.h
|
||||
@ -619,6 +619,10 @@ end
|
||||
%{_pkgdocdir}/npm/doc
|
||||
|
||||
%changelog
|
||||
* Wed Aug 21 2019 Stephen Gallagher <sgallagh@redhat.com> - -
|
||||
- Update to 12.9.0
|
||||
- https://github.com/nodejs/node/blob/v12.9.0/doc/changelogs/CHANGELOG_V12.md#12.9.0
|
||||
|
||||
* Thu Aug 15 2019 Stephen Gallagher <sgallagh@redhat.com> - 1:12.8.2-1
|
||||
- Update to 12.8.1
|
||||
- Resolves: CVE-2019-9511 "Data Dribble"
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (node-v12.8.1-stripped.tar.gz) = b7c007e7a0c92303893a389d345f1040d43a0c8eb1ed46f250476ddfae368dbf5a708a81a6bf9f30411684aeabb436371451ebab9decaf2b8e192ea8a342784f
|
||||
SHA512 (node-v12.9.0-stripped.tar.gz) = c82d9e7e76de928d9c7e2b05de6640efc91bf700a9594e744554a02a92d831d238489e7bf34f0beffd1573ed74298d8cd63dd75bf609f2c7d916da3bff50dd74
|
||||
|
Loading…
Reference in New Issue
Block a user