- remove two hunks from security patch breaking pbmclean and pbmlife
(#493015) - fix ppmdfont and svgtopnm, thanks to Jiri Moskovcak
This commit is contained in:
parent
c898a9ede8
commit
d300d89c7d
@ -1310,30 +1310,6 @@ diff -up netpbm-10.35.46/editor/pamoil.c.security netpbm-10.35.46/editor/pamoil.
|
|||||||
MALLOCARRAY(hist, inpam.maxval + 1);
|
MALLOCARRAY(hist, inpam.maxval + 1);
|
||||||
if (hist == NULL)
|
if (hist == NULL)
|
||||||
pm_error("Unable to allocate memory for histogram.");
|
pm_error("Unable to allocate memory for histogram.");
|
||||||
diff -up netpbm-10.35.46/editor/pbmclean.c.security netpbm-10.35.46/editor/pbmclean.c
|
|
||||||
--- netpbm-10.35.46/editor/pbmclean.c.security 2008-06-24 08:58:59.000000000 +0200
|
|
||||||
+++ netpbm-10.35.46/editor/pbmclean.c 2008-06-24 09:04:21.000000000 +0200
|
|
||||||
@@ -150,7 +150,7 @@ nextrow(FILE * const ifd,
|
|
||||||
inrow[0] = inrow[1];
|
|
||||||
inrow[1] = inrow[2];
|
|
||||||
inrow[2] = shuffle ;
|
|
||||||
- if (row+1 < rows) {
|
|
||||||
+ if (row <= rows) {
|
|
||||||
/* Read the "next" row in from the file. Allocate buffer if needed */
|
|
||||||
if (inrow[2] == NULL)
|
|
||||||
inrow[2] = pbm_allocrow(cols);
|
|
||||||
diff -up netpbm-10.35.46/editor/pbmlife.c.security netpbm-10.35.46/editor/pbmlife.c
|
|
||||||
--- netpbm-10.35.46/editor/pbmlife.c.security 2008-06-24 08:58:59.000000000 +0200
|
|
||||||
+++ netpbm-10.35.46/editor/pbmlife.c 2008-06-24 09:04:21.000000000 +0200
|
|
||||||
@@ -54,7 +54,7 @@ char* argv[];
|
|
||||||
prevrow = thisrow;
|
|
||||||
thisrow = nextrow;
|
|
||||||
nextrow = temprow;
|
|
||||||
- if ( row < rows - 1 )
|
|
||||||
+ if ( row <= rows )
|
|
||||||
pbm_readpbmrow( ifp, nextrow, cols, format );
|
|
||||||
|
|
||||||
for ( col = 0; col < cols; ++col )
|
|
||||||
diff -up netpbm-10.35.46/editor/pbmpscale.c.security netpbm-10.35.46/editor/pbmpscale.c
|
diff -up netpbm-10.35.46/editor/pbmpscale.c.security netpbm-10.35.46/editor/pbmpscale.c
|
||||||
--- netpbm-10.35.46/editor/pbmpscale.c.security 2008-06-24 08:58:59.000000000 +0200
|
--- netpbm-10.35.46/editor/pbmpscale.c.security 2008-06-24 08:58:59.000000000 +0200
|
||||||
+++ netpbm-10.35.46/editor/pbmpscale.c 2008-06-24 09:04:21.000000000 +0200
|
+++ netpbm-10.35.46/editor/pbmpscale.c 2008-06-24 09:04:21.000000000 +0200
|
||||||
|
13
netpbm-10.35-ppmdfontfix.patch
Normal file
13
netpbm-10.35-ppmdfontfix.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff -up netpbm-10.35.58/lib/ppmdfont.c.ppmdfontfix netpbm-10.35.58/lib/ppmdfont.c
|
||||||
|
--- netpbm-10.35.58/lib/ppmdfont.c.ppmdfontfix 2009-01-19 09:23:54.000000000 +0100
|
||||||
|
+++ netpbm-10.35.58/lib/ppmdfont.c 2009-03-23 13:06:36.000000000 +0100
|
||||||
|
@@ -62,7 +62,8 @@ static void
|
||||||
|
readFontHeader(FILE * const ifP,
|
||||||
|
struct ppmd_fontHeader * const fontHeaderP) {
|
||||||
|
|
||||||
|
- fread(&fontHeaderP->signature, 1, sizeof(fontHeaderP->signature), ifP);
|
||||||
|
+ if (!fread(&fontHeaderP->signature, 1, sizeof(fontHeaderP->signature), ifP))
|
||||||
|
+ pm_error("Error reading font header.");
|
||||||
|
fontHeaderP->format = fgetc(ifP);
|
||||||
|
fontHeaderP->characterCount = fgetc(ifP);
|
||||||
|
fontHeaderP->firstCodePoint = fgetc(ifP);
|
14
netpbm-10.35-svgtopam.patch
Normal file
14
netpbm-10.35-svgtopam.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up netpbm-10.35.58/converter/other/Makefile.svgtopam netpbm-10.35.58/converter/other/Makefile
|
||||||
|
--- netpbm-10.35.58/converter/other/Makefile.svgtopam 2009-01-19 09:23:58.000000000 +0100
|
||||||
|
+++ netpbm-10.35.58/converter/other/Makefile 2009-03-23 13:17:22.000000000 +0100
|
||||||
|
@@ -107,10 +107,6 @@ ifneq ($(ZLIB),NONE)
|
||||||
|
BINARIES += pnmtops
|
||||||
|
endif
|
||||||
|
|
||||||
|
-ifneq ($(XML2_LIBS),NONE)
|
||||||
|
- BINARIES += svgtopam
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
MERGEBINARIES = $(BINARIES)
|
||||||
|
|
||||||
|
EXTRA_OBJECTS = exif.o rast.o pngtxt.o bmepsoe.o
|
10
netpbm.spec
10
netpbm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.35.61
|
Version: 10.35.61
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -36,6 +36,8 @@ Patch24: netpbm-10.35-64bitfix.patch
|
|||||||
Patch25: netpbm-10.35-ximtoppmsegfault.patch
|
Patch25: netpbm-10.35-ximtoppmsegfault.patch
|
||||||
Patch26: netpbm-10.35-ppmfadeusage.patch
|
Patch26: netpbm-10.35-ppmfadeusage.patch
|
||||||
Patch27: netpbm-10.35-ppmrainbowexit.patch
|
Patch27: netpbm-10.35-ppmrainbowexit.patch
|
||||||
|
Patch28: netpbm-10.35-ppmdfontfix.patch
|
||||||
|
Patch29: netpbm-10.35-svgtopam.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||||
BuildRequires: libX11-devel, python, jasper-devel
|
BuildRequires: libX11-devel, python, jasper-devel
|
||||||
@ -102,6 +104,8 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch25 -p1 -b .ximtoppmsegfault
|
%patch25 -p1 -b .ximtoppmsegfault
|
||||||
%patch26 -p1 -b .ppmfadeusage
|
%patch26 -p1 -b .ppmfadeusage
|
||||||
%patch27 -p1 -b .ppmrainbowexit
|
%patch27 -p1 -b .ppmrainbowexit
|
||||||
|
%patch28 -p1 -b .ppmdfontfix
|
||||||
|
%patch29 -p1 -b .svgtopam
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure <<EOF
|
./configure <<EOF
|
||||||
@ -227,6 +231,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/netpbm/
|
%{_datadir}/netpbm/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 31 2009 Jindrich Novy <jnovy@redhat.com> 10.35.61-2
|
||||||
|
- remove two hunks from security patch breaking pbmclean and pbmlife (#493015)
|
||||||
|
- fix ppmdfont and svgtopnm, thanks to Jiri Moskovcak
|
||||||
|
|
||||||
* Mon Mar 23 2009 Jindrich Novy <jnovy@redhat.com> 10.35.61-1
|
* Mon Mar 23 2009 Jindrich Novy <jnovy@redhat.com> 10.35.61-1
|
||||||
- update to 10.35.61
|
- update to 10.35.61
|
||||||
- upstream fixes array bound violation in pbmtog3
|
- upstream fixes array bound violation in pbmtog3
|
||||||
|
Loading…
Reference in New Issue
Block a user