- update to 10.35.61
- upstream fixes array bound violation in pbmtog3 - drop .pbmtog3segfault patch, we fixed this some time ago already and it is in upstream now - use saner exit status in ppmfade
This commit is contained in:
parent
ef860ef581
commit
c898a9ede8
@ -1 +1,2 @@
|
||||
netpbm-10.35.60.tar.bz2
|
||||
netpbm-10.35.61.tar.bz2
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- netpbm-10.35/converter/pbm/pbmtog3.c.pbmtog3segfault 2006-09-18 12:20:32.000000000 +0200
|
||||
+++ netpbm-10.35/converter/pbm/pbmtog3.c 2006-12-28 11:43:19.000000000 +0100
|
||||
@@ -371,7 +371,7 @@
|
||||
r2 <<= c++; r2 <<= 1; k += c;
|
||||
}
|
||||
}
|
||||
- if (milepost[n - 1] != cols)
|
||||
+ if (!n || milepost[n - 1] != cols)
|
||||
milepost[n++] = cols;
|
||||
*lengthP = n;
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
diff -up netpbm-10.35.60/editor/ppmfade.ppmfadeusage netpbm-10.35.60/editor/ppmfade
|
||||
--- netpbm-10.35.60/editor/ppmfade.ppmfadeusage 2009-02-26 17:43:14.000000000 +0100
|
||||
+++ netpbm-10.35.60/editor/ppmfade 2009-02-26 17:43:44.000000000 +0100
|
||||
--- netpbm-10.35.60/editor/ppmfade.ppmfadeusage 2009-02-27 12:35:26.000000000 +0100
|
||||
+++ netpbm-10.35.60/editor/ppmfade 2009-02-27 12:39:06.000000000 +0100
|
||||
@@ -36,6 +36,8 @@ my $mode = $SPREAD; # default fading mo
|
||||
#
|
||||
# Check those command line args.
|
||||
@ -10,3 +10,19 @@ diff -up netpbm-10.35.60/editor/ppmfade.ppmfadeusage netpbm-10.35.60/editor/ppmf
|
||||
if (@ARGV == 0) {
|
||||
usage();
|
||||
}
|
||||
@@ -82,7 +84,7 @@ for ($n = 0; $n < @ARGV; $n++) {
|
||||
usage();
|
||||
} else {
|
||||
print "Unknown argument: $ARGV[$n]\n";
|
||||
- exit 100;
|
||||
+ exit 1;
|
||||
}
|
||||
}
|
||||
#
|
||||
@@ -312,5 +314,5 @@ sub usage() {
|
||||
print " [-base basename]\n";
|
||||
print "Notes: Default base: fade\n";
|
||||
print " The resulting image files will be named fade.NNNN.ppm.\n";
|
||||
- exit(100);
|
||||
+ exit 1;
|
||||
}
|
||||
|
13
netpbm.spec
13
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.35.60
|
||||
Release: 3%{?dist}
|
||||
Version: 10.35.61
|
||||
Release: 1%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
Group: System Environment/Libraries
|
||||
@ -25,7 +25,6 @@ Patch12: netpbm-10.33-ppmtompeg.patch
|
||||
Patch13: netpbm-10.33-multilib.patch
|
||||
Patch14: netpbm-10.34-pamscale.patch
|
||||
Patch15: netpbm-10.35-ppmquantall.patch
|
||||
Patch16: netpbm-10.35-pbmtog3segfault.patch
|
||||
Patch17: netpbm-10.35-pbmtomacp.patch
|
||||
Patch18: netpbm-10.35-glibc.patch
|
||||
Patch19: netpbm-10.35-gcc43.patch
|
||||
@ -92,7 +91,6 @@ netpbm-progs. You'll also need to install the netpbm package.
|
||||
%patch13 -p1 -b .multilib
|
||||
%patch14 -p1 -b .pamscale
|
||||
%patch15 -p1 -b .pqall
|
||||
%patch16 -p1 -b .pbmtog3segfault
|
||||
%patch17 -p1 -b .pbmtomacp
|
||||
%patch18 -p1 -b .glibc
|
||||
%patch19 -p1 -b .gcc43
|
||||
@ -229,6 +227,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/netpbm/
|
||||
|
||||
%changelog
|
||||
* Mon Mar 23 2009 Jindrich Novy <jnovy@redhat.com> 10.35.61-1
|
||||
- update to 10.35.61
|
||||
- upstream fixes array bound violation in pbmtog3
|
||||
- drop .pbmtog3segfault patch, we fixed this some time ago already
|
||||
and it is in upstream now
|
||||
- use saner exit status in ppmfade
|
||||
|
||||
* Thu Feb 26 2009 Jindrich Novy <jnovy@redhat.com> 10.35.60-3
|
||||
- fix broken perl syntax in ppmfade
|
||||
- fix exit status and error reporting in ppmrainbow
|
||||
|
Loading…
Reference in New Issue
Block a user