- update to 10.47.09, fixes occassional crash in pamtosvg

- fix documentation
- fix ppmfade exit status
This commit is contained in:
Jindrich Novy 2010-01-25 08:42:36 +00:00
parent ef5891128a
commit cdf609915c
5 changed files with 163 additions and 3 deletions

View File

@ -1 +1 @@
netpbm-10.47.08.tar.xz
netpbm-10.47.09.tar.xz

91
netpbm-docfix.patch Normal file
View File

@ -0,0 +1,91 @@
diff -up netpbm-10.35.58/converter/pbm/pbmtoepson.c.docfix netpbm-10.35.58/converter/pbm/pbmtoepson.c
--- netpbm-10.35.58/converter/pbm/pbmtoepson.c.docfix 2009-01-19 09:24:03.000000000 +0100
+++ netpbm-10.35.58/converter/pbm/pbmtoepson.c 2009-04-15 09:10:52.000000000 +0200
@@ -74,7 +74,7 @@ parseCommandLine(int arg
&dpiSpec, 0);
OPTENT3(0, "adjacent", OPT_FLAG, NULL,
&adjacentSpec, 0);
- OPTENT3(0, "nonadjacent", OPT_FLAG, NULL,
+ OPTENT3(0, "noadjacent", OPT_FLAG, NULL,
&nonadjacentSpec, 0);
opt.opt_table = option_def;
diff -up netpbm-10.35.58/userguide/cameratopam.html.docfix netpbm-10.35.58/userguide/cameratopam.html
--- netpbm-10.35.58/userguide/cameratopam.html.docfix 2009-01-19 09:24:18.000000000 +0100
+++ netpbm-10.35.58/userguide/cameratopam.html 2009-04-15 09:16:16.000000000 +0200
@@ -25,10 +25,10 @@ cameratopam - convert raw camera image t
[<b>-balance_camera</b>]
[<b>-red_scale=</b><i>float</i>]
[<b>-blue_scale=</b><i>float</i>]
-[<b>-brightness=</b><i>fraction</i>]
+[<b>-bright=</b><i>fraction</i>]
[<b>-no_clip_color</b>]
[<b>-rgb</b>]
-[<b>-secondary</b>]
+[<b>-use_secondary</b>]
[<b>-linear</b>]
[<b>-verbose</b>]
@@ -106,7 +106,7 @@ the default.
<dd>Further adjust the color balance by multiplying the red and blue
channels by these values. Both default to 1.0.
-<dt><b>-brightness=</b><i>float</i>
+<dt><b>-bright=</b><i>float</i>
<dd>Change the output brightness. Default is 1.0.
@@ -114,14 +114,14 @@ channels by these values. Both default
<dd>By default, <b>cameratoapm</b> clips all colors to prevent pink
hues in the highlights. Combine this option with
-<b>-brightness=0.25</b> to leave the image data completely unclipped.
+<b>-bright=0.25</b> to leave the image data completely unclipped.
<dt><b>-rgb</b>
<dd>Write raw camera colors to the output file. By default,
<b>cameratoapm</b> converts to sRGB colorspace.
-<dt><b>-secondary</b>
+<dt><b>-use_secondary</b>
<dd>For cameras based on the Fuji Super CCD SR, this option causes
<b>cameratopam</b> to use the secondary sensors, in effect
diff -up netpbm-10.35.58/userguide/fiascotopnm.html.docfix netpbm-10.35.58/userguide/fiascotopnm.html
--- netpbm-10.35.58/userguide/fiascotopnm.html.docfix 2009-01-19 09:24:18.000000000 +0100
+++ netpbm-10.35.58/userguide/fiascotopnm.html 2009-04-15 09:10:52.000000000 +0200
@@ -51,7 +51,7 @@ the output file(s) are written to the fi
this list. Otherwise, the current directory is used to store the
output file(s).
-<DT><B>-z</B>, <B>--fast</B>
+<DT><B>-r</B>, <B>--fast</B>
<DD>
Decompress images in the 4:2:0 format; i.e., each chroma channel is
decompressed to an image of halved width and height. Use this option
@@ -83,7 +83,7 @@ given amount <I>N</I>. <I>N</I> is 1 (mi
is 70. When <I>N</I>=0, then the smoothing amount specified in the
FIASCO file is used (defined by the FIASCO coder).
-<DT><B>-F</B> <I>N</I>, <B>--fps=</B><I>N</I>
+<DT><B>-F</B> <I>N</I>, <B>--framerate=</B><I>N</I>
<DD>
Set number of frames per second to <I>N</I>. When using this option,
the frame rate specified in the FIASCO file is overridden.
@@ -109,13 +109,9 @@ following methods (in the specified orde
<LI>--config=<I>name</I>
</OL>
-<DT><B>-h</B>, <B>--info</B>
+<DT><B>-h</B>, <B>--help</B>
<DD>
-Print brief help, then exit.
-
-<DT><B>-H</B>, <B>--help</B>
-<DD>
-Print detailed help, then exit.
+Print help, then exit.
</DL>

60
netpbm-ppmfadeusage.patch Normal file
View File

@ -0,0 +1,60 @@
diff -up netpbm-10.47.05/editor/ppmfade.ppmfadeusage netpbm-10.47.05/editor/ppmfade
--- netpbm-10.47.05/editor/ppmfade.ppmfadeusage 2010-01-21 05:36:00.000000000 +0100
+++ netpbm-10.47.05/editor/ppmfade 2010-01-21 05:40:32.000000000 +0100
@@ -34,6 +34,7 @@ my $base_name = "fade"; # default base
my $image = "ppm"; # default output storage format
my $mode = $SPREAD; # default fading mode
+sub usage();
my $n; # argument number
@@ -44,7 +45,7 @@ for ($n = 0; $n < @ARGV; $n++) {
if (-e $first_file) {
} else {
print "I can't find first file '$first_file'\n";
- exit 20;
+ exit 1;
}
} elsif ($ARGV[$n] eq "-l") {
$n++;
@@ -52,7 +53,7 @@ for ($n = 0; $n < @ARGV; $n++) {
if (-e $last_file) {
} else {
print "I can't find last file '$last_file'\n";
- exit 20;
+ exit 1;
}
} elsif ($ARGV[$n] eq "-base") {
$n++;
@@ -77,7 +78,7 @@ for ($n = 0; $n < @ARGV; $n++) {
usage();
} else {
print "Unknown argument: $ARGV[$n]\n";
- exit 100;
+ exit 1;
}
}
#
@@ -96,18 +97,18 @@ if ($first_file ne "undefined") {
$width = $1; $height = $2;
} else {
print("Unrecognized results from pnmfile on $first_file.\n");
- exit(50);
+ exit 1;
}
} elsif ($last_file ne "undefined") {
if ((`pnmfile $last_file` =~ m{\b(\d+)\sby\s(\d+)} )) {
$width = $1; $height = $2;
} else {
print("Unrecognized results from pnmfile on $first_file.\n");
- exit(50);
+ exit 1;
}
} else {
print("ppmfade: You must specify -f or -l (or both)\n");
- exit(90);
+ exit 1;
}
print("Frames are " . $width . "W x " . $height . "H\n");

View File

@ -1,6 +1,6 @@
Summary: A library for handling different graphics file formats
Name: netpbm
Version: 10.47.08
Version: 10.47.09
Release: 1%{?dist}
# See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain
@ -25,6 +25,8 @@ Patch11: netpbm-multilib.patch
Patch12: netpbm-pamscale.patch
Patch13: netpbm-glibc.patch
Patch14: netpbm-svgtopam.patch
Patch15: netpbm-docfix.patch
Patch16: netpbm-ppmfadeusage.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel
@ -80,6 +82,8 @@ netpbm-progs. You'll also need to install the netpbm package.
%patch12 -p1 -b .pamscale
%patch13 -p1 -b .glibc
%patch14 -p1 -b .svgtopam
%patch15 -p1 -b .docfix
%patch16 -p1 -b .ppmfadeusage
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
@ -208,6 +212,11 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/
%changelog
* Mon Jan 25 2010 Jindrich Novy <jnovy@redhat.com> 10.47.09-1
- update to 10.47.09, fixes occassional crash in pamtosvg
- fix documentation
- fix ppmfade exit status
* Wed Jan 13 2010 Jindrich Novy <jnovy@redhat.com> 10.47.08-1
- update to 10.47.08

View File

@ -1 +1 @@
0b382883c1b93f5120da1eaca7b253f8 netpbm-10.47.08.tar.xz
83225183f7bf589fc861721f28ad1bbb netpbm-10.47.09.tar.xz