diff --git a/.cvsignore b/.cvsignore
index 816cd7b..b6f2aa4 100644
--- a/.cvsignore
+++ b/.cvsignore
@@ -1 +1 @@
-netpbm-10.47.08.tar.xz
+netpbm-10.47.09.tar.xz
diff --git a/netpbm-docfix.patch b/netpbm-docfix.patch
new file mode 100644
index 0000000..5ec7074
--- /dev/null
+++ b/netpbm-docfix.patch
@@ -0,0 +1,91 @@
+diff -up netpbm-10.35.58/converter/pbm/pbmtoepson.c.docfix netpbm-10.35.58/converter/pbm/pbmtoepson.c
+--- netpbm-10.35.58/converter/pbm/pbmtoepson.c.docfix 2009-01-19 09:24:03.000000000 +0100
++++ netpbm-10.35.58/converter/pbm/pbmtoepson.c 2009-04-15 09:10:52.000000000 +0200
+@@ -74,7 +74,7 @@ parseCommandLine(int arg
+ &dpiSpec, 0);
+ OPTENT3(0, "adjacent", OPT_FLAG, NULL,
+ &adjacentSpec, 0);
+- OPTENT3(0, "nonadjacent", OPT_FLAG, NULL,
++ OPTENT3(0, "noadjacent", OPT_FLAG, NULL,
+ &nonadjacentSpec, 0);
+
+ opt.opt_table = option_def;
+diff -up netpbm-10.35.58/userguide/cameratopam.html.docfix netpbm-10.35.58/userguide/cameratopam.html
+--- netpbm-10.35.58/userguide/cameratopam.html.docfix 2009-01-19 09:24:18.000000000 +0100
++++ netpbm-10.35.58/userguide/cameratopam.html 2009-04-15 09:16:16.000000000 +0200
+@@ -25,10 +25,10 @@ cameratopam - convert raw camera image t
+ [-balance_camera]
+ [-red_scale=float]
+ [-blue_scale=float]
+-[-brightness=fraction]
++[-bright=fraction]
+ [-no_clip_color]
+ [-rgb]
+-[-secondary]
++[-use_secondary]
+ [-linear]
+ [-verbose]
+
+@@ -106,7 +106,7 @@ the default.
+
Further adjust the color balance by multiplying the red and blue
+ channels by these values. Both default to 1.0.
+
+--brightness=float
++-bright=float
+
+ Change the output brightness. Default is 1.0.
+
+@@ -114,14 +114,14 @@ channels by these values. Both default
+
+ By default, cameratoapm clips all colors to prevent pink
+ hues in the highlights. Combine this option with
+--brightness=0.25 to leave the image data completely unclipped.
++-bright=0.25 to leave the image data completely unclipped.
+
+ -rgb
+
+ Write raw camera colors to the output file. By default,
+ cameratoapm converts to sRGB colorspace.
+
+--secondary
++-use_secondary
+
+ For cameras based on the Fuji Super CCD SR, this option causes
+ cameratopam to use the secondary sensors, in effect
+diff -up netpbm-10.35.58/userguide/fiascotopnm.html.docfix netpbm-10.35.58/userguide/fiascotopnm.html
+--- netpbm-10.35.58/userguide/fiascotopnm.html.docfix 2009-01-19 09:24:18.000000000 +0100
++++ netpbm-10.35.58/userguide/fiascotopnm.html 2009-04-15 09:10:52.000000000 +0200
+@@ -51,7 +51,7 @@ the output file(s) are written to the fi
+ this list. Otherwise, the current directory is used to store the
+ output file(s).
+
+--z, --fast
++-r, --fast
+
+ Decompress images in the 4:2:0 format; i.e., each chroma channel is
+ decompressed to an image of halved width and height. Use this option
+@@ -83,7 +83,7 @@ given amount N. N is 1 (mi
+ is 70. When N=0, then the smoothing amount specified in the
+ FIASCO file is used (defined by the FIASCO coder).
+
+--F N, --fps=N
++-F N, --framerate=N
+
+ Set number of frames per second to N. When using this option,
+ the frame rate specified in the FIASCO file is overridden.
+@@ -109,13 +109,9 @@ following methods (in the specified orde
+ --config=name
+
+
+--h, --info
++-h, --help
+
+-Print brief help, then exit.
+-
+--H, --help
+-
+-Print detailed help, then exit.
++Print help, then exit.
+
+
+
diff --git a/netpbm-ppmfadeusage.patch b/netpbm-ppmfadeusage.patch
new file mode 100644
index 0000000..92833e5
--- /dev/null
+++ b/netpbm-ppmfadeusage.patch
@@ -0,0 +1,60 @@
+diff -up netpbm-10.47.05/editor/ppmfade.ppmfadeusage netpbm-10.47.05/editor/ppmfade
+--- netpbm-10.47.05/editor/ppmfade.ppmfadeusage 2010-01-21 05:36:00.000000000 +0100
++++ netpbm-10.47.05/editor/ppmfade 2010-01-21 05:40:32.000000000 +0100
+@@ -34,6 +34,7 @@ my $base_name = "fade"; # default base
+ my $image = "ppm"; # default output storage format
+ my $mode = $SPREAD; # default fading mode
+
++sub usage();
+
+ my $n; # argument number
+
+@@ -44,7 +45,7 @@ for ($n = 0; $n < @ARGV; $n++) {
+ if (-e $first_file) {
+ } else {
+ print "I can't find first file '$first_file'\n";
+- exit 20;
++ exit 1;
+ }
+ } elsif ($ARGV[$n] eq "-l") {
+ $n++;
+@@ -52,7 +53,7 @@ for ($n = 0; $n < @ARGV; $n++) {
+ if (-e $last_file) {
+ } else {
+ print "I can't find last file '$last_file'\n";
+- exit 20;
++ exit 1;
+ }
+ } elsif ($ARGV[$n] eq "-base") {
+ $n++;
+@@ -77,7 +78,7 @@ for ($n = 0; $n < @ARGV; $n++) {
+ usage();
+ } else {
+ print "Unknown argument: $ARGV[$n]\n";
+- exit 100;
++ exit 1;
+ }
+ }
+ #
+@@ -96,18 +97,18 @@ if ($first_file ne "undefined") {
+ $width = $1; $height = $2;
+ } else {
+ print("Unrecognized results from pnmfile on $first_file.\n");
+- exit(50);
++ exit 1;
+ }
+ } elsif ($last_file ne "undefined") {
+ if ((`pnmfile $last_file` =~ m{\b(\d+)\sby\s(\d+)} )) {
+ $width = $1; $height = $2;
+ } else {
+ print("Unrecognized results from pnmfile on $first_file.\n");
+- exit(50);
++ exit 1;
+ }
+ } else {
+ print("ppmfade: You must specify -f or -l (or both)\n");
+- exit(90);
++ exit 1;
+ }
+
+ print("Frames are " . $width . "W x " . $height . "H\n");
diff --git a/netpbm.spec b/netpbm.spec
index deed72d..531c971 100644
--- a/netpbm.spec
+++ b/netpbm.spec
@@ -1,6 +1,6 @@
Summary: A library for handling different graphics file formats
Name: netpbm
-Version: 10.47.08
+Version: 10.47.09
Release: 1%{?dist}
# See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain
@@ -25,6 +25,8 @@ Patch11: netpbm-multilib.patch
Patch12: netpbm-pamscale.patch
Patch13: netpbm-glibc.patch
Patch14: netpbm-svgtopam.patch
+Patch15: netpbm-docfix.patch
+Patch16: netpbm-ppmfadeusage.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel
@@ -80,6 +82,8 @@ netpbm-progs. You'll also need to install the netpbm package.
%patch12 -p1 -b .pamscale
%patch13 -p1 -b .glibc
%patch14 -p1 -b .svgtopam
+%patch15 -p1 -b .docfix
+%patch16 -p1 -b .ppmfadeusage
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
@@ -208,6 +212,11 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/
%changelog
+* Mon Jan 25 2010 Jindrich Novy 10.47.09-1
+- update to 10.47.09, fixes occassional crash in pamtosvg
+- fix documentation
+- fix ppmfade exit status
+
* Wed Jan 13 2010 Jindrich Novy 10.47.08-1
- update to 10.47.08
diff --git a/sources b/sources
index 24eb879..2b63ef9 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-0b382883c1b93f5120da1eaca7b253f8 netpbm-10.47.08.tar.xz
+83225183f7bf589fc861721f28ad1bbb netpbm-10.47.09.tar.xz