- fix buffer overflow in pnmtofiasco

This commit is contained in:
Jindrich Novy 2010-01-27 10:45:52 +00:00
parent cdf609915c
commit a276486e28
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up netpbm-10.47.09/converter/other/fiasco/lib/image.h.fiasco-overflow netpbm-10.47.09/converter/other/fiasco/lib/image.h
--- netpbm-10.47.09/converter/other/fiasco/lib/image.h.fiasco-overflow 2010-01-25 09:00:48.000000000 +0100
+++ netpbm-10.47.09/converter/other/fiasco/lib/image.h 2010-01-27 10:29:48.000000000 +0100
@@ -29,7 +29,7 @@ typedef struct image
* Image data
*/
{
- char id [7];
+ char id [8];
unsigned reference_count;
unsigned width; /* Width of the image */
unsigned height; /* Height of the image */

View File

@ -1,7 +1,7 @@
Summary: A library for handling different graphics file formats Summary: A library for handling different graphics file formats
Name: netpbm Name: netpbm
Version: 10.47.09 Version: 10.47.09
Release: 1%{?dist} Release: 2%{?dist}
# See copyright_summary for details # See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain License: BSD and GPLv2 and IJG and MIT and Public Domain
Group: System Environment/Libraries Group: System Environment/Libraries
@ -27,6 +27,7 @@ Patch13: netpbm-glibc.patch
Patch14: netpbm-svgtopam.patch Patch14: netpbm-svgtopam.patch
Patch15: netpbm-docfix.patch Patch15: netpbm-docfix.patch
Patch16: netpbm-ppmfadeusage.patch Patch16: netpbm-ppmfadeusage.patch
Patch17: netpbm-fiasco-overflow.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel BuildRequires: libX11-devel, python, jasper-devel
@ -84,6 +85,7 @@ netpbm-progs. You'll also need to install the netpbm package.
%patch14 -p1 -b .svgtopam %patch14 -p1 -b .svgtopam
%patch15 -p1 -b .docfix %patch15 -p1 -b .docfix
%patch16 -p1 -b .ppmfadeusage %patch16 -p1 -b .ppmfadeusage
%patch17 -p1 -b .fiasco-overflow
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
@ -212,6 +214,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/ %{_datadir}/netpbm/
%changelog %changelog
* Wed Jan 27 2010 Jindrich Novy <jnovy@redhat.com> 10.47.09-2
- fix buffer overflow in pnmtofiasco
* Mon Jan 25 2010 Jindrich Novy <jnovy@redhat.com> 10.47.09-1 * Mon Jan 25 2010 Jindrich Novy <jnovy@redhat.com> 10.47.09-1
- update to 10.47.09, fixes occassional crash in pamtosvg - update to 10.47.09, fixes occassional crash in pamtosvg
- fix documentation - fix documentation