Resolves: #1700164 - enable MPEG support
This commit is contained in:
parent
5ad902a1cb
commit
11ddd979a6
@ -1,13 +0,0 @@
|
||||
diff --git a/converter/ppm/Makefile b/converter/ppm/Makefile
|
||||
index b97349d..f68170f 100644
|
||||
--- a/converter/ppm/Makefile
|
||||
+++ b/converter/ppm/Makefile
|
||||
@@ -7,7 +7,7 @@ VPATH=.:$(SRCDIR)/$(SUBDIR)
|
||||
|
||||
include $(BUILDDIR)/config.mk
|
||||
|
||||
-SUBDIRS = hpcdtoppm ppmtompeg
|
||||
+SUBDIRS = hpcdtoppm
|
||||
|
||||
PORTBINARIES = 411toppm eyuvtoppm gouldtoppm ilbmtoppm imgtoppm \
|
||||
leaftoppm mtvtoppm neotoppm \
|
44
netpbm.spec
44
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.86.00
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -10,30 +10,28 @@ URL: http://netpbm.sourceforge.net/
|
||||
# svn checkout https://svn.code.sf.net/p/netpbm/code/userguide netpbm-%%{version}/userguide
|
||||
# svn checkout https://svn.code.sf.net/p/netpbm/code/trunk/test netpbm-%%{version}/test
|
||||
# and removing the .svn directories ( find -name "\.svn" -type d -print0 | xargs -0 rm -rf )
|
||||
# and removing the ppmtompeg code, due to patents ( rm -rf netpbm-%%{version}/converter/ppm/ppmtompeg/ )
|
||||
Source0: netpbm-%{version}.tar.xz
|
||||
Patch0: netpbm-security-scripts.patch
|
||||
Patch1: netpbm-security-code.patch
|
||||
Patch2: netpbm-ppmfadeusage.patch
|
||||
Patch3: netpbm-noppmtompeg.patch
|
||||
Patch4: netpbm-CVE-2017-2587.patch
|
||||
Patch5: netpbm-python3.patch
|
||||
Patch6: netpbm-time.patch
|
||||
Patch7: netpbm-gcc4.patch
|
||||
Patch8: netpbm-bmptopnm.patch
|
||||
Patch9: netpbm-CAN-2005-2471.patch
|
||||
Patch10: netpbm-xwdfix.patch
|
||||
Patch11: netpbm-multilib.patch
|
||||
Patch12: netpbm-glibc.patch
|
||||
Patch13: netpbm-docfix.patch
|
||||
Patch14: netpbm-fiasco-overflow.patch
|
||||
Patch15: netpbm-cmuwtopbm.patch
|
||||
Patch16: netpbm-pamtojpeg2k.patch
|
||||
Patch17: netpbm-manfix.patch
|
||||
Patch18: netpbm-manual-pages.patch
|
||||
Patch19: netpbm-jasper.patch
|
||||
Patch20: netpbm-userguide.patch
|
||||
Patch21: netpbm-libdir-so.patch
|
||||
Patch3: netpbm-CVE-2017-2587.patch
|
||||
Patch4: netpbm-python3.patch
|
||||
Patch5: netpbm-time.patch
|
||||
Patch6: netpbm-gcc4.patch
|
||||
Patch7: netpbm-bmptopnm.patch
|
||||
Patch8: netpbm-CAN-2005-2471.patch
|
||||
Patch9: netpbm-xwdfix.patch
|
||||
Patch10: netpbm-multilib.patch
|
||||
Patch11: netpbm-glibc.patch
|
||||
Patch12: netpbm-docfix.patch
|
||||
Patch13: netpbm-fiasco-overflow.patch
|
||||
Patch14: netpbm-cmuwtopbm.patch
|
||||
Patch15: netpbm-pamtojpeg2k.patch
|
||||
Patch16: netpbm-manfix.patch
|
||||
Patch17: netpbm-manual-pages.patch
|
||||
Patch18: netpbm-jasper.patch
|
||||
Patch19: netpbm-userguide.patch
|
||||
Patch20: netpbm-libdir-so.patch
|
||||
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
||||
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
|
||||
@ -138,7 +136,6 @@ make \
|
||||
# prepare man files
|
||||
cd userguide
|
||||
# BZ 948531
|
||||
rm -f ppmtompeg*
|
||||
rm -f *.manual-pages
|
||||
rm -f *.manfix
|
||||
for i in *.html ; do
|
||||
@ -231,6 +228,9 @@ popd
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Wed Apr 17 2019 Josef Ridky <jridky@redhat.com> - 10.86.00-2
|
||||
- Enable MPEG and MPEG-2 support (#1700164)
|
||||
|
||||
* Mon Apr 01 2019 Josef Ridky <jridky@redhat.com> - 10.86.00-1
|
||||
- New upstream release (#1694351)
|
||||
|
||||
|
@ -5,7 +5,6 @@
|
||||
# svn checkout https://svn.code.sf.net/p/netpbm/code/userguide netpbm-%{version}/userguide
|
||||
# svn checkout https://svn.code.sf.net/p/netpbm/code/trunk/test netpbm-%{version}/test
|
||||
# and removing the .svn directories ( find -name "\.svn" -type d -print0 | xargs -0 rm -rf )
|
||||
# and removing the ppmtompeg code, due to patents ( rm -rf netpbm-%{version}/converter/ppm/ppmtompeg/ )
|
||||
|
||||
VERSION=$1
|
||||
if [[ -z $VERSION ]]; then
|
||||
@ -21,7 +20,6 @@ svn checkout https://svn.code.sf.net/p/netpbm/code/advanced $NETPBM_NAME
|
||||
svn checkout https://svn.code.sf.net/p/netpbm/code/userguide $NETPBM_NAME/userguide
|
||||
svn checkout https://svn.code.sf.net/p/netpbm/code/trunk/test $NETPBM_NAME/test
|
||||
find -name '\.svn' -type d -print0 | xargs -0 rm -rf
|
||||
rm -rf $NETPBM_NAME/converter/ppm/ppmtompeg/
|
||||
tar -cJvf $NETPBM_NAME.tar.xz $NETPBM_NAME
|
||||
rm -rf $NETPBM_NAME/
|
||||
popd
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (netpbm-10.86.00.tar.xz) = 2f268256cd3da6af988dd75b2c471993ae6f98be32bf62da8b4441d8522ab67ecbdced9b80d7013cc965350e9dcb0af05220954fc8428677369d79f60b080a79
|
||||
SHA512 (netpbm-10.86.00.tar.xz) = 8866d4df8678c4f860a79e48cd8a2bb4721e0b45ade5fe2af2c20debbbafd8fb486b8f3c65de61e061bfc6112c2bfeffa6ed6530b9c15854be91f2aa01f0c62f
|
||||
|
Loading…
Reference in New Issue
Block a user