New upstram release 10.86.00
This commit is contained in:
parent
4c6e5b409d
commit
5ad902a1cb
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@
|
||||
/netpbm-10.82.00.tar.xz
|
||||
/netpbm-10.83.01.tar.xz
|
||||
/netpbm-10.84.03.tar.xz
|
||||
/netpbm-10.86.00.tar.xz
|
||||
|
@ -1,7 +1,8 @@
|
||||
diff -urNp a/converter/other/pstopnm.c b/converter/other/pstopnm.c
|
||||
--- a/converter/other/pstopnm.c 2018-07-23 15:14:51.200658026 +0200
|
||||
+++ b/converter/other/pstopnm.c 2018-07-23 15:18:12.579910612 +0200
|
||||
@@ -896,11 +896,11 @@ execGhostscript(int const
|
||||
diff --git a/converter/other/pstopnm.c b/converter/other/pstopnm.c
|
||||
index f534265..2ab48ab 100644
|
||||
--- a/converter/other/pstopnm.c
|
||||
+++ b/converter/other/pstopnm.c
|
||||
@@ -896,11 +896,11 @@ execGhostscript(int const inputPipeFd,
|
||||
ghostscriptProg, arg0,
|
||||
deviceopt, outfileopt, gopt, ropt, textalphabitsopt,
|
||||
"-q", "-dNOPAUSE",
|
||||
@ -9,8 +10,9 @@ diff -urNp a/converter/other/pstopnm.c b/converter/other/pstopnm.c
|
||||
+ "-dPARANOIDSAFER", "-");
|
||||
}
|
||||
|
||||
execl(ghostscriptProg, arg0, deviceopt, outfileopt, gopt, ropt, "-q",
|
||||
- "-dNOPAUSE", "-dSAFER", "-", NULL);
|
||||
- execl(ghostscriptProg, arg0, deviceopt, outfileopt, gopt, ropt,
|
||||
- textalphabitsopt, "-q", "-dNOPAUSE", "-dSAFER", "-", NULL);
|
||||
+ execl(ghostscriptProg, arg0, deviceopt, outfileopt, gopt, ropt, "-q",
|
||||
+ "-dNOPAUSE", "-dPARANOIDSAFER", "-", NULL);
|
||||
|
||||
pm_error("execl() of Ghostscript ('%s') failed, errno=%d (%s)",
|
||||
|
@ -1,7 +1,9 @@
|
||||
--- netpbm-10.35/converter/other/bmptopnm.c.bmptopnm 2007-01-29 13:08:46.000000000 +0100
|
||||
+++ netpbm-10.35/converter/other/bmptopnm.c 2007-01-29 13:32:21.000000000 +0100
|
||||
@@ -1262,7 +1262,7 @@ readBmp(FILE * const ifP,
|
||||
xel ** const colormapP,
|
||||
diff --git a/converter/other/bmptopnm.c b/converter/other/bmptopnm.c
|
||||
index 3f66634..ca4f944 100644
|
||||
--- a/converter/other/bmptopnm.c
|
||||
+++ b/converter/other/bmptopnm.c
|
||||
@@ -1494,7 +1494,7 @@ readBmp(FILE * const ifP,
|
||||
unsigned int * const cmapSizeP,
|
||||
bool const verbose) {
|
||||
|
||||
- xel * colormap; /* malloc'ed */
|
||||
|
@ -1,33 +1,34 @@
|
||||
diff -Naur netpbm-10.84.03.orig/lib/Makefile netpbm-10.84.03/lib/Makefile
|
||||
--- netpbm-10.84.03.orig/lib/Makefile 2018-11-23 10:36:41.000000000 +0100
|
||||
+++ netpbm-10.84.03/lib/Makefile 2019-02-12 08:22:24.188229574 +0100
|
||||
@@ -221,7 +221,7 @@
|
||||
diff --git a/lib/Makefile b/lib/Makefile
|
||||
index bc758df..7f51b41 100644
|
||||
--- a/lib/Makefile
|
||||
+++ b/lib/Makefile
|
||||
@@ -221,7 +221,7 @@ libpm.o: compile.h
|
||||
.PHONY: install.lib
|
||||
ifeq ($(NETPBMLIBTYPE),unixshared)
|
||||
# install a Unix-style shared library
|
||||
-install.lib: $(PKGDIR)/lib $(PKGDIR)/link
|
||||
-install.lib: $(PKGDIR)/lib $(PKGDIR)/sharedlink
|
||||
+install.lib: $(PKGDIR)/lib
|
||||
cd $(PKGDIR)/lib ; rm -f libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).*
|
||||
$(INSTALL) -c -m $(INSTALL_PERM_LIBD) \
|
||||
libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN) $(PKGDIR)/lib/
|
||||
@@ -263,19 +263,19 @@
|
||||
@@ -263,27 +263,26 @@ $(INTERFACE_HEADERS:%=%_installhdr): $(PKGDIR)/include/netpbm
|
||||
$(SRCDIR)/lib/$(@:%_installhdr=%) $(PKGDIR)/include/netpbm/
|
||||
|
||||
.PHONY: install.staticlib
|
||||
-install.staticlib: $(PKGDIR)/link
|
||||
-install.staticlib: $(PKGDIR)/staticlink
|
||||
+install.staticlib: $(PKGDIR)/lib
|
||||
$(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.$(STATICLIBSUFFIX) \
|
||||
- $(PKGDIR)/link
|
||||
- $(PKGDIR)/staticlink
|
||||
+ $(PKGDIR)/lib
|
||||
|
||||
# Install a shared library stub -- the ".so" file used at link time to
|
||||
# prepare a program for dynamically linking a library at run time
|
||||
.PHONY: install.sharedlibstub
|
||||
-install.sharedlibstub: $(PKGDIR)/link
|
||||
-install.sharedlibstub: $(PKGDIR)/sharedlink
|
||||
+install.sharedlibstub: $(PKGDIR)/lib
|
||||
ifeq ($(NETPBMLIBTYPE),unixshared)
|
||||
# install the link-time (.so) links to the runtime libraries
|
||||
- cd $(PKGDIR)/link ; \
|
||||
- cd $(PKGDIR)/sharedlink ; \
|
||||
+ cd $(PKGDIR)/lib ; \
|
||||
rm -f libnetpbm.$(NETPBMLIBSUFFIX); \
|
||||
- $(SYMLINK) ../lib/libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
|
||||
@ -35,3 +36,13 @@ diff -Naur netpbm-10.84.03.orig/lib/Makefile netpbm-10.84.03/lib/Makefile
|
||||
libnetpbm.$(NETPBMLIBSUFFIX)
|
||||
endif
|
||||
ifeq ($(NETPBMLIBTYPE),dll)
|
||||
- $(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.dll.a \
|
||||
- $(PKGDIR)/sharedlink
|
||||
+ $(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.dll.a $(PKGDIR)/link
|
||||
endif
|
||||
ifeq ($(NETPBMLIBTYPE),dylib)
|
||||
- cd $(PKGDIR)/sharedlink/ ; \
|
||||
+ cd $(PKGDIR)/link/ ; \
|
||||
rm -f libnetpbm.dylib; \
|
||||
$(SYMLINK) ../lib/libnetpbm.$(MAJ).$(MIN).dylib libnetpbm.dylib
|
||||
endif
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -urNp old/userguide/libnetpbm_ug.html new/userguide/libnetpbm_ug.html
|
||||
--- old/userguide/libnetpbm_ug.html 2017-09-05 14:20:09.734743404 +0200
|
||||
+++ new/userguide/libnetpbm_ug.html 2017-09-05 14:47:30.496705483 +0200
|
||||
diff --git a/userguide/libnetpbm_ug.html b/userguide/libnetpbm_ug.html
|
||||
index 94d4fd4..bb1c77e 100644
|
||||
--- a/userguide/libnetpbm_ug.html
|
||||
+++ b/userguide/libnetpbm_ug.html
|
||||
@@ -374,7 +374,7 @@ plain format.
|
||||
<H2 id="reference">Reference</h2>
|
||||
|
||||
@ -10,9 +11,10 @@ diff -urNp old/userguide/libnetpbm_ug.html new/userguide/libnetpbm_ug.html
|
||||
processing image data.
|
||||
|
||||
<p>The <a href="libpm.html">Libnetpbm Utility Manual</a>
|
||||
diff -urNp old/userguide/pamfunc.html new/userguide/pamfunc.html
|
||||
--- old/userguide/pamfunc.html 2017-09-05 14:20:09.738743398 +0200
|
||||
+++ new/userguide/pamfunc.html 2017-09-05 14:47:41.760644848 +0200
|
||||
diff --git a/userguide/pamfunc.html b/userguide/pamfunc.html
|
||||
index d158393..e0fe96a 100644
|
||||
--- a/userguide/pamfunc.html
|
||||
+++ b/userguide/pamfunc.html
|
||||
@@ -57,7 +57,7 @@ output image.
|
||||
and bit string (such as and with 01001000). For the arithmetic functions, the
|
||||
function arguments and results are the fraction that a sample is of the
|
||||
@ -22,21 +24,10 @@ diff -urNp old/userguide/pamfunc.html new/userguide/pamfunc.html
|
||||
the sample value, and the maxval indicates the width of the bit string.
|
||||
|
||||
<h4>Arithmetic functions</h4>
|
||||
diff -urNp old/userguide/pbmtextps.html new/userguide/pbmtextps.html
|
||||
--- old/userguide/pbmtextps.html 2017-09-05 14:20:09.736743401 +0200
|
||||
+++ new/userguide/pbmtextps.html 2017-09-05 14:47:58.840553598 +0200
|
||||
@@ -185,7 +185,7 @@ edge of the type. See <a href="#margins
|
||||
<dt><b>-ascent=</b><i>n</i>
|
||||
<dt><b>-descent=</b><i>n</i>
|
||||
<dd>
|
||||
-These options control the the margins added to the image, measured from
|
||||
+These options control the margins added to the image, measured from
|
||||
the text baseline. See <a href="#margins">Margins</a> for details.
|
||||
|
||||
<p>Sizes are in points, as a floating point number.
|
||||
diff -urNp old/userguide/pbmtog3.html new/userguide/pbmtog3.html
|
||||
--- old/userguide/pbmtog3.html 2017-09-05 14:20:09.735743403 +0200
|
||||
+++ new/userguide/pbmtog3.html 2017-09-05 14:48:55.648255793 +0200
|
||||
diff --git a/userguide/pbmtog3.html b/userguide/pbmtog3.html
|
||||
index ee2bd6b..3b23517 100644
|
||||
--- a/userguide/pbmtog3.html
|
||||
+++ b/userguide/pbmtog3.html
|
||||
@@ -77,7 +77,7 @@ You cannot specify both.
|
||||
<H2 id="history">HISTORY</H2>
|
||||
|
||||
@ -46,9 +37,11 @@ diff -urNp old/userguide/pbmtog3.html new/userguide/pbmtog3.html
|
||||
<<A HREF="mailto:paul@manray.sgi.com">paul@manray.sgi.com</A>> in 1989
|
||||
and then modified extensively by others.
|
||||
|
||||
diff -urNp old/userguide/ppmtompeg.html new/userguide/ppmtompeg.html
|
||||
--- old/userguide/ppmtompeg.html 2017-09-05 14:20:09.739743396 +0200
|
||||
+++ new/userguide/ppmtompeg.html 1970-01-01 01:00:00.000000000 +0100
|
||||
diff --git a/userguide/ppmtompeg.html b/userguide/ppmtompeg.html
|
||||
deleted file mode 100644
|
||||
index a1ce767..0000000
|
||||
--- a/userguide/ppmtompeg.html
|
||||
+++ /dev/null
|
||||
@@ -1,1291 +0,0 @@
|
||||
-<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
|
||||
-<HTML>
|
||||
|
@ -1,11 +1,238 @@
|
||||
diff -up netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c.pamtojpeg2kfix netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c
|
||||
--- netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c.pamtojpeg2kfix 2010-04-27 15:47:10.000000000 +0200
|
||||
+++ netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c 2010-05-03 15:37:49.934269588 +0200
|
||||
@@ -518,7 +518,5 @@ main(int argc, char **argv)
|
||||
diff --git a/converter/other/jpeg2000/pamtojpeg2k.c b/converter/other/jpeg2000/pamtojpeg2k.c
|
||||
index 4d73316..a53573f 100644
|
||||
--- a/converter/other/jpeg2000/pamtojpeg2k.c
|
||||
+++ b/converter/other/jpeg2000/pamtojpeg2k.c
|
||||
@@ -98,7 +98,7 @@ parseCommandLine(int argc, char ** argv,
|
||||
char * modeOpt;
|
||||
|
||||
unsigned int option_def_index;
|
||||
-
|
||||
+
|
||||
MALLOCARRAY_NOFAIL(option_def, 100);
|
||||
|
||||
option_def_index = 0; /* incremented by OPTENTRY */
|
||||
@@ -134,25 +134,25 @@ parseCommandLine(int argc, char ** argv,
|
||||
&numrlvlsSpec, 0);
|
||||
OPTENT3(0, "numgbits", OPT_UINT, &cmdlineP->numgbits,
|
||||
&numgbitsSpec, 0);
|
||||
- OPTENT3(0, "nomct", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "nomct", OPT_FLAG, NULL,
|
||||
&cmdlineP->nomct, 0);
|
||||
- OPTENT3(0, "sop", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "sop", OPT_FLAG, NULL,
|
||||
&cmdlineP->sop, 0);
|
||||
- OPTENT3(0, "eph", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "eph", OPT_FLAG, NULL,
|
||||
&cmdlineP->eph, 0);
|
||||
- OPTENT3(0, "lazy", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "lazy", OPT_FLAG, NULL,
|
||||
&cmdlineP->lazy, 0);
|
||||
- OPTENT3(0, "termall", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "termall", OPT_FLAG, NULL,
|
||||
&cmdlineP->termall, 0);
|
||||
- OPTENT3(0, "segsym", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "segsym", OPT_FLAG, NULL,
|
||||
&cmdlineP->segsym, 0);
|
||||
- OPTENT3(0, "vcausal", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "vcausal", OPT_FLAG, NULL,
|
||||
&cmdlineP->vcausal, 0);
|
||||
- OPTENT3(0, "pterm", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "pterm", OPT_FLAG, NULL,
|
||||
&cmdlineP->pterm, 0);
|
||||
- OPTENT3(0, "resetprob", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "resetprob", OPT_FLAG, NULL,
|
||||
&cmdlineP->resetprob, 0);
|
||||
- OPTENT3(0, "verbose", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "verbose", OPT_FLAG, NULL,
|
||||
&cmdlineP->verbose, 0);
|
||||
OPTENT3(0, "debuglevel", OPT_UINT, &cmdlineP->debuglevel,
|
||||
&debuglevelSpec, 0);
|
||||
@@ -223,7 +223,7 @@ parseCommandLine(int argc, char ** argv,
|
||||
cmdlineP->inputFilename = strdup("-"); /* he wants stdin */
|
||||
else if (argc - 1 == 1)
|
||||
cmdlineP->inputFilename = strdup(argv[1]);
|
||||
- else
|
||||
+ else
|
||||
pm_error("Too many arguments. The only argument accepted\n"
|
||||
"is the input file specification");
|
||||
|
||||
@@ -232,7 +232,7 @@ parseCommandLine(int argc, char ** argv,
|
||||
|
||||
|
||||
static void
|
||||
-createJasperRaster(struct pam * const inpamP,
|
||||
+createJasperRaster(struct pam * const inpamP,
|
||||
jas_image_t * const jasperP) {
|
||||
/*----------------------------------------------------------------------------
|
||||
Create the raster in the *jasperP object, reading the raster from the
|
||||
@@ -254,7 +254,7 @@ createJasperRaster(struct pam * const inpamP,
|
||||
if (matrix[plane] == NULL)
|
||||
pm_error("Unable to create matrix for plane %u. "
|
||||
"jas_matrix_create() failed.", plane);
|
||||
- }
|
||||
+ }
|
||||
tuplerow = pnm_allocpamrow(inpamP);
|
||||
|
||||
jasperMaxval = pm_bitstomaxval(pm_maxvaltobits(inpamP->maxval));
|
||||
@@ -271,7 +271,7 @@ createJasperRaster(struct pam * const inpamP,
|
||||
unsigned int jasperSample;
|
||||
|
||||
if (oddMaxval)
|
||||
- jasperSample = tuplerow[col][plane] *
|
||||
+ jasperSample = tuplerow[col][plane] *
|
||||
jasperMaxval / inpamP->maxval;
|
||||
else
|
||||
jasperSample = tuplerow[col][plane];
|
||||
@@ -279,16 +279,16 @@ createJasperRaster(struct pam * const inpamP,
|
||||
jas_matrix_set(matrix[plane], 0, col, jasperSample);
|
||||
}
|
||||
}
|
||||
- {
|
||||
+ {
|
||||
unsigned int plane;
|
||||
|
||||
for (plane = 0; plane < inpamP->depth; ++plane) {
|
||||
int rc;
|
||||
- rc = jas_image_writecmpt(jasperP, plane, 0, row,
|
||||
+ rc = jas_image_writecmpt(jasperP, plane, 0, row,
|
||||
inpamP->width, 1,
|
||||
matrix[plane]);
|
||||
if (rc != 0)
|
||||
- pm_error("jas_image_writecmpt() of plane %u failed.",
|
||||
+ pm_error("jas_image_writecmpt() of plane %u failed.",
|
||||
plane);
|
||||
}
|
||||
}
|
||||
@@ -297,14 +297,14 @@ createJasperRaster(struct pam * const inpamP,
|
||||
pnm_freepamrow(tuplerow);
|
||||
for (plane = 0; plane < inpamP->depth; ++plane)
|
||||
jas_matrix_destroy(matrix[plane]);
|
||||
-
|
||||
+
|
||||
free(matrix);
|
||||
}
|
||||
|
||||
|
||||
|
||||
static void
|
||||
-createJasperImage(struct pam * const inpamP,
|
||||
+createJasperImage(struct pam * const inpamP,
|
||||
jas_image_t ** const jasperPP) {
|
||||
|
||||
jas_image_cmptparm_t * cmptparms;
|
||||
@@ -322,7 +322,7 @@ createJasperImage(struct pam * const inpamP,
|
||||
cmptparms[plane].prec = pm_maxvaltobits(inpamP->maxval);
|
||||
cmptparms[plane].sgnd = 0;
|
||||
}
|
||||
- *jasperPP =
|
||||
+ *jasperPP =
|
||||
jas_image_create(inpamP->depth, cmptparms, JAS_CLRSPC_UNKNOWN);
|
||||
if (*jasperPP == NULL)
|
||||
pm_error("Unable to create jasper image structure. "
|
||||
@@ -371,7 +371,7 @@ convertToJasperImage(struct pam * const inpamP,
|
||||
|
||||
|
||||
static void
|
||||
-writeJpc(jas_image_t * const jasperP,
|
||||
+writeJpc(jas_image_t * const jasperP,
|
||||
struct cmdlineInfo const cmdline,
|
||||
FILE * const ofP) {
|
||||
|
||||
@@ -383,8 +383,8 @@ writeJpc(jas_image_t * const jasperP,
|
||||
|
||||
/* Note: ilyrrates is a hack because we're too lazy to properly parse
|
||||
command line options to get the information and then compose
|
||||
- a proper input to Jasper. So the user can screw things up by
|
||||
- specifying garbage for the -ilyrrates option
|
||||
+ a proper input to Jasper. So the user can screw things up by
|
||||
+ specifying garbage for the -ilyrrates option
|
||||
*/
|
||||
if (strlen(cmdline.ilyrrates) > 0)
|
||||
pm_asprintf(&ilyrratesOpt, "ilyrrates=%s", cmdline.ilyrrates);
|
||||
@@ -410,7 +410,7 @@ writeJpc(jas_image_t * const jasperP,
|
||||
*/
|
||||
rateOpt[0] = '\0';
|
||||
}
|
||||
- pm_asprintf(&options,
|
||||
+ pm_asprintf(&options,
|
||||
"imgareatlx=%u "
|
||||
"imgareatly=%u "
|
||||
"tilegrdtlx=%u "
|
||||
@@ -428,7 +428,7 @@ writeJpc(jas_image_t * const jasperP,
|
||||
"numrlvls=%u "
|
||||
"numgbits=%u "
|
||||
"%s %s %s %s %s %s %s %s %s",
|
||||
-
|
||||
+
|
||||
cmdline.imgareatlx,
|
||||
cmdline.imgareatly,
|
||||
cmdline.tilegrdtlx,
|
||||
@@ -471,8 +471,8 @@ writeJpc(jas_image_t * const jasperP,
|
||||
pm_message("Using Jasper to encode to 'jpc' format with options "
|
||||
"'%s'", options);
|
||||
|
||||
- rc = jas_image_encode(jasperP, outStreamP,
|
||||
- jas_image_strtofmt((char*)"jpc"),
|
||||
+ rc = jas_image_encode(jasperP, outStreamP,
|
||||
+ jas_image_strtofmt((char*)"jpc"),
|
||||
(char *)options);
|
||||
if (rc != 0)
|
||||
pm_error("jas_image_encode() failed to encode the JPEG 2000 "
|
||||
@@ -484,11 +484,11 @@ writeJpc(jas_image_t * const jasperP,
|
||||
int rc;
|
||||
|
||||
rc = jas_stream_close(outStreamP);
|
||||
-
|
||||
+
|
||||
if (rc != 0)
|
||||
pm_error("Failed to close output stream, "
|
||||
"jas_stream_close() rc = %d", rc);
|
||||
- }
|
||||
+ }
|
||||
|
||||
jas_image_clearfmts();
|
||||
|
||||
@@ -506,33 +506,31 @@ main(int argc, char **argv)
|
||||
jas_image_t * jasperP;
|
||||
|
||||
pnm_init(&argc, argv);
|
||||
-
|
||||
+
|
||||
parseCommandLine(argc, argv, &cmdline);
|
||||
-
|
||||
- {
|
||||
+
|
||||
+ {
|
||||
int rc;
|
||||
-
|
||||
+
|
||||
rc = jas_init();
|
||||
if ( rc != 0 )
|
||||
pm_error("Failed to initialize Jasper library. "
|
||||
"jas_init() returns rc %d", rc );
|
||||
}
|
||||
-
|
||||
+
|
||||
jas_setdbglevel(cmdline.debuglevel);
|
||||
-
|
||||
+
|
||||
ifP = pm_openr(cmdline.inputFilename);
|
||||
-
|
||||
+
|
||||
pnm_readpaminit(ifP, &inpam, PAM_STRUCT_SIZE(tuple_type));
|
||||
-
|
||||
+
|
||||
convertToJasperImage(&inpam, &jasperP);
|
||||
-
|
||||
+
|
||||
writeJpc(jasperP, cmdline, stdout);
|
||||
-
|
||||
+
|
||||
jas_image_destroy(jasperP);
|
||||
|
||||
pm_close(ifP);
|
||||
|
||||
- pm_close(stdout);
|
||||
-
|
||||
-
|
||||
return 0;
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,17 +1,9 @@
|
||||
diff -urNp a/userguide/pammixmulti.html b/userguide/pammixmulti.html
|
||||
--- a/userguide/pammixmulti.html 2018-11-23 11:20:28.471419187 +0100
|
||||
+++ b/userguide/pammixmulti.html 2018-11-23 11:24:19.488085440 +0100
|
||||
diff --git a/userguide/pammixmulti.html b/userguide/pammixmulti.html
|
||||
index c5854c3..a18fa14 100755
|
||||
--- a/userguide/pammixmulti.html
|
||||
+++ b/userguide/pammixmulti.html
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0"?>
|
||||
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN">
|
||||
<html>
|
||||
<head>
|
||||
@@ -6,7 +5,7 @@
|
||||
<meta http-equiv="content-type" content="text/html; charset=utf-8">
|
||||
</head>
|
||||
<body>
|
||||
-<h1 id="pammixmulti">pammixmulti</h1>
|
||||
+<h1>pammixmulti</h1>
|
||||
|
||||
Updated: 18 November 2018<br />
|
||||
<a href="#index">Table Of Contents</a>
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.84.03
|
||||
Release: 3%{?dist}
|
||||
Version: 10.86.00
|
||||
Release: 1%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -231,6 +231,9 @@ popd
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Mon Apr 01 2019 Josef Ridky <jridky@redhat.com> - 10.86.00-1
|
||||
- New upstream release (#1694351)
|
||||
|
||||
* Tue Feb 12 2019 Ralf Corsépius <corsepiu@fedoraproject.org> - 10.84.03-3
|
||||
- Package %%{_libdir}/*.so (RHBZ#1676370).
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (netpbm-10.84.03.tar.xz) = 400712274c5e04fa81ae593052a4f08cbe51e5c9437fef0d40d4f4586c9db2b406f7b5fe7a20ec714a8ea31b19de861842d2fb0989f0c4ef625cfaa145f87952
|
||||
SHA512 (netpbm-10.86.00.tar.xz) = 2f268256cd3da6af988dd75b2c471993ae6f98be32bf62da8b4441d8522ab67ecbdced9b80d7013cc965350e9dcb0af05220954fc8428677369d79f60b080a79
|
||||
|
Loading…
Reference in New Issue
Block a user