146 lines
5.3 KiB
Diff
146 lines
5.3 KiB
Diff
--- net-snmp-5.4/configure.libdir.fix 2007-02-26 12:25:08.000000000 +0100
|
|
+++ net-snmp-5.4/configure.libdir 2007-02-26 12:28:03.000000000 +0100
|
|
@@ -27039,7 +27039,7 @@
|
|
if test "$with_libwrap" != "no"; then
|
|
if test "$with_libwrap" != "yes"; then
|
|
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
|
|
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
|
|
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
|
|
fi
|
|
|
|
_libs=${LIBS}
|
|
@@ -27242,7 +27242,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -27470,7 +27470,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
--- net-snmp-5.4/configure.mnttab.fix 2006-11-24 18:56:15.000000000 +0100
|
|
+++ net-snmp-5.4/configure.mnttab 2007-02-26 12:28:14.000000000 +0100
|
|
@@ -27047,7 +27047,7 @@
|
|
if test "$with_libwrap" != "no"; then
|
|
if test "$with_libwrap" != "yes"; then
|
|
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
|
|
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
|
|
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
|
|
fi
|
|
|
|
_libs=${LIBS}
|
|
@@ -27250,7 +27250,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -27478,7 +27478,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
--- net-snmp-5.4/configure.fix 2007-02-26 12:25:08.000000000 +0100
|
|
+++ net-snmp-5.4/configure 2007-02-26 12:27:24.000000000 +0100
|
|
@@ -27039,7 +27039,7 @@
|
|
if test "$with_libwrap" != "no"; then
|
|
if test "$with_libwrap" != "yes"; then
|
|
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
|
|
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
|
|
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
|
|
fi
|
|
|
|
_libs=${LIBS}
|
|
@@ -27242,7 +27242,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -27470,7 +27470,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
--- net-snmp-5.4/configure.in.fix 2006-11-24 18:53:18.000000000 +0100
|
|
+++ net-snmp-5.4/configure.in 2007-02-26 12:27:50.000000000 +0100
|
|
@@ -2683,7 +2683,7 @@
|
|
if test "$with_libwrap" != "no"; then
|
|
if test "$with_libwrap" != "yes"; then
|
|
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
|
|
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
|
|
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
|
|
fi
|
|
|
|
_libs=${LIBS}
|
|
@@ -2700,7 +2700,7 @@
|
|
|
|
AC_MSG_RESULT([yes])
|
|
AC_DEFINE(NETSNMP_USE_LIBWRAP)
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap"],
|
|
[
|
|
AC_MSG_RESULT([no])
|
|
@@ -2716,7 +2716,7 @@
|
|
|
|
AC_MSG_RESULT(yes)
|
|
AC_DEFINE(NETSNMP_USE_LIBWRAP)
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap -lnsl",
|
|
|
|
AC_MSG_RESULT(no)
|
|
--- net-snmp-5.4/configure.ethtool-config.fix 2007-02-26 12:25:08.000000000 +0100
|
|
+++ net-snmp-5.4/configure.ethtool-config 2007-02-26 12:27:38.000000000 +0100
|
|
@@ -27039,7 +27039,7 @@
|
|
if test "$with_libwrap" != "no"; then
|
|
if test "$with_libwrap" != "yes"; then
|
|
CPPFLAGS="${CPPFLAGS} -I$with_libwrap/include"
|
|
- LDFLAGS="${LDFLAGS} -L$with_libwrap/lib"
|
|
+ LDFLAGS="${LDFLAGS} -L$with_libwrap"
|
|
fi
|
|
|
|
_libs=${LIBS}
|
|
@@ -27242,7 +27242,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|
|
@@ -27470,7 +27470,7 @@
|
|
#define NETSNMP_USE_LIBWRAP 1
|
|
_ACEOF
|
|
|
|
- test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap/lib"
|
|
+ test "$with_libwrap" != no -a "$with_libwrap" != yes && WRAPLIBS="-L$with_libwrap"
|
|
WRAPLIBS="$WRAPLIBS -lwrap -lnsl"
|
|
else
|
|
echo "$as_me: failed program was:" >&5
|