fixed perl linking
This commit is contained in:
parent
236dda1ab3
commit
a6d519fe77
14
net-snmp-5.7-libtool.patch
Normal file
14
net-snmp-5.7-libtool.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
Fix a typo in libtool, seems to be related to bug #742678
|
||||||
|
|
||||||
|
diff -up net-snmp-5.7.1/ltmain.sh.orig net-snmp-5.7.1/ltmain.sh
|
||||||
|
--- net-snmp-5.7.1/ltmain.sh.orig 2011-09-28 06:53:47.000000000 +0200
|
||||||
|
+++ net-snmp-5.7.1/ltmain.sh 2011-10-04 09:48:11.022131513 +0200
|
||||||
|
@@ -8051,7 +8051,7 @@ EOF
|
||||||
|
elif test -n "$runpath_var"; then
|
||||||
|
case "$perm_rpath " in
|
||||||
|
*" $libdir "*) ;;
|
||||||
|
- *) func_apped perm_rpath " $libdir" ;;
|
||||||
|
+ *) func_append perm_rpath " $libdir" ;;
|
||||||
|
esac
|
||||||
|
fi
|
||||||
|
done
|
16
net-snmp-5.7-mibs-perl-linking.patch
Normal file
16
net-snmp-5.7-mibs-perl-linking.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
742678: libnetsnmpmibs.so.30 is linked against libperl.so
|
||||||
|
|
||||||
|
add perl rpath to libnetsnmpmibs.so
|
||||||
|
|
||||||
|
diff -up net-snmp-5.7.1/agent/Makefile.in.orig net-snmp-5.7.1/agent/Makefile.in
|
||||||
|
--- net-snmp-5.7.1/agent/Makefile.in.orig 2011-10-04 09:49:26.762027506 +0200
|
||||||
|
+++ net-snmp-5.7.1/agent/Makefile.in 2011-10-04 10:31:48.092899541 +0200
|
||||||
|
@@ -302,7 +302,7 @@ libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VE
|
||||||
|
$(RANLIB) $(AGENTLIB)
|
||||||
|
|
||||||
|
libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION): ${LMIBOBJS} $(AGENTLIB) $(USELIBS)
|
||||||
|
- $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) ${LMIBLIBS} $(LIB_LD_LIBS) @AGENTLIBS@
|
||||||
|
+ $(LIB_LD_CMD) $(MIBLIB) ${LMIBOBJS} $(AGENTLIB) $(USELIBS) @LD_NO_UNDEFINED@ $(LDFLAGS) ${LMIBLIBS} $(PERLLDOPTS_FOR_LIBS) $(LIB_LD_LIBS) @AGENTLIBS@
|
||||||
|
$(RANLIB) $(MIBLIB)
|
||||||
|
|
||||||
|
agentlib: $(AGENTLIB)
|
@ -11,7 +11,7 @@
|
|||||||
Summary: A collection of SNMP protocol tools and libraries
|
Summary: A collection of SNMP protocol tools and libraries
|
||||||
Name: net-snmp
|
Name: net-snmp
|
||||||
Version: 5.7.1
|
Version: 5.7.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -38,6 +38,8 @@ Patch6: net-snmp-5.5-perl-linking.patch
|
|||||||
Patch7: net-snmp-5.6-test-debug.patch
|
Patch7: net-snmp-5.6-test-debug.patch
|
||||||
Patch8: net-snmp-5.6.1-mysql.patch
|
Patch8: net-snmp-5.6.1-mysql.patch
|
||||||
Patch9: net-snmp-5.7.1-systemd.patch
|
Patch9: net-snmp-5.7.1-systemd.patch
|
||||||
|
Patch10: net-snmp-5.7-libtool.patch
|
||||||
|
Patch11: net-snmp-5.7-mibs-perl-linking.patch
|
||||||
|
|
||||||
Requires(post): chkconfig
|
Requires(post): chkconfig
|
||||||
Requires(preun): chkconfig
|
Requires(preun): chkconfig
|
||||||
@ -199,6 +201,8 @@ The net-snmp-sysvinit package provides SysV init scripts for Net-SNMP daemons.
|
|||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
%patch8 -p1 -b .mysql
|
%patch8 -p1 -b .mysql
|
||||||
%patch9 -p1 -b .systemd
|
%patch9 -p1 -b .systemd
|
||||||
|
%patch10 -p1 -b .libtool
|
||||||
|
%patch11 -p1 -b .mibs-perl
|
||||||
|
|
||||||
%ifarch sparc64 s390 s390x
|
%ifarch sparc64 s390 s390x
|
||||||
# disable failing test - see https://bugzilla.redhat.com/show_bug.cgi?id=680697
|
# disable failing test - see https://bugzilla.redhat.com/show_bug.cgi?id=680697
|
||||||
@ -505,6 +509,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
%config(noreplace,missingok) %{_sysconfdir}/sysconfig/snmptrapd
|
%config(noreplace,missingok) %{_sysconfdir}/sysconfig/snmptrapd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 5 2011 Jan Safranek <jsafrane@redhat.com> - 1:5.7.1-2
|
||||||
|
- fixed perl linking (#742678)
|
||||||
|
|
||||||
* Tue Oct 4 2011 Jan Safranek <jsafrane@redhat.com> - 1:5.7.1-1
|
* Tue Oct 4 2011 Jan Safranek <jsafrane@redhat.com> - 1:5.7.1-1
|
||||||
- updated to 5.7.1:
|
- updated to 5.7.1:
|
||||||
- Fixed the mib-parsing-bug introduced shortly before 5.7
|
- Fixed the mib-parsing-bug introduced shortly before 5.7
|
||||||
|
Loading…
Reference in New Issue
Block a user