Merge branch 'f18'
Conflicts: net-snmp.spec
This commit is contained in:
commit
958d377eeb
23
net-snmp-5.7.2-python-ipaddress-size.patch
Normal file
23
net-snmp-5.7.2-python-ipaddress-size.patch
Normal file
@ -0,0 +1,23 @@
|
||||
895357 - net-snmp-python adds zeros to end of IP address (IPADDR type), which is not valid
|
||||
|
||||
Source: upstream commit 234158b8e84cc204cbac96e6e9be6959635404b8
|
||||
|
||||
--- a/python/netsnmp/client_intf.c
|
||||
+++ a/python/netsnmp/client_intf.c
|
||||
@@ -821,14 +821,14 @@ OCT:
|
||||
|
||||
case TYPE_IPADDR:
|
||||
vars->type = ASN_IPADDRESS;
|
||||
- vars->val.integer = (long *)malloc(sizeof(long));
|
||||
+ vars->val.integer = (in_addr_t *)malloc(sizeof(in_addr_t));
|
||||
if (val)
|
||||
*(vars->val.integer) = inet_addr(val);
|
||||
else {
|
||||
ret = FAILURE;
|
||||
*(vars->val.integer) = 0;
|
||||
}
|
||||
- vars->val_len = sizeof(long);
|
||||
+ vars->val_len = sizeof(in_addr_t);
|
||||
break;
|
||||
|
||||
case TYPE_OBJID:
|
@ -11,7 +11,7 @@
|
||||
Summary: A collection of SNMP protocol tools and libraries
|
||||
Name: net-snmp
|
||||
Version: 5.7.2
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
License: BSD
|
||||
@ -35,6 +35,7 @@ Patch3: net-snmp-5.6-multilib.patch
|
||||
Patch4: net-snmp-5.5-apsl-copying.patch
|
||||
Patch5: net-snmp-5.6-test-debug.patch
|
||||
Patch6: net-snmp-5.7.2-systemd.patch
|
||||
Patch7: net-snmp-5.7.2-python-ipaddress-size.patch
|
||||
|
||||
Requires(post): chkconfig
|
||||
Requires(preun): chkconfig
|
||||
@ -194,6 +195,7 @@ The net-snmp-sysvinit package provides SysV init scripts for Net-SNMP daemons.
|
||||
%patch4 -p1 -b .apsl
|
||||
%patch5 -p1
|
||||
%patch6 -p1 -b .systemd
|
||||
%patch7 -p1 -b .ipaddress-size
|
||||
|
||||
%ifarch sparc64 s390 s390x
|
||||
# disable failing test - see https://bugzilla.redhat.com/show_bug.cgi?id=680697
|
||||
@ -487,6 +489,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_initrddir}/snmptrapd
|
||||
|
||||
%changelog
|
||||
* Thu Jan 17 2013 Jan Safranek <jsafrane@redhat.com> - 1:5.7.2-5
|
||||
- Python: fixed IPADDRESS size on 64-bit systems (#895357)
|
||||
|
||||
* Mon Nov 12 2012 Jan Safranek <jsafrane@redhat.com> - 1:5.7.2-4
|
||||
- Fixed systemd support (#875632).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user