auto-import changelog data from net-snmp-5.1.1-2.src.rpm
Thu Apr 08 2004 Phil Knirsch <pknirsch@redhat.com> 5.1.1-2 - Added Kaj J. Niemi that fixes ipAdEntIfIndex problem (#119106) - Added Kaj J. Niemi to shut up memshared message for 2.6 kernel (#119203) Tue Mar 23 2004 Phil Knirsch <pknirsch@redhat.com> 5.1.1-1 - Update to latest upstream version 5.1.1 - Included updated patches from Kaj J. Niemi (#118580). Thu Mar 18 2004 Phil Knirsch <pknirsch@redhat.com> 5.1-12 - Hacked an ugly perl hack to get rid of perl RPATH problems. - Fixed 64bit patch and applied it. ;-)
This commit is contained in:
parent
0e6bc952c8
commit
3762211db6
@ -1 +1 @@
|
||||
net-snmp-5.1.tar.gz
|
||||
net-snmp-5.1.1.tar.gz
|
||||
|
51
net-snmp-5.1.1-ipAdEntIfIndex.patch
Normal file
51
net-snmp-5.1.1-ipAdEntIfIndex.patch
Normal file
@ -0,0 +1,51 @@
|
||||
--- net-snmp-5.1.1/agent/mibgroup/mibII/ipAddr.c.ipAdEntIfIndex 2004-04-08 17:38:48.368076685 +0200
|
||||
+++ net-snmp-5.1.1/agent/mibgroup/mibII/ipAddr.c 2004-04-08 17:48:52.977283961 +0200
|
||||
@@ -200,6 +200,9 @@
|
||||
#else
|
||||
static struct ifnet lowin_ifnet;
|
||||
static in_addr_t addr_ret;
|
||||
+#if defined(linux)
|
||||
+ static struct in_ifaddr in_ifaddr;
|
||||
+#endif
|
||||
#endif
|
||||
static struct ifnet ifnet;
|
||||
#endif /* hpux11 */
|
||||
@@ -211,14 +214,14 @@
|
||||
memcpy((char *) current, (char *) vp->name,
|
||||
(int) vp->namelen * sizeof(oid));
|
||||
|
||||
-#if !defined(freebsd2) && !defined(hpux11) && !defined(linux)
|
||||
+#if !defined(freebsd2) && !defined(hpux11)
|
||||
Interface_Scan_Init();
|
||||
#else
|
||||
Address_Scan_Init();
|
||||
#endif
|
||||
for (;;) {
|
||||
|
||||
-#if !defined(freebsd2) && !defined(hpux11) && !defined(linux)
|
||||
+#if !defined(freebsd2) && !defined(hpux11)
|
||||
if (Interface_Scan_Next(&interface, NULL, &ifnet, &in_ifaddr) == 0)
|
||||
break;
|
||||
#ifdef STRUCT_IFNET_HAS_IF_ADDRLIST
|
||||
@@ -226,10 +229,7 @@
|
||||
continue; /* No address found for interface */
|
||||
#endif
|
||||
#else /* !freebsd2 && !hpux11 */
|
||||
-#if defined(linux)
|
||||
- if (Address_Scan_Next(&interface, &ifnet) == 0)
|
||||
- break;
|
||||
-#else
|
||||
+#if !defined(linux)
|
||||
if (Address_Scan_Next(&interface, &in_ifaddr) == 0)
|
||||
break;
|
||||
#endif
|
||||
@@ -240,6 +240,9 @@
|
||||
#elif defined(linux) || defined(sunV3)
|
||||
cp = (u_char *) & (((struct sockaddr_in *) &(ifnet.if_addr))->
|
||||
sin_addr.s_addr);
|
||||
+
|
||||
+ if (*cp == 0) /* first octet is zero? 0.x.x.x is not a */
|
||||
+ continue; /* legal address for an interface */
|
||||
#else
|
||||
cp = (u_char *) & (((struct sockaddr_in *) &(in_ifaddr.ia_addr))->
|
||||
sin_addr.s_addr);
|
22
net-snmp-5.1.1-pie.patch
Normal file
22
net-snmp-5.1.1-pie.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- net-snmp-5.1.1.rc1/apps/Makefile.in.pie 2004-03-09 17:51:28.000000000 +0200
|
||||
+++ net-snmp-5.1.1.rc1/apps/Makefile.in 2004-03-17 21:27:41.251685488 +0200
|
||||
@@ -101,7 +101,7 @@
|
||||
$(LINK) -o $@ snmptest.$(OSUFFIX) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
|
||||
|
||||
snmptrapd$(EXEEXT): $(TRAPD_OBJECTS) $(USETRAPLIBS) $(INSTALLLIBS)
|
||||
- $(LINK) -o $@ $(TRAPD_OBJECTS) $(INSTALLLIBS) $(LOCAL_LIBS) ${LDFLAGS} ${TRAPLIBS}
|
||||
+ $(LINK) -o $@ -pie $(TRAPD_OBJECTS) $(INSTALLLIBS) $(LOCAL_LIBS) ${LDFLAGS} ${TRAPLIBS}
|
||||
|
||||
snmptrap$(EXEEXT): snmptrap.$(OSUFFIX) $(USELIBS)
|
||||
$(LINK) -o $@ snmptrap.$(OSUFFIX) $(LOCAL_LIBS) ${LDFLAGS} ${LIBS}
|
||||
--- net-snmp-5.1.1.rc1/agent/Makefile.in.pie 2003-10-14 16:30:48.000000000 +0300
|
||||
+++ net-snmp-5.1.1.rc1/agent/Makefile.in 2004-03-17 21:25:41.662096693 +0200
|
||||
@@ -116,7 +116,7 @@
|
||||
$(CC) $(CFLAGS) -o $@ -D_GETMIBSTAT_TEST -DDODEBUG -c $?
|
||||
|
||||
snmpd$(EXEEXT): ${LAGENTOBJS} $(USELIBS) $(HELPERLIB) $(LIBTARG) ${INSTALLLIBS}
|
||||
- $(LINK) $(CFLAGS) -o $@ ${LAGENTOBJS} $(LOCAL_LIBS) ${LDFLAGS} ${OUR_AGENT_LIBS}
|
||||
+ $(LINK) $(CFLAGS) -o $@ -pie ${LAGENTOBJS} $(LOCAL_LIBS) ${LDFLAGS} ${OUR_AGENT_LIBS}
|
||||
|
||||
|
||||
libnetsnmpagent.$(LIB_EXTENSION)$(LIB_VERSION): ${LLIBAGENTOBJS} libnetsnmpmibs.$(LIB_EXTENSION)$(LIB_VERSION)
|
@ -2,8 +2,8 @@
|
||||
|
||||
Summary: A collection of SNMP protocol tools and libraries.
|
||||
Name: net-snmp
|
||||
Version: 5.1
|
||||
Release: 11.1
|
||||
Version: 5.1.1
|
||||
Release: 2
|
||||
License: BSDish
|
||||
Group: System Environment/Daemons
|
||||
Source0: ftp://net-snmp.sourceforge.net/net-snmp-%{version}.tar.gz
|
||||
@ -21,13 +21,14 @@ Patch6: net-snmp-5.0.8-ipv6-sock-close.patch
|
||||
Patch7: net-snmp-5.0.8-readonly.patch
|
||||
Patch8: net-snmp-5.1-libwrap.patch
|
||||
Patch9: net-snmp-5.1-sensors.patch
|
||||
Patch10: net-snmp-5.1-getopt.patch
|
||||
Patch11: net-snmp-5.1-xs-label-iid.patch
|
||||
Patch12: net-snmp-5.1-async-getnext.patch
|
||||
Patch13: net-snmp-5.1-hr_storage-mbuf-v2.patch
|
||||
Patch14: net-snmp-5.1-pie.patch
|
||||
Patch13: net-snmp-5.1.1-hr_storage-mbuf-v2.patch
|
||||
Patch14: net-snmp-5.1.1-pie.patch
|
||||
Patch15: net-snmp-5.1-bsdcompat.patch
|
||||
Patch16: net-snmp-5.1-64bit.patch
|
||||
Patch17: net-snmp-5.1.1-ipAdEntIfIndex.patch
|
||||
Patch18: net-snmp-5.1.1-quiet-memshared.patch
|
||||
Prereq: /sbin/chkconfig
|
||||
Obsoletes: ucd-snmp
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
@ -113,7 +114,6 @@ Install the net-snmp-perl package, if you want to use mib2c or SNMP with perl.
|
||||
%ifarch %{ix86}
|
||||
%patch9 -p1 -b .sensors
|
||||
%endif
|
||||
%patch10 -p1 -b .getopt
|
||||
%patch11 -p1 -b .xs-label-iid
|
||||
%patch12 -p1 -b .async-getnext
|
||||
%patch13 -p1 -b .hr_storage-mbuf-v2
|
||||
@ -121,6 +121,10 @@ Install the net-snmp-perl package, if you want to use mib2c or SNMP with perl.
|
||||
%patch14 -p1 -b .pie
|
||||
%endif
|
||||
%patch15 -p1 -b .bsdcompat
|
||||
%patch16 -p1 -b .64bit
|
||||
%patch17 -p1 -b .ipAdEntIfIndex
|
||||
%patch18 -p1 -b .quiet-memshared
|
||||
|
||||
|
||||
# Do this patch with a perl hack...
|
||||
perl -pi -e "s|'\\\$install_libdir'|'%{_libdir}'|" ltmain.sh
|
||||
@ -152,8 +156,9 @@ make
|
||||
|
||||
pushd perl
|
||||
# Use just built libs for perl module building, not the system libs.
|
||||
#perl Makefile.PL -NET-SNMP-IN-SOURCE=true PREFIX=${RPM_BUILD_ROOT}/%{_prefix} INSTALLDIRS=vendor
|
||||
perl Makefile.PL PREFIX=${RPM_BUILD_ROOT}/%{_prefix} INSTALLDIRS=vendor -NET-SNMP-CONFIG="sh ../../net-snmp-config" -NET-SNMP-IN-SOURCE=true
|
||||
perl Makefile.PL -NET-SNMP-IN-SOURCE=true PREFIX=${RPM_BUILD_ROOT}/%{_prefix} INSTALLDIRS=vendor
|
||||
perl -pi -e 's/^LD_RUN_PATH.*//;s/LD_RUN_PATH=\".*\" //;' default_store/Makefile OID/Makefile agent/Makefile agent/default_store/Makefile ASN/Makefile SNMP/Makefile
|
||||
#perl Makefile.PL PREFIX=${RPM_BUILD_ROOT}/%{_prefix} INSTALLDIRS=vendor -NET-SNMP-CONFIG="sh ../../net-snmp-config" -NET-SNMP-IN-SOURCE=true
|
||||
make
|
||||
popd
|
||||
|
||||
@ -271,6 +276,18 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%attr(0644,root,root) %{_mandir}/man3/*.3pm.*
|
||||
|
||||
%changelog
|
||||
* Thu Apr 08 2004 Phil Knirsch <pknirsch@redhat.com> 5.1.1-2
|
||||
- Added Kaj J. Niemi that fixes ipAdEntIfIndex problem (#119106)
|
||||
- Added Kaj J. Niemi to shut up memshared message for 2.6 kernel (#119203)
|
||||
|
||||
* Tue Mar 23 2004 Phil Knirsch <pknirsch@redhat.com> 5.1.1-1
|
||||
- Update to latest upstream version 5.1.1
|
||||
- Included updated patches from Kaj J. Niemi (#118580).
|
||||
|
||||
* Thu Mar 18 2004 Phil Knirsch <pknirsch@redhat.com> 5.1-12
|
||||
- Hacked an ugly perl hack to get rid of perl RPATH problems.
|
||||
- Fixed 64bit patch and applied it. ;-)
|
||||
|
||||
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user