New upstream version 1.11.6.
Add linuxdisk plugin. Remove rust plugin if compiled.
This commit is contained in:
parent
3d8e2fc142
commit
df26f1b46f
@ -0,0 +1,34 @@
|
|||||||
|
From d77c93b1cc42fc6cbda1b2abf941b001ad741cba Mon Sep 17 00:00:00 2001
|
||||||
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
||||||
|
Date: Sat, 2 Mar 2019 08:28:04 +0000
|
||||||
|
Subject: [PATCH] common: utils: Use include/ directory to get
|
||||||
|
<nbdkit-plugin.h>
|
||||||
|
|
||||||
|
This worked before because nbdkit was installed by the system package
|
||||||
|
manager, but if not:
|
||||||
|
|
||||||
|
utils.c:42:10: fatal error: nbdkit-plugin.h: No such file or directory
|
||||||
|
42 | #include <nbdkit-plugin.h>
|
||||||
|
| ^~~~~~~~~~~~~~~~~
|
||||||
|
compilation terminated.
|
||||||
|
|
||||||
|
Fixes commit 96b468d2e4214d15d722bd44db289d95e137280a.
|
||||||
|
---
|
||||||
|
common/utils/Makefile.am | 2 ++
|
||||||
|
1 file changed, 2 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/common/utils/Makefile.am b/common/utils/Makefile.am
|
||||||
|
index e002586..d1d95ed 100644
|
||||||
|
--- a/common/utils/Makefile.am
|
||||||
|
+++ b/common/utils/Makefile.am
|
||||||
|
@@ -37,5 +37,7 @@ noinst_LTLIBRARIES = libutils.la
|
||||||
|
libutils_la_SOURCES = \
|
||||||
|
utils.c \
|
||||||
|
utils.h
|
||||||
|
+libutils_la_CPPFLAGS = \
|
||||||
|
+ -I$(top_srcdir)/include
|
||||||
|
libutils_la_CFLAGS = \
|
||||||
|
$(WARNINGS_CFLAGS)
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
@ -25,7 +25,7 @@
|
|||||||
%global verify_tarball_signature 1
|
%global verify_tarball_signature 1
|
||||||
|
|
||||||
# If there are patches which touch autotools files, set this to 1.
|
# If there are patches which touch autotools files, set this to 1.
|
||||||
%global patches_touch_autotools %{nil}
|
%global patches_touch_autotools 1
|
||||||
|
|
||||||
# The source directory.
|
# The source directory.
|
||||||
%global source_directory 1.11-development
|
%global source_directory 1.11-development
|
||||||
@ -45,6 +45,9 @@ Source1: http://libguestfs.org/download/nbdkit/%{source_directory}/%{name
|
|||||||
Source2: libguestfs.keyring
|
Source2: libguestfs.keyring
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Upstream fix to include directory.
|
||||||
|
Patch1: 0001-common-utils-Use-include-directory-to-get-nbdkit-plu.patch
|
||||||
|
|
||||||
%if 0%{patches_touch_autotools}
|
%if 0%{patches_touch_autotools}
|
||||||
BuildRequires: autoconf, automake, libtool
|
BuildRequires: autoconf, automake, libtool
|
||||||
%endif
|
%endif
|
||||||
|
Loading…
Reference in New Issue
Block a user