nbdkit/0001-common-utils-Use-include-directory-to-get-nbdkit-plu.patch
Richard W.M. Jones df26f1b46f New upstream version 1.11.6.
Add linuxdisk plugin.
Remove rust plugin if compiled.
2019-03-02 08:32:49 +00:00

35 lines
1007 B
Diff

From d77c93b1cc42fc6cbda1b2abf941b001ad741cba Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Sat, 2 Mar 2019 08:28:04 +0000
Subject: [PATCH] common: utils: Use include/ directory to get
<nbdkit-plugin.h>
This worked before because nbdkit was installed by the system package
manager, but if not:
utils.c:42:10: fatal error: nbdkit-plugin.h: No such file or directory
42 | #include <nbdkit-plugin.h>
| ^~~~~~~~~~~~~~~~~
compilation terminated.
Fixes commit 96b468d2e4214d15d722bd44db289d95e137280a.
---
common/utils/Makefile.am | 2 ++
1 file changed, 2 insertions(+)
diff --git a/common/utils/Makefile.am b/common/utils/Makefile.am
index e002586..d1d95ed 100644
--- a/common/utils/Makefile.am
+++ b/common/utils/Makefile.am
@@ -37,5 +37,7 @@ noinst_LTLIBRARIES = libutils.la
libutils_la_SOURCES = \
utils.c \
utils.h
+libutils_la_CPPFLAGS = \
+ -I$(top_srcdir)/include
libutils_la_CFLAGS = \
$(WARNINGS_CFLAGS)
--
2.20.1