Update to MySQL 5.0.37. Resolves: #231838 Put client library into a

separate mysql-libs RPM to reduce dependencies Resolves: #205630 Minor
    rpmlint cleanups.
This commit is contained in:
Tom Lane 2007-03-12 17:08:30 +00:00 committed by Michal Schorm
parent ebf8197d53
commit 22c32d815d
6 changed files with 185 additions and 200 deletions

View File

@ -1 +1 @@
mysql-5.0.33.tar.gz
mysql-5.0.37.tar.gz

16
mysql-info-schema.patch Normal file
View File

@ -0,0 +1,16 @@
Crude workaround for upstream bug #27035 ... don't these people even run
their own regression tests before making releases?
diff -Naur mysql-5.0.37.orig/mysql-test/r/information_schema.result mysql-5.0.37/mysql-test/r/information_schema.result
--- mysql-5.0.37.orig/mysql-test/r/information_schema.result 2007-03-05 14:40:30.000000000 -0500
+++ mysql-5.0.37/mysql-test/r/information_schema.result 2007-03-12 11:48:12.000000000 -0400
@@ -1096,7 +1096,7 @@
group by column_type order by num;
column_type group_concat(table_schema, '.', table_name) num
varchar(20) information_schema.COLUMNS,information_schema.PROFILING 2
-varchar(7) information_schema.PROFILING,information_schema.PROFILING,information_schema.PROFILING,information_schema.ROUTINES,information_schema.VIEWS 5
+varchar(7) information_schema.ROUTINES,information_schema.VIEWS 2
create table t1(f1 char(1) not null, f2 char(9) not null)
default character set utf8;
select CHARACTER_MAXIMUM_LENGTH, CHARACTER_OCTET_LENGTH from

View File

@ -1,16 +1,5 @@
Workarounds for recently-introduced SSL breakage, filed as upstream bugs
#24121, #24148, and #24157.
I believe the client.c fix is actually correct.
The viossl.c patch is just a crude reversion to the 5.0.22 approach to work
around brain death in close_connection(). I don't know the mysql code well
enough to venture changing the locking logic in close_connection(), though.
Also, change openssl_1 test to agree with the test certificate included in the
distribution. And in viosslfactories.c, suppress ERR_print_errors_fp which
gives system-dependent error messages, since that breaks the openssl_1 test
(which has evidently only been tested with yassl, if at all).
Workaround for recently-introduced SSL breakage, filed as upstream bug
#24121 (why is this still not fixed in 5.0.37?)
diff -Naur mysql-5.0.33.orig/sql-common/client.c mysql-5.0.33/sql-common/client.c
@ -25,77 +14,3 @@ diff -Naur mysql-5.0.33.orig/sql-common/client.c mysql-5.0.33/sql-common/client.
mysql->options.client_flag|= CLIENT_SSL_VERIFY_SERVER_CERT;
else
mysql->options.client_flag&= ~CLIENT_SSL_VERIFY_SERVER_CERT;
diff -Naur mysql-5.0.33.orig/vio/viossl.c mysql-5.0.33/vio/viossl.c
--- mysql-5.0.33.orig/vio/viossl.c 2007-01-09 07:51:50.000000000 -0500
+++ mysql-5.0.33/vio/viossl.c 2007-02-09 12:39:12.000000000 -0500
@@ -124,19 +124,10 @@
if (ssl)
{
- switch ((r= SSL_shutdown(ssl)))
- {
- case 1: /* Shutdown successful */
- break;
- case 0: /* Shutdown not yet finished, call it again */
- if ((r= SSL_shutdown(ssl) >= 0))
- break;
- /* Fallthrough */
- default: /* Shutdown failed */
+ r = SSL_shutdown(ssl);
+ if (r < 0)
DBUG_PRINT("vio_error", ("SSL_shutdown() failed, error: %d",
SSL_get_error(ssl, r)));
- break;
- }
SSL_free(ssl);
vio->ssl_arg= 0;
}
diff -Naur mysql-5.0.33.orig/mysql-test/r/openssl_1.result mysql-5.0.33/mysql-test/r/openssl_1.result
--- mysql-5.0.33.orig/mysql-test/r/openssl_1.result 2007-01-09 08:09:32.000000000 -0500
+++ mysql-5.0.33/mysql-test/r/openssl_1.result 2007-02-09 12:36:17.000000000 -0500
@@ -3,8 +3,8 @@
insert into t1 values (5);
grant select on test.* to ssl_user1@localhost require SSL;
grant select on test.* to ssl_user2@localhost require cipher "DHE-RSA-AES256-SHA";
-grant select on test.* to ssl_user3@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
-grant select on test.* to ssl_user4@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB" ISSUER "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
+grant select on test.* to ssl_user3@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB/emailAddress=abstract.mysql.developer@mysql.com";
+grant select on test.* to ssl_user4@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB/emailAddress=abstract.mysql.developer@mysql.com" ISSUER "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
grant select on test.* to ssl_user5@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "xxx";
flush privileges;
connect(localhost,ssl_user5,,test,MASTER_PORT,MASTER_SOCKET);
diff -Naur mysql-5.0.33.orig/mysql-test/t/openssl_1.test mysql-5.0.33/mysql-test/t/openssl_1.test
--- mysql-5.0.33.orig/mysql-test/t/openssl_1.test 2007-01-09 08:09:28.000000000 -0500
+++ mysql-5.0.33/mysql-test/t/openssl_1.test 2007-02-09 12:36:17.000000000 -0500
@@ -10,8 +10,8 @@
grant select on test.* to ssl_user1@localhost require SSL;
grant select on test.* to ssl_user2@localhost require cipher "DHE-RSA-AES256-SHA";
-grant select on test.* to ssl_user3@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
-grant select on test.* to ssl_user4@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB" ISSUER "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
+grant select on test.* to ssl_user3@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB/emailAddress=abstract.mysql.developer@mysql.com";
+grant select on test.* to ssl_user4@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB/emailAddress=abstract.mysql.developer@mysql.com" ISSUER "/C=SE/ST=Uppsala/L=Uppsala/O=MySQL AB";
grant select on test.* to ssl_user5@localhost require cipher "DHE-RSA-AES256-SHA" AND SUBJECT "xxx";
flush privileges;
diff -Naur mysql-5.0.33.orig/vio/viosslfactories.c mysql-5.0.33/vio/viosslfactories.c
--- mysql-5.0.33.orig/vio/viosslfactories.c 2007-01-09 07:51:28.000000000 -0500
+++ mysql-5.0.33/vio/viosslfactories.c 2007-02-09 12:37:26.000000000 -0500
@@ -87,7 +87,7 @@
{
DBUG_PRINT("error",("unable to get certificate from '%s'\n", cert_file));
fprintf(stderr,"SSL error: ");
- ERR_print_errors_fp(stderr);
+ DBUG_EXECUTE("error",ERR_print_errors_fp(stderr););
fprintf(stderr,"Unable to get certificate from '%s'\n", cert_file);
fflush(stderr);
DBUG_RETURN(1);
@@ -100,7 +100,7 @@
{
DBUG_PRINT("error", ("unable to get private key from '%s'\n", key_file));
fprintf(stderr,"SSL error: ");
- ERR_print_errors_fp(stderr);
+ DBUG_EXECUTE("error",ERR_print_errors_fp(stderr););
fprintf(stderr,"Unable to get private key from '%s'\n", key_file);
fflush(stderr);
DBUG_RETURN(1);

View File

@ -6,24 +6,27 @@ from the calling terminal session. Without this, the ssl_des test hangs up
because OpenSSL tries to read a PEM key from /dev/tty.
diff -Naur mysql-5.0.33.orig/Makefile.am mysql-5.0.33/Makefile.am
--- mysql-5.0.33.orig/Makefile.am 2007-01-09 07:51:07.000000000 -0500
+++ mysql-5.0.33/Makefile.am 2007-02-09 13:37:00.000000000 -0500
@@ -121,8 +121,8 @@
diff -Naur mysql-5.0.37.orig/Makefile.am mysql-5.0.37/Makefile.am
--- mysql-5.0.37.orig/Makefile.am 2007-03-05 14:21:11.000000000 -0500
+++ mysql-5.0.37/Makefile.am 2007-03-12 11:19:05.000000000 -0400
@@ -124,11 +124,11 @@
test:
test-ps:
cd mysql-test ; \
- ./mysql-test-run && \
- ./mysql-test-run --ps-protocol
+ ./mysql-test-run --ssl && \
+ ./mysql-test-run --ps-protocol --ssl
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
+ @PERL@ ./mysql-test-run.pl $(force) --ssl --ps-protocol
test-force:
test-ns:
cd mysql-test ; \
diff -Naur mysql-5.0.33.orig/mysql-test/lib/mtr_process.pl mysql-5.0.33/mysql-test/lib/mtr_process.pl
--- mysql-5.0.33.orig/mysql-test/lib/mtr_process.pl 2007-01-09 08:09:33.000000000 -0500
+++ mysql-5.0.33/mysql-test/lib/mtr_process.pl 2007-02-09 13:36:05.000000000 -0500
@@ -147,6 +147,9 @@
- @PERL@ ./mysql-test-run.pl $(force)
+ @PERL@ ./mysql-test-run.pl $(force) --ssl
test: test-ns test-ps
diff -Naur mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl mysql-5.0.37/mysql-test/lib/mtr_process.pl
--- mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl 2007-03-05 14:40:33.000000000 -0500
+++ mysql-5.0.37/mysql-test/lib/mtr_process.pl 2007-03-12 11:17:52.000000000 -0400
@@ -161,6 +161,9 @@
# became a deamon as well, and was hard to kill ;-)
# Need to catch SIGCHLD and do waitpid or something instead......
@ -33,10 +36,10 @@ diff -Naur mysql-5.0.33.orig/mysql-test/lib/mtr_process.pl mysql-5.0.33/mysql-te
$SIG{INT}= 'DEFAULT'; # Parent do some stuff, we don't
my $log_file_open_mode = '>';
diff -Naur mysql-5.0.33.orig/mysql-test/mysql-test-run.pl mysql-5.0.33/mysql-test/mysql-test-run.pl
--- mysql-5.0.33.orig/mysql-test/mysql-test-run.pl 2007-01-09 07:51:07.000000000 -0500
+++ mysql-5.0.33/mysql-test/mysql-test-run.pl 2007-02-09 13:36:27.000000000 -0500
@@ -3862,7 +3862,7 @@
diff -Naur mysql-5.0.37.orig/mysql-test/mysql-test-run.pl mysql-5.0.37/mysql-test/mysql-test-run.pl
--- mysql-5.0.37.orig/mysql-test/mysql-test-run.pl 2007-03-05 14:21:11.000000000 -0500
+++ mysql-5.0.37/mysql-test/mysql-test-run.pl 2007-03-12 11:17:52.000000000 -0400
@@ -3906,7 +3906,7 @@
if ( defined $exe )
{

View File

@ -1,7 +1,7 @@
Name: mysql
Version: 5.0.33
Version: 5.0.37
Release: 1%{?dist}
Summary: MySQL client programs and shared libraries.
Summary: MySQL client programs and shared libraries
License: GPL
Group: Applications/Databases
URL: http://www.mysql.com
@ -26,18 +26,19 @@ Patch7: mysql-rpl-test.patch
Patch8: mysql-install-test.patch
Patch9: mysql-bdb-link.patch
Patch10: mysql-ssl-bugs.patch
Patch11: mysql-y2007bug.patch
Patch11: mysql-info-schema.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-root
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
Prereq: /sbin/ldconfig, /sbin/install-info, grep, fileutils, chkconfig
BuildRequires: gperf, perl, readline-devel, openssl-devel
BuildRequires: gcc-c++, ncurses-devel, zlib-devel
BuildRequires: libtool automake autoconf
# make test requires time
BuildRequires: time
Requires: %{name}-libs = %{version}-%{release}
Requires: bash
Conflicts: MySQL
Obsoletes: mysql-client mysql-perl
# make test requires time
BuildRequires: time
# Working around perl dependency checking bug in rpm FTTB. Remove later.
%define __perl_requires %{SOURCE999}
@ -46,16 +47,29 @@ BuildRequires: time
MySQL is a multi-user, multi-threaded SQL database server. MySQL is a
client/server implementation consisting of a server daemon (mysqld)
and many different client programs and libraries. The base package
contains the MySQL client programs, the client shared libraries, and
generic MySQL files.
contains the standard MySQL client programs and generic MySQL files.
%package libs
Summary: The shared libraries required for MySQL clients
License: GPL
Group: Applications/Databases
%description libs
The mysql-libs package provides the essential shared libraries for any
MySQL client program or interface. You will need to install this package
to use any other MySQL package or any clients that need to connect to a
MySQL server.
%package server
Summary: The MySQL server and related files.
Summary: The MySQL server and related files
License: GPL
Group: Applications/Databases
Prereq: /sbin/chkconfig, /usr/sbin/useradd
Requires: %{name} = %{version}-%{release}, sh-utils
Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires: sh-utils
# mysqlhotcopy needs DBI/DBD support
Requires: perl-DBI, perl-DBD-MySQL
Conflicts: MySQL-server
@ -68,10 +82,11 @@ the MySQL server and some accompanying files and directories.
%package devel
Summary: Files for development of MySQL applications.
Summary: Files for development of MySQL applications
License: GPL
Group: Applications/Databases
Requires: %{name} = %{version}-%{release}
Requires: %{name}-libs = %{version}-%{release}
Requires: openssl-devel
Conflicts: MySQL-devel
@ -82,7 +97,7 @@ developing MySQL client applications.
%package bench
Summary: MySQL benchmark scripts and data.
Summary: MySQL benchmark scripts and data
License: GPL
Group: Applications/Databases
Requires: %{name} = %{version}-%{release}
@ -95,7 +110,7 @@ MySQL.
%package test
Summary: The test suite distributed with MySQL.
Summary: The test suite distributed with MySQL
License: GPL
Group: Applications/Databases
Requires: %{name} = %{version}-%{release}
@ -225,6 +240,7 @@ install -m 0755 scriptstub ${RPM_BUILD_ROOT}%{_bindir}/mysql_config
rm -f ${RPM_BUILD_ROOT}%{_bindir}/comp_err
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_binary_distribution
rm -f ${RPM_BUILD_ROOT}%{_bindir}/make_win_src_distribution
rm -f ${RPM_BUILD_ROOT}%{_mandir}/man1/make_win_bin_dist.1*
rm -f ${RPM_BUILD_ROOT}%{_libdir}/mysql/libmysqlclient*.la
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/binary-configure
rm -f ${RPM_BUILD_ROOT}%{_datadir}/mysql/make_binary_distribution
@ -252,6 +268,8 @@ rm -rf $RPM_BUILD_ROOT
%post
/sbin/install-info %{_infodir}/mysql.info.gz %{_infodir}/dir
%post libs
/sbin/ldconfig
%post server
@ -271,7 +289,7 @@ if [ $1 = 0 ]; then
/sbin/chkconfig --del mysqld
fi
%postun
%postun libs
if [ $1 = 0 ] ; then
/sbin/ldconfig
fi
@ -313,9 +331,17 @@ fi
%{_mandir}/man1/mysqlshow.1*
%dir %{_libdir}/mysql
%{_libdir}/mysql/libmysqlclient*.so.*
%{_libdir}/mysql/mysqlbug
%{_libdir}/mysql/mysql_config
# perhaps my.cnf should be in the server package?
%config(noreplace) /etc/my.cnf
%files libs
%defattr(-,root,root)
%dir %{_libdir}/mysql
%{_libdir}/mysql/libmysqlclient*.so.*
/etc/ld.so.conf.d/*
%dir %{_datadir}/mysql
@ -343,7 +369,6 @@ fi
%lang(sv) %{_datadir}/mysql/swedish
%lang(uk) %{_datadir}/mysql/ukrainian
%{_datadir}/mysql/charsets
%config(noreplace) /etc/my.cnf
%files server
%defattr(-,root,root)
@ -406,6 +431,26 @@ fi
%{_mandir}/man1/safe_mysqld.1*
%{_mandir}/man1/my_print_defaults.1*
%{_mandir}/man1/mysql_tzinfo_to_sql.1*
%{_mandir}/man1/mysql_install_db.1*
%{_mandir}/man1/ndb_config.1*
%{_mandir}/man1/ndb_cpcd.1*
%{_mandir}/man1/ndb_delete_all.1*
%{_mandir}/man1/ndb_desc.1*
%{_mandir}/man1/ndb_drop_index.1*
%{_mandir}/man1/ndb_drop_table.1*
%{_mandir}/man1/ndb_error_reporter.1*
%{_mandir}/man1/ndb_mgm.1*
%{_mandir}/man1/ndb_mgmd.1*
%{_mandir}/man1/ndb_print_backup_file.1*
%{_mandir}/man1/ndb_print_schema_file.1*
%{_mandir}/man1/ndb_print_sys_file.1*
%{_mandir}/man1/ndb_restore.1*
%{_mandir}/man1/ndb_select_all.1*
%{_mandir}/man1/ndb_select_count.1*
%{_mandir}/man1/ndb_show_tables.1*
%{_mandir}/man1/ndb_size.pl.1*
%{_mandir}/man1/ndb_waiter.1*
%{_mandir}/man1/ndbd.1*
%{_mandir}/man8/mysqld.8*
%{_mandir}/man8/mysqlmanager.8*
@ -435,6 +480,12 @@ fi
%attr(-,mysql,mysql) %{_datadir}/mysql-test
%changelog
* Mon Mar 12 2007 Tom Lane <tgl@redhat.com> 5.0.37-1
- Update to MySQL 5.0.37
Resolves: #231838
- Put client library into a separate mysql-libs RPM to reduce dependencies
Resolves: #205630
* Fri Feb 9 2007 Tom Lane <tgl@redhat.com> 5.0.33-1
- Update to MySQL 5.0.33
- Install band-aid fix for "view" regression test designed to fail after 2006
@ -730,178 +781,178 @@ Resolves: #199368
* Tue Nov 12 2002 Florian La Roche <Florian.LaRoche@redhat.de>
- do not prereq userdel, not used at all
* Mon Sep 9 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.52-4
* Mon Sep 9 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.52-4
- Use %%{_libdir}
- Add patch for x86-64
* Wed Sep 4 2002 Jakub Jelinek <jakub@redhat.com> 3.23.52-3
- rebuilt with gcc-3.2-7
* Thu Aug 29 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.52-2
* Thu Aug 29 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.52-2
- Add --enable-local-infile to configure - a new option
which doesn't default to the old behaviour (#72885)
* Fri Aug 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.52-1
* Fri Aug 23 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.52-1
- 3.23.52. Fixes a minor security problem, various bugfixes.
* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com> 3.23.51-5
- rebuilt with gcc-3.2 (we hope)
* Mon Jul 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.51-4
* Mon Jul 22 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.51-4
- rebuild
* Thu Jul 18 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.51-3
* Thu Jul 18 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.51-3
- Fix #63543 and #63542
* Thu Jul 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.51-2
* Thu Jul 11 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.51-2
- Turn off bdb on PPC(#68591)
- Turn off the assembly optimizations, for safety.
* Wed Jun 26 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.51-1
* Wed Jun 26 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.51-1
- Work around annoying auto* thinking this is a crosscompile
- 3.23.51
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Mon Jun 10 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.50-2
* Mon Jun 10 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.50-2
- Add dependency on perl-DBI and perl-DBD-MySQL (#66349)
* Thu May 30 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.50-1
* Thu May 30 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.50-1
- 3.23.50
* Thu May 23 2002 Tim Powers <timp@redhat.com>
- automated rebuild
* Mon May 13 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.49-4
* Mon May 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.49-4
- Rebuild
- Don't set CXX to gcc, it doesn't work anymore
- Exclude Alpha
* Mon Apr 8 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.49-3
* Mon Apr 8 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.49-3
- Add the various .cnf examples as doc files to mysql-server (#60349)
- Don't include manual.ps, it's just 200 bytes with a URL inside (#60349)
- Don't include random files in /usr/share/mysql (#60349)
- langify (#60349)
* Thu Feb 21 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.49-2
* Thu Feb 21 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.49-2
- Rebuild
* Sun Feb 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.49-1
* Sun Feb 17 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.49-1
- 3.23.49
* Thu Feb 14 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.48-2
* Thu Feb 14 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.48-2
- work around perl dependency bug.
* Mon Feb 11 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.48-1
* Mon Feb 11 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.48-1
- 3.23.48
* Thu Jan 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.47-4
* Thu Jan 17 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.47-4
- Use kill, not mysqladmin, to flush logs and shut down. Thus,
an admin password can be set with no problems.
- Remove reload from init script
* Wed Jan 16 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.47-3
* Wed Jan 16 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.47-3
- remove db3-devel from buildrequires,
MySQL has had its own bundled copy since the mid thirties
* Sun Jan 6 2002 Trond Eivind Glomsrød <teg@redhat.com> 3.23.47-1
* Sun Jan 6 2002 Trond Eivind Glomsrd <teg@redhat.com> 3.23.47-1
- 3.23.47
- Don't build for alpha, toolchain immature.
* Mon Dec 3 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.46-1
* Mon Dec 3 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.46-1
- 3.23.46
- use -fno-rtti and -fno-exceptions, and set CXX to increase stability.
Recommended by mysql developers.
* Sun Nov 25 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.45-1
* Sun Nov 25 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.45-1
- 3.23.45
* Wed Nov 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.44-2
* Wed Nov 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.44-2
- centralize definition of datadir in the initscript (#55873)
* Fri Nov 2 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.44-1
* Fri Nov 2 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.44-1
- 3.23.44
* Thu Oct 4 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.43-1
* Thu Oct 4 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.43-1
- 3.23.43
* Mon Sep 10 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.42-1
* Mon Sep 10 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.42-1
- 3.23.42
- reenable innodb
* Tue Aug 14 2001 Trond Eivind Glomsrød <teg@redhat.com> 3.23.41-1
* Tue Aug 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 3.23.41-1
- 3.23.41 bugfix release
- disable innodb, to avoid the broken updates
- Use "mysqladmin flush_logs" instead of kill -HUP in logrotate
script (#51711)
* Sat Jul 21 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Sat Jul 21 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.40, bugfix release
- Add zlib-devel to buildrequires:
* Fri Jul 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jul 20 2001 Trond Eivind Glomsrd <teg@redhat.com>
- BuildRequires-tweaking
* Thu Jun 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Jun 28 2001 Trond Eivind Glomsrd <teg@redhat.com>
- Reenable test, but don't run them for s390, s390x or ia64
- Make /etc/my.cnf config(noplace). Same for /etc/logrotate.d/mysqld
* Thu Jun 14 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Jun 14 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.29
- enable innodb
- enable assembly again
- disable tests for now...
* Tue May 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue May 15 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.38
- Don't use BDB on Alpha - no fast mutexes
* Tue Apr 24 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Apr 24 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.37
- Add _GNU_SOURCE to the compile flags
* Wed Mar 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Mar 28 2001 Trond Eivind Glomsrd <teg@redhat.com>
- Make it obsolete our 6.2 PowerTools packages
- 3.23.36 bugfix release - fixes some security issues
which didn't apply to our standard configuration
- Make "make test" part of the build process, except on IA64
(it fails there)
* Tue Mar 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Mar 20 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.35 bugfix release
- Don't delete the mysql user on uninstall
* Tue Mar 13 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Mar 13 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.34a bugfix release
* Wed Feb 7 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Feb 7 2001 Trond Eivind Glomsrd <teg@redhat.com>
- added readline-devel to BuildRequires:
* Tue Feb 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Feb 6 2001 Trond Eivind Glomsrd <teg@redhat.com>
- small i18n-fixes to initscript (action needs $)
* Tue Jan 30 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Jan 30 2001 Trond Eivind Glomsrd <teg@redhat.com>
- make it shut down and rotate logs without using mysqladmin
(from #24909)
* Mon Jan 29 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jan 29 2001 Trond Eivind Glomsrd <teg@redhat.com>
- conflict with "MySQL"
* Tue Jan 23 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Jan 23 2001 Trond Eivind Glomsrd <teg@redhat.com>
- improve gettextizing
* Mon Jan 22 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jan 22 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.32
- fix logrotate script (#24589)
* Wed Jan 17 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jan 17 2001 Trond Eivind Glomsrd <teg@redhat.com>
- gettextize
- move the items in Requires(post): to Requires: in preparation
for an errata for 7.0 when 3.23.31 is released
- 3.23.31
* Tue Jan 16 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Jan 16 2001 Trond Eivind Glomsrd <teg@redhat.com>
- add the log file to the rpm database, and make it 0640
(#24116)
- as above in logrotate script
@ -912,71 +963,71 @@ Resolves: #199368
- use standard safe_mysqld
- shut down cleaner
* Mon Jan 08 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jan 08 2001 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.30
- do an explicit chmod on /var/lib/mysql in post, to avoid
any problems with broken permissons. There is a report
of rm not changing this on its own (#22989)
* Mon Jan 01 2001 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jan 01 2001 Trond Eivind Glomsrd <teg@redhat.com>
- bzipped source
- changed from 85 to 78 in startup, so it starts before
apache (which can use modules requiring mysql)
* Wed Dec 27 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Dec 27 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.29a
* Tue Dec 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Dec 19 2000 Trond Eivind Glomsrd <teg@redhat.com>
- add requirement for new libstdc++, build for errata
* Mon Dec 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Dec 18 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.29
* Mon Nov 27 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Nov 27 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.28 (gamma)
- remove old patches, as they are now upstreamed
* Thu Nov 14 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Nov 14 2000 Trond Eivind Glomsrd <teg@redhat.com>
- Add a requirement for a new glibc (#20735)
- build on IA64
* Wed Nov 1 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Nov 1 2000 Trond Eivind Glomsrd <teg@redhat.com>
- disable more assembly
* Wed Nov 1 2000 Jakub Jelinek <jakub@redhat.com>
- fix mysql on SPARC (#20124)
* Tue Oct 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Oct 31 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.27
* Wed Oct 25 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Oct 25 2000 Trond Eivind Glomsrd <teg@redhat.com>
- add patch for fixing bogus aliasing in mysql from Jakub,
which should fix #18905 and #18620
* Mon Oct 23 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Oct 23 2000 Trond Eivind Glomsrd <teg@redhat.com>
- check for negative niceness values, and negate it
if present (#17899)
- redefine optflags on IA32 FTTB
* Wed Oct 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Oct 18 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.26, which among other fixes now uses mkstemp()
instead of tempnam().
- revert changes made yesterday, the problem is now
isolated
* Tue Oct 17 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Oct 17 2000 Trond Eivind Glomsrd <teg@redhat.com>
- use the compat C++ compiler FTTB. Argh.
- add requirement of ncurses4 (see above)
* Sun Oct 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Oct 01 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.25
- fix shutdown problem (#17956)
* Tue Sep 26 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Sep 26 2000 Trond Eivind Glomsrd <teg@redhat.com>
- Don't try to include no-longer-existing PUBLIC file
as doc (#17532)
* Thu Sep 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Sep 12 2000 Trond Eivind Glomsrd <teg@redhat.com>
- rename config file to /etc/my.cnf, which is what
mysqld wants... doh. (#17432)
- include a changed safe_mysqld, so the pid file option
@ -985,20 +1036,20 @@ Resolves: #199368
mysql socket. (#17432)
- 3.23.24
* Wed Sep 06 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Sep 06 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.23
* Sun Aug 27 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Aug 27 2000 Trond Eivind Glomsrd <teg@redhat.com>
- Add "|| :" to condrestart to avoid non-zero exit code
* Thu Aug 24 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Aug 24 2000 Trond Eivind Glomsrd <teg@redhat.com>
- it's mysql.com, not mysql.org and use correct path to
source (#16830)
* Wed Aug 16 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Aug 16 2000 Trond Eivind Glomsrd <teg@redhat.com>
- source file from /etc/rc.d, not /etc/rd.d. Doh.
* Sun Aug 13 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Aug 13 2000 Trond Eivind Glomsrd <teg@redhat.com>
- don't run ldconfig -n, it doesn't update ld.so.cache
(#16034)
- include some missing binaries
@ -1008,31 +1059,31 @@ Resolves: #199368
* Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
- condrestart fixes
* Mon Aug 01 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Aug 01 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.22. Disable the old patches, they're now in.
* Thu Jul 27 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Jul 27 2000 Trond Eivind Glomsrd <teg@redhat.com>
- bugfixes in the initscript
- move the .so link to the devel package
* Wed Jul 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jul 19 2000 Trond Eivind Glomsrd <teg@redhat.com>
- rebuild due to glibc changes
* Tue Jul 18 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Tue Jul 18 2000 Trond Eivind Glomsrd <teg@redhat.com>
- disable compiler patch
- don't include info directory file
* Mon Jul 17 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jul 17 2000 Trond Eivind Glomsrd <teg@redhat.com>
- move back to /etc/rc.d/init.d
* Fri Jul 14 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jul 14 2000 Trond Eivind Glomsrd <teg@redhat.com>
- more cleanups in initscript
* Thu Jul 13 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Thu Jul 13 2000 Trond Eivind Glomsrd <teg@redhat.com>
- add a patch to work around compiler bug
(from monty@mysql.com)
* Wed Jul 12 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jul 12 2000 Trond Eivind Glomsrd <teg@redhat.com>
- don't build the SQL daemon statically (glibc problems)
- fix the logrotate script - only flush log if mysql
is running
@ -1042,23 +1093,23 @@ Resolves: #199368
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
- automatic rebuild
* Mon Jul 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Mon Jul 10 2000 Trond Eivind Glomsrd <teg@redhat.com>
- try the new compiler again
- build the SQL daemon statically
- add compile time support for complex charsets
- enable assembler
- more cleanups in initscript
* Sun Jul 09 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sun Jul 09 2000 Trond Eivind Glomsrd <teg@redhat.com>
- use old C++ compiler
- Exclusivearch x86
* Sat Jul 08 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Sat Jul 08 2000 Trond Eivind Glomsrd <teg@redhat.com>
- move .so files to devel package
- more cleanups
- exclude sparc for now
* Wed Jul 05 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Wed Jul 05 2000 Trond Eivind Glomsrd <teg@redhat.com>
- 3.23.21
- remove file from /etc/sysconfig
- Fix initscript a bit - initialization of databases doesn't
@ -1070,7 +1121,7 @@ Resolves: #199368
* Tue Jul 2 2000 Jakub Jelinek <jakub@redhat.com>
- Rebuild with new C++
* Fri Jun 30 2000 Trond Eivind Glomsrød <teg@redhat.com>
* Fri Jun 30 2000 Trond Eivind Glomsrd <teg@redhat.com>
- update to 3.23.20
- use %%configure, %%makeinstall, %%{_tmppath}, %%{_mandir},
%%{_infodir}, /etc/init.d

View File

@ -1 +1 @@
10cb85276a1468c7906a4ff4dd565d61 mysql-5.0.33.tar.gz
26ed76facb58bdeae40c8310e337dde2 mysql-5.0.37.tar.gz