22c32d815d
separate mysql-libs RPM to reduce dependencies Resolves: #205630 Minor rpmlint cleanups.
51 lines
1.9 KiB
Diff
51 lines
1.9 KiB
Diff
Hack the top-level Makefile to enable the openssl regression tests.
|
|
(Why doesn't this happen automatically given the configure option??)
|
|
|
|
Also, tweak the Perl test script so that the mysqld daemon gets detached
|
|
from the calling terminal session. Without this, the ssl_des test hangs up
|
|
because OpenSSL tries to read a PEM key from /dev/tty.
|
|
|
|
|
|
diff -Naur mysql-5.0.37.orig/Makefile.am mysql-5.0.37/Makefile.am
|
|
--- mysql-5.0.37.orig/Makefile.am 2007-03-05 14:21:11.000000000 -0500
|
|
+++ mysql-5.0.37/Makefile.am 2007-03-12 11:19:05.000000000 -0400
|
|
@@ -124,11 +124,11 @@
|
|
|
|
test-ps:
|
|
cd mysql-test ; \
|
|
- @PERL@ ./mysql-test-run.pl $(force) --ps-protocol
|
|
+ @PERL@ ./mysql-test-run.pl $(force) --ssl --ps-protocol
|
|
|
|
test-ns:
|
|
cd mysql-test ; \
|
|
- @PERL@ ./mysql-test-run.pl $(force)
|
|
+ @PERL@ ./mysql-test-run.pl $(force) --ssl
|
|
|
|
test: test-ns test-ps
|
|
|
|
diff -Naur mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl mysql-5.0.37/mysql-test/lib/mtr_process.pl
|
|
--- mysql-5.0.37.orig/mysql-test/lib/mtr_process.pl 2007-03-05 14:40:33.000000000 -0500
|
|
+++ mysql-5.0.37/mysql-test/lib/mtr_process.pl 2007-03-12 11:17:52.000000000 -0400
|
|
@@ -161,6 +161,9 @@
|
|
# became a deamon as well, and was hard to kill ;-)
|
|
# Need to catch SIGCHLD and do waitpid or something instead......
|
|
|
|
+ # dunno, it works for me ...
|
|
+ POSIX::setsid();
|
|
+
|
|
$SIG{INT}= 'DEFAULT'; # Parent do some stuff, we don't
|
|
|
|
my $log_file_open_mode = '>';
|
|
diff -Naur mysql-5.0.37.orig/mysql-test/mysql-test-run.pl mysql-5.0.37/mysql-test/mysql-test-run.pl
|
|
--- mysql-5.0.37.orig/mysql-test/mysql-test-run.pl 2007-03-05 14:21:11.000000000 -0500
|
|
+++ mysql-5.0.37/mysql-test/mysql-test-run.pl 2007-03-12 11:17:52.000000000 -0400
|
|
@@ -3906,7 +3906,7 @@
|
|
|
|
if ( defined $exe )
|
|
{
|
|
- $pid= mtr_spawn($exe, $args, "",
|
|
+ $pid= mtr_spawn($exe, $args, '/dev/null',
|
|
$mysqld->{'path_myerr'},
|
|
$mysqld->{'path_myerr'},
|
|
"",
|