28 lines
1.0 KiB
Diff
28 lines
1.0 KiB
Diff
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
|
|
index 1eb22c37..e200d4eb 100644
|
|
--- a/mysql-test/CMakeLists.txt
|
|
+++ b/mysql-test/CMakeLists.txt
|
|
@@ -56,6 +56,9 @@ INSTALL(
|
|
ENDIF()
|
|
|
|
|
|
+# Expand some paths in the perl script correctly
|
|
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl ${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl @ONLY)
|
|
+
|
|
IF(NOT ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
|
|
# Enable running mtr from build directory
|
|
FIND_PROGRAM(PERL_EXECUTABLE perl
|
|
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
|
index 05a504da..9cdc2cda 100755
|
|
--- a/mysql-test/mysql-test-run.pl
|
|
+++ b/mysql-test/mysql-test-run.pl
|
|
@@ -1626,7 +1626,7 @@ sub command_line_setup {
|
|
my $path_share = $path_language;
|
|
|
|
@share_locations =
|
|
- ("share/mysql-" . $mysql_base_version, "share/mysql", "share");
|
|
+ ("@INSTALL_MYSQLSHAREDIR@", "share/mysql-" . $mysql_base_version, "share/mysql", "share");
|
|
|
|
$path_charsetsdir = my_find_dir($basedir, \@share_locations, "charsets");
|
|
|