Update to MySQL 8.0.16
This commit is contained in:
parent
6e1efab1d6
commit
780acf29b5
@ -1,15 +0,0 @@
|
||||
diff --git a/client/CMakeLists.txt b/client/CMakeLists.txt
|
||||
index 8cc64089f5a..2ee48177b85 100644
|
||||
--- a/client/CMakeLists.txt
|
||||
+++ b/client/CMakeLists.txt
|
||||
@@ -113,10 +113,6 @@ TARGET_LINK_LIBRARIES(mysql_secure_installation mysqlclient)
|
||||
|
||||
MYSQL_ADD_EXECUTABLE(mysql_ssl_rsa_setup mysql_ssl_rsa_setup.cc path.cc logger.cc)
|
||||
TARGET_LINK_LIBRARIES(mysql_ssl_rsa_setup mysys mysys_ssl)
|
||||
-# Bug in /usr/lib/gcc-snapshot/lib/libstdc++.so ??
|
||||
-IF(CMAKE_CXX_COMPILER_VERSION VERSION_EQUAL "9.0.0")
|
||||
- TARGET_LINK_LIBRARIES(mysql_ssl_rsa_setup -static-libstdc++)
|
||||
-ENDIF()
|
||||
|
||||
# "WIN32" also covers 64 bit. "echo" is used in some files below "mysql-test/".
|
||||
IF(WIN32)
|
@ -1,22 +0,0 @@
|
||||
Do not build MySQL Router.
|
||||
It is a set of tools and libraries used for the InnoDB cluster.
|
||||
|
||||
However without MySQL Shell it can't be operated.
|
||||
We don't pack the MySQL Shell, so don´t build the router at all.
|
||||
|
||||
|
||||
|
||||
I have this confirmed from the mail conversation with the MySQL side:
|
||||
"While technically possible, it's practically impossible to set up router without the MySQL Shell."
|
||||
|
||||
--- mysql-8.0.13/CMakeLists.txt 2018-10-07 10:44:22.000000000 +0200
|
||||
+++ mysql-8.0.13/CMakeLists.txt_patched 2018-10-23 03:10:01.490792624 +0200
|
||||
@@ -1046,7 +1046,7 @@ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/sql/s
|
||||
|
||||
# depends on mysql_version.h to exist
|
||||
IF(NOT WITHOUT_SERVER)
|
||||
- ADD_SUBDIRECTORY(router)
|
||||
+# ADD_SUBDIRECTORY(router)
|
||||
ENDIF()
|
||||
|
||||
GET_PROPERTY(CWD_DEFINITIONS DIRECTORY PROPERTY COMPILE_DEFINITIONS)
|
@ -1,28 +1,22 @@
|
||||
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
|
||||
index 7c1e82b5..a92ba915 100644
|
||||
index 1eb22c37..e200d4eb 100644
|
||||
--- a/mysql-test/CMakeLists.txt
|
||||
+++ b/mysql-test/CMakeLists.txt
|
||||
@@ -56,6 +56,10 @@ INSTALL(
|
||||
@@ -56,6 +56,9 @@ INSTALL(
|
||||
ENDIF()
|
||||
|
||||
|
||||
+# Expand some paths in the perl scripts correctly
|
||||
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm ${CMAKE_CURRENT_SOURCE_DIR}/lib/My/ConfigFactory.pm @ONLY)
|
||||
+# Expand some paths in the perl script correctly
|
||||
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl ${CMAKE_CURRENT_SOURCE_DIR}/mysql-test-run.pl @ONLY)
|
||||
+
|
||||
IF(NOT ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
|
||||
# Enable running mtr from build directory
|
||||
CONFIGURE_FILE(
|
||||
FIND_PROGRAM(PERL_EXECUTABLE perl
|
||||
diff --git a/mysql-test/mysql-test-run.pl b/mysql-test/mysql-test-run.pl
|
||||
index 8c058527..7acd8534 100755
|
||||
index 05a504da..9cdc2cda 100755
|
||||
--- a/mysql-test/mysql-test-run.pl
|
||||
+++ b/mysql-test/mysql-test-run.pl
|
||||
@@ -1479,11 +1479,11 @@ sub command_line_setup {
|
||||
}
|
||||
|
||||
# Look for language files and charsetsdir, use same share
|
||||
- $path_language = mtr_path_exists("$bindir/share/mysql", "$bindir/share");
|
||||
+ $path_language = mtr_path_exists("$bindir/@INSTALL_MYSQLSHAREDIR@", "$bindir/share/mysql", "$bindir/share");
|
||||
@@ -1626,7 +1626,7 @@ sub command_line_setup {
|
||||
my $path_share = $path_language;
|
||||
|
||||
@share_locations =
|
||||
|
@ -82,7 +82,7 @@
|
||||
%global sameevr %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
|
||||
Name: community-mysql
|
||||
Version: 8.0.15
|
||||
Version: 8.0.16
|
||||
Release: 1%{?with_debug:.debug}%{?dist}
|
||||
Summary: MySQL client programs and shared libraries
|
||||
URL: http://www.mysql.com
|
||||
@ -122,8 +122,6 @@ Patch5: %{pkgnamepatch}-paths.patch
|
||||
# Patches specific for this mysql package
|
||||
Patch51: %{pkgnamepatch}-chain-certs.patch
|
||||
Patch52: %{pkgnamepatch}-sharedir.patch
|
||||
Patch53: %{pkgnamepatch}-router.patch
|
||||
Patch54: %{pkgnamepatch}-gcc9.patch
|
||||
Patch55: %{pkgnamepatch}-rpath.patch
|
||||
Patch75: %{pkgnamepatch}-arm32-timer.patch
|
||||
|
||||
@ -375,8 +373,6 @@ the MySQL sources.
|
||||
%patch5 -p1
|
||||
%patch51 -p1
|
||||
%patch52 -p1
|
||||
%patch53 -p1
|
||||
%patch54 -p1
|
||||
%patch55 -p1
|
||||
%patch75 -p1
|
||||
|
||||
@ -390,86 +386,20 @@ popd
|
||||
pushd mysql-test
|
||||
|
||||
add_test () {
|
||||
echo "$@" $ >> %{skiplist}
|
||||
echo "$1" : BUG#0 "${@:2}" >> %{skiplist}
|
||||
}
|
||||
|
||||
touch %{skiplist}
|
||||
|
||||
# Fails everywhere; last check: 8.0.14
|
||||
add_test auth_sec.cert_verify :
|
||||
add_test auth_sec.mysql_ssl_connection :
|
||||
add_test auth_sec.openssl_cert_generation :
|
||||
add_test auth_sec.ssl_auto_detect :
|
||||
add_test auth_sec.ssl_mode :
|
||||
add_test auth_sec.tls :
|
||||
add_test binlog.binlog_grant_alter_user :
|
||||
add_test innodb.create_tablespace :
|
||||
add_test main.grant_alter_user_qa :
|
||||
add_test main.grant_user_lock_qa :
|
||||
add_test main.mysqldump :
|
||||
add_test main.mysql_ssl_default :
|
||||
add_test main.openssl_1 :
|
||||
add_test main.plugin_auth_sha256_tls :
|
||||
add_test main.ssl :
|
||||
add_test main.ssl_ca :
|
||||
add_test main.ssl_cipher :
|
||||
add_test main.ssl_compress :
|
||||
add_test main.ssl_crl :
|
||||
add_test main.ssl_verify_identity :
|
||||
add_test main.ssl_8k_key :
|
||||
add_test main.type_float :
|
||||
add_test perfschema.start_server_zero_digest_sql_length :
|
||||
add_test x.connection_openssl :
|
||||
add_test x.connection_openssl_unixsocket :
|
||||
add_test x.connection_tls_version :
|
||||
add_test x.mysqlxtest_mode_ssl :
|
||||
add_test x.mysqlxtest_mode_ssl_unixsocket :
|
||||
|
||||
# Started failing in due to changes in Rawhide after ~25.1.2019
|
||||
add_test main.ctype_utf8 :
|
||||
add_test main.ctype_utf8mb4_heap :
|
||||
add_test main.ctype_utf8mb4_innodb :
|
||||
add_test main.ctype_utf8mb4_myisam :
|
||||
add_test main.regular_expressions_func :
|
||||
add_test main.regular_expressions_utf-8 :
|
||||
|
||||
# These tests fail on ppc64 and ppc64le; last check 8.0.14
|
||||
%ifarch ppc ppc64 ppc64le
|
||||
add_test innodb.instant_add_column_basic :
|
||||
add_test innodb.temporary_table_optimization :
|
||||
add_test json.json_functions_innodb :
|
||||
add_test main.histograms :
|
||||
add_test main.opt_costmodel :
|
||||
add_test main.ps :
|
||||
add_test main.select_all :
|
||||
add_test main.select_all_bka :
|
||||
add_test main.select_all_bka_nixbnl :
|
||||
add_test main.select_icp_mrr :
|
||||
add_test main.select_icp_mrr_bka :
|
||||
add_test main.select_icp_mrr_bka_nixbnl :
|
||||
add_test main.select_none :
|
||||
add_test main.select_none_bka :
|
||||
add_test main.select_none_bka_nixbnl :
|
||||
add_test main.sp :
|
||||
add_test main.type_newdecimal :
|
||||
add_test main.type_ranges :
|
||||
add_test test_service_sql_api.test_sql_all_col_types :
|
||||
add_test x.multiple_resultsets :
|
||||
%endif
|
||||
|
||||
# These tests fail on armv7hl; last check 8.0.14
|
||||
# These tests fail on armv7hl; last check 8.0.16
|
||||
%ifarch %arm aarch64
|
||||
add_test gis.st_latitude :
|
||||
add_test gis.st_longitude :
|
||||
add_test x.connection_auth_mechanism_memory_ssl :
|
||||
add_test x.connection_auth_mechanism_memory_with_invalidation :
|
||||
add_test x.connection_auth_mechanism_memory1 :
|
||||
add_test x.connection_auth_mechanism_memory2 :
|
||||
# Missing hw counters; in 5.7.21 reported as unstable tests
|
||||
add_test perfschema.func_file_io : missing hw on arm32
|
||||
add_test perfschema.func_mutex : missing hw on arm32
|
||||
add_test perfschema.global_read_lock : missing hw on arm32
|
||||
add_test perfschema.setup_objects : missing hw on arm32
|
||||
add_test gis.st_latitude
|
||||
add_test gis.st_longitude
|
||||
# Missing hw counters
|
||||
add_test perfschema.func_file_io missing hw on arm32
|
||||
add_test perfschema.func_mutex missing hw on arm32
|
||||
add_test perfschema.global_read_lock missing hw on arm32
|
||||
add_test perfschema.setup_objects missing hw on arm32
|
||||
%endif
|
||||
|
||||
popd
|
||||
@ -533,6 +463,7 @@ cmake .. \
|
||||
%ifarch s390 s390x
|
||||
-DUSE_LD_GOLD=OFF \
|
||||
%endif
|
||||
-DWITH_ROUTER=OFF \
|
||||
-DWITH_SYSTEM_LIBS=ON \
|
||||
-DWITH_BOOST=../boost \
|
||||
-DREPRODUCIBLE_BUILD=OFF \
|
||||
@ -598,13 +529,7 @@ install -p -m 755 scripts/mysql-check-upgrade %{buildroot}%{_libexecdir}/mysql-c
|
||||
install -p -m 644 scripts/mysql-scripts-common %{buildroot}%{_libexecdir}/mysql-scripts-common
|
||||
install -D -p -m 0644 scripts/server.cnf %{buildroot}%{_sysconfdir}/my.cnf.d/%{pkg_name}-server.cnf
|
||||
|
||||
# mysql-test includes one executable that doesn't belong under /usr/share,
|
||||
# so move it and provide a symlink
|
||||
mv %{buildroot}%{_datadir}/mysql-test/lib/My/SafeProcess/my_safe_process %{buildroot}%{_bindir}
|
||||
ln -s ../../../../../bin/my_safe_process %{buildroot}%{_datadir}/mysql-test/lib/My/SafeProcess/my_safe_process
|
||||
|
||||
rm %{buildroot}%{_libdir}/mysql/*.a
|
||||
rm %{buildroot}%{_datadir}/%{pkg_name}/magic
|
||||
rm %{buildroot}%{_datadir}/%{pkg_name}/mysql.server
|
||||
rm %{buildroot}%{_datadir}/%{pkg_name}/mysqld_multi.server
|
||||
rm %{buildroot}%{_mandir}/man1/comp_err.1*
|
||||
@ -679,7 +604,7 @@ polish,portuguese,romanian,russian,serbian,slovak,spanish,swedish,ukrainian}
|
||||
%endif
|
||||
|
||||
%if %{without test}
|
||||
rm %{buildroot}%{_bindir}/{mysql_client_test,mysqlxtest,my_safe_process}
|
||||
rm %{buildroot}%{_bindir}/{mysql_client_test,mysqlxtest,mysqltest_safe_process}
|
||||
rm -r %{buildroot}%{_datadir}/mysql-test
|
||||
rm %{buildroot}%{_mandir}/man1/mysql_client_test.1*
|
||||
%endif
|
||||
@ -704,7 +629,7 @@ export MTR_BUILD_THREAD=%{__isa_bits}
|
||||
%else
|
||||
--skip-test-list=%{skiplist}
|
||||
%endif
|
||||
rm -r var $(readlink var)
|
||||
rm -r var $(readlink var)
|
||||
popd
|
||||
popd
|
||||
%endif
|
||||
@ -927,12 +852,21 @@ fi
|
||||
%files test
|
||||
%{_bindir}/mysql_client_test
|
||||
%{_bindir}/mysqltest
|
||||
%{_bindir}/mysqltest_safe_process
|
||||
%{_bindir}/mysqlxtest
|
||||
%{_bindir}/my_safe_process
|
||||
%attr(-,mysql,mysql) %{_datadir}/mysql-test
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Apr 26 2019 Lars Tangvald <lars.tangvald@oracle.com> - 8.0.16-1
|
||||
- Update to MySQL 8.0.16
|
||||
- Rediff sharedir patch
|
||||
- Refresh skip list and use new, required format
|
||||
- Remove GCC9 patch now upstream
|
||||
- Upstream: my_safe_process renamed and moved into proper location
|
||||
- Use upstream option to skip router build
|
||||
- OpenSSL 1.1.1 and TLSv1.3 is now supported, enable tests
|
||||
|
||||
* Mon Feb 11 2019 Michal Schorm <mschorm@redhat.com> - 8.0.15-1
|
||||
- Update to MySQL 8.0.15
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mysql-boost-8.0.15.tar.gz) = eda525aa6545b9c62d268d4cdff5b5ba5a286929234a05487b5e13bbed87046811f7fd4e4fc2c4f41432519bd28d7da38ad99c5c10d1d1389b027540a7817bf3
|
||||
SHA512 (mysql-boost-8.0.16.tar.gz) = 4de08d74637d1fef4f570148e66c8ddf2b59d1c0a49d715ca632da7f572645b65ec5f7c115aaf0bd179b0a9f1ba2bc40357c371f170a674118159d99b2c49516
|
||||
|
Loading…
Reference in New Issue
Block a user