- New upstream 2.27.2 release. Drop upstreamed patches.

This commit is contained in:
Peter Robinson 2009-08-11 16:28:22 +00:00
parent 8d7022905e
commit 711ebb6efe
6 changed files with 7 additions and 149 deletions

View File

@ -1 +1 @@
mutter-2.27.1.tar.bz2
mutter-2.27.2.tar.bz2

View File

@ -1,37 +0,0 @@
From acfc4983446139a849c57c8ba001eca372010ab3 Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Wed, 29 Jul 2009 17:04:18 +0000
Subject: Also update Clutter 1.0 pkg-config requirement and README
We need to also change the pkg-config requirement to be 1.0.
---
diff --git a/README b/README
index 66af52b..4ec8f2d 100644
--- a/README
+++ b/README
@@ -20,7 +20,7 @@ libstartup-notification at
http://www.freedesktop.org/software/startup-notification/ or on the
GNOME ftp site. You also need GConf 1.2 (unless building a funky
extra-small embedded metacity with --disable-gconf, see below).
-You need Clutter 0.9.3. You need gobject-introspection 0.6.3.
+You need Clutter 1.0. You need gobject-introspection 0.6.3.
REPORTING BUGS AND SUBMITTING PATCHES
===
diff --git a/configure.in b/configure.in
index a1173d5..b843a68 100644
--- a/configure.in
+++ b/configure.in
@@ -227,8 +227,8 @@ else
AC_MSG_ERROR([no. Mutter requires the Xcomposite extension to build.])
fi
-CLUTTER_VERSION=0.9.3
-CLUTTER_PACKAGE=clutter-0.9
+CLUTTER_VERSION=1.0.0
+CLUTTER_PACKAGE=clutter-1.0
AC_SUBST(CLUTTER_PACKAGE)
if $PKG_CONFIG --atleast-version $CLUTTER_VERSION $CLUTTER_PACKAGE ; then
MUTTER_PC_MODULES="$MUTTER_PC_MODULES $CLUTTER_PACKAGE "
--
cgit v0.8.2

View File

@ -1,24 +0,0 @@
From a1ac1f4b2ec41e6da572a29ff5a1c20bd0e6934c Mon Sep 17 00:00:00 2001
From: Colin Walters <walters@verbum.org>
Date: Wed, 29 Jul 2009 16:08:53 +0000
Subject: Build using Clutter 1.0
Clutter just released 1.0, sync to that.
---
diff --git a/src/Makefile.am b/src/Makefile.am
index b675ab8..2ee9978 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -210,8 +210,8 @@ Meta-$(api_version).gir: $(G_IR_SCANNER) mutter $(libmutterinclude_HEADERS) $(mu
--include=GObject-2.0 \
--include=Gdk-2.0 \
--include=Gtk-2.0 \
- --include=Clutter-0.9 \
- --pkg=clutter-0.9 \
+ --include=Clutter-1.0 \
+ --pkg=clutter-1.0 \
--pkg=gtk+-2.0 \
--include=xfixes-4.0 \
--program=$$pwd/mutter \
--
cgit v0.8.2

View File

@ -1,78 +0,0 @@
From d91d503eb25412432e8aa9b4863d469d5828a4b7 Mon Sep 17 00:00:00 2001
From: Owen W. Taylor <otaylor@fishsoup.net>
Date: Wed, 22 Jul 2009 18:37:43 +0000
Subject: Pass event to clutter when the plugin doesn't have xevent_filter
With recent changes, Clutter no longer sets up the viewport correctly,
unless it receives ConfigureNotify events. If there is a plugin with
an xevent_filter function, then it's that plugins responsibility to pass
the event to Clutter if it doesn't want it. If there is no plugin,
or the plugin doesn't have an xevent_filter function, then we should
call clutter_x11_handle_event() ourselves.
http://bugzilla.gnome.org/show_bug.cgi?id=589419
---
diff --git a/src/compositor/mutter-plugin-manager.c b/src/compositor/mutter-plugin-manager.c
index 98d3f19..9d8ae74 100644
--- a/src/compositor/mutter-plugin-manager.c
+++ b/src/compositor/mutter-plugin-manager.c
@@ -30,6 +30,8 @@
#include <string.h>
+#include <clutter/x11/clutter-x11.h>
+
/*
* There is only one instace of each module per the process.
*/
@@ -585,12 +587,31 @@ mutter_plugin_manager_xevent_filter (MutterPluginManager *plugin_mgr,
XEvent *xev)
{
GList *l;
+ gboolean have_plugin_xevent_func;
if (!plugin_mgr)
return FALSE;
l = plugin_mgr->plugins;
+ /* We need to make sure that clutter gets certain events, like
+ * ConfigureNotify on the stage window. If there is a plugin that
+ * provides an xevent_filter function, then it's the responsibility
+ * of that plugin to pass events to Clutter. Otherwise, we send the
+ * event directly to Clutter ourselves.
+ *
+ * What happens if there are two plugins with xevent_filter functions
+ * is undefined; in general, multiple competing plugins are something
+ * we don't support well or care much about.
+ *
+ * FIXME: Really, we should just always handle sending the event to
+ * clutter if a plugin doesn't report the event as handled by
+ * returning TRUE, but it doesn't seem worth breaking compatibility
+ * of the plugin interface right now to achieve this; the way it is
+ * now works fine in practice.
+ */
+ have_plugin_xevent_func = FALSE;
+
while (l)
{
MutterPlugin *plugin = l->data;
@@ -598,6 +619,7 @@ mutter_plugin_manager_xevent_filter (MutterPluginManager *plugin_mgr,
if (klass->xevent_filter)
{
+ have_plugin_xevent_func = TRUE;
if (klass->xevent_filter (plugin, xev) == TRUE)
return TRUE;
}
@@ -605,5 +627,8 @@ mutter_plugin_manager_xevent_filter (MutterPluginManager *plugin_mgr,
l = l->next;
}
+ if (!have_plugin_xevent_func)
+ return clutter_x11_handle_event (xev) != CLUTTER_X11_FILTER_CONTINUE;
+
return FALSE;
}
--
cgit v0.8.2

View File

@ -1,15 +1,12 @@
Name: mutter
Version: 2.27.1
Release: 5%{?dist}
Version: 2.27.2
Release: 1%{?dist}
Summary: Window and compositing manager based on Clutter
Group: User Interface/Desktops
License: GPLv2+
URL: http://git.gnome.org/cgit/mutter
Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.27/%{name}-%{version}.tar.bz2
Patch0: mutter-pluginmanager.patch
Patch1: mutter-clutter1.0.patch
Patch2: mutter-clutter-1.0-2.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: clutter-devel
@ -71,9 +68,6 @@ utilities for testing Metacity/Mutter themes.
%prep
%setup -q
%patch0 -p1 -b .pluginmanager
%patch1 -p1 -b .clutter1
%patch2 -p1 -b .clutter2
%build
autoreconf
@ -161,6 +155,9 @@ gconftool-2 --makefile-install-rule \
%doc %{_mandir}/man1/mutter-window-demo.1.gz
%changelog
* Tue Aug 11 2009 Peter Robinson <pbrobinson@gmail.com> 2.27.2-1
- New upstream 2.27.2 release. Drop upstreamed patches.
* Wed Jul 29 2009 Peter Robinson <pbrobinson@gmail.com> 2.27.1-5
- Add upstream patches for clutter 1.0

View File

@ -1 +1 @@
973f59241bb1554bc046bd0ac4aea564 mutter-2.27.1.tar.bz2
9b7e9ffcb14e90c9f31c973383a1a432 mutter-2.27.2.tar.bz2