- Add upstream patches for clutter 1.0
This commit is contained in:
parent
895e688a7b
commit
8d7022905e
37
mutter-clutter-1.0-2.patch
Normal file
37
mutter-clutter-1.0-2.patch
Normal file
@ -0,0 +1,37 @@
|
||||
From acfc4983446139a849c57c8ba001eca372010ab3 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Wed, 29 Jul 2009 17:04:18 +0000
|
||||
Subject: Also update Clutter 1.0 pkg-config requirement and README
|
||||
|
||||
We need to also change the pkg-config requirement to be 1.0.
|
||||
---
|
||||
diff --git a/README b/README
|
||||
index 66af52b..4ec8f2d 100644
|
||||
--- a/README
|
||||
+++ b/README
|
||||
@@ -20,7 +20,7 @@ libstartup-notification at
|
||||
http://www.freedesktop.org/software/startup-notification/ or on the
|
||||
GNOME ftp site. You also need GConf 1.2 (unless building a funky
|
||||
extra-small embedded metacity with --disable-gconf, see below).
|
||||
-You need Clutter 0.9.3. You need gobject-introspection 0.6.3.
|
||||
+You need Clutter 1.0. You need gobject-introspection 0.6.3.
|
||||
|
||||
REPORTING BUGS AND SUBMITTING PATCHES
|
||||
===
|
||||
diff --git a/configure.in b/configure.in
|
||||
index a1173d5..b843a68 100644
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -227,8 +227,8 @@ else
|
||||
AC_MSG_ERROR([no. Mutter requires the Xcomposite extension to build.])
|
||||
fi
|
||||
|
||||
-CLUTTER_VERSION=0.9.3
|
||||
-CLUTTER_PACKAGE=clutter-0.9
|
||||
+CLUTTER_VERSION=1.0.0
|
||||
+CLUTTER_PACKAGE=clutter-1.0
|
||||
AC_SUBST(CLUTTER_PACKAGE)
|
||||
if $PKG_CONFIG --atleast-version $CLUTTER_VERSION $CLUTTER_PACKAGE ; then
|
||||
MUTTER_PC_MODULES="$MUTTER_PC_MODULES $CLUTTER_PACKAGE "
|
||||
--
|
||||
cgit v0.8.2
|
24
mutter-clutter1.0.patch
Normal file
24
mutter-clutter1.0.patch
Normal file
@ -0,0 +1,24 @@
|
||||
From a1ac1f4b2ec41e6da572a29ff5a1c20bd0e6934c Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Wed, 29 Jul 2009 16:08:53 +0000
|
||||
Subject: Build using Clutter 1.0
|
||||
|
||||
Clutter just released 1.0, sync to that.
|
||||
---
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index b675ab8..2ee9978 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -210,8 +210,8 @@ Meta-$(api_version).gir: $(G_IR_SCANNER) mutter $(libmutterinclude_HEADERS) $(mu
|
||||
--include=GObject-2.0 \
|
||||
--include=Gdk-2.0 \
|
||||
--include=Gtk-2.0 \
|
||||
- --include=Clutter-0.9 \
|
||||
- --pkg=clutter-0.9 \
|
||||
+ --include=Clutter-1.0 \
|
||||
+ --pkg=clutter-1.0 \
|
||||
--pkg=gtk+-2.0 \
|
||||
--include=xfixes-4.0 \
|
||||
--program=$$pwd/mutter \
|
||||
--
|
||||
cgit v0.8.2
|
17
mutter.spec
17
mutter.spec
@ -1,6 +1,6 @@
|
||||
Name: mutter
|
||||
Version: 2.27.1
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Window and compositing manager based on Clutter
|
||||
|
||||
Group: User Interface/Desktops
|
||||
@ -8,6 +8,8 @@ License: GPLv2+
|
||||
URL: http://git.gnome.org/cgit/mutter
|
||||
Source0: ftp://ftp.gnome.org/pub/gnome/sources/%{name}/2.27/%{name}-%{version}.tar.bz2
|
||||
Patch0: mutter-pluginmanager.patch
|
||||
Patch1: mutter-clutter1.0.patch
|
||||
Patch2: mutter-clutter-1.0-2.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: clutter-devel
|
||||
@ -31,6 +33,13 @@ BuildRequires: intltool
|
||||
BuildRequires: gnome-doc-utils
|
||||
BuildRequires: desktop-file-utils
|
||||
|
||||
# Add these due to the autoreconf for the clutter patches
|
||||
BuildRequires: intltool
|
||||
BuildRequires: gettext
|
||||
BuildRequires: libtool
|
||||
BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
|
||||
Requires: control-center-filesystem
|
||||
Requires: startup-notification
|
||||
Requires: GConf2
|
||||
@ -63,8 +72,11 @@ utilities for testing Metacity/Mutter themes.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .pluginmanager
|
||||
%patch1 -p1 -b .clutter1
|
||||
%patch2 -p1 -b .clutter2
|
||||
|
||||
%build
|
||||
autoreconf
|
||||
%configure --with-clutter --disable-static
|
||||
|
||||
SHOULD_HAVE_DEFINED="HAVE_SM HAVE_XINERAMA HAVE_XFREE_XINERAMA HAVE_SHAPE HAVE_RANDR HAVE_STARTUP_NOTIFICATION HAVE_COMPOSITE_EXTENSION"
|
||||
@ -149,6 +161,9 @@ gconftool-2 --makefile-install-rule \
|
||||
%doc %{_mandir}/man1/mutter-window-demo.1.gz
|
||||
|
||||
%changelog
|
||||
* Wed Jul 29 2009 Peter Robinson <pbrobinson@gmail.com> 2.27.1-5
|
||||
- Add upstream patches for clutter 1.0
|
||||
|
||||
* Wed Jul 29 2009 Peter Robinson <pbrobinson@gmail.com> 2.27.1-4
|
||||
- Add patch to fix mutter --replace
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user