Update to 1.8.0
This commit is contained in:
parent
0530d090aa
commit
f3da5468cb
1
.gitignore
vendored
1
.gitignore
vendored
@ -23,3 +23,4 @@
|
||||
/harfbuzz-1.4.4.tar.bz2
|
||||
/harfbuzz-1.4.8.tar.bz2
|
||||
/harfbuzz-1.7.6.tar.bz2
|
||||
/harfbuzz-1.8.0.tar.bz2
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff -rupN harfbuzz-1.7.6/configure.ac harfbuzz-1.7.6-new/configure.ac
|
||||
--- harfbuzz-1.7.6/configure.ac 2018-03-07 15:56:39.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/configure.ac 2018-05-29 18:07:02.832946432 +0200
|
||||
@@ -489,6 +489,30 @@ fi
|
||||
diff -rupN harfbuzz-1.8.0/configure.ac harfbuzz-1.8.0-new/configure.ac
|
||||
--- harfbuzz-1.8.0/configure.ac 2018-06-06 03:00:50.000000000 +0200
|
||||
+++ harfbuzz-1.8.0-new/configure.ac 2018-06-08 15:04:05.953353503 +0200
|
||||
@@ -503,6 +503,30 @@ fi
|
||||
|
||||
dnl ===========================================================================
|
||||
|
||||
@ -32,16 +32,16 @@ diff -rupN harfbuzz-1.7.6/configure.ac harfbuzz-1.7.6-new/configure.ac
|
||||
AC_CONFIG_FILES([
|
||||
Makefile
|
||||
src/Makefile
|
||||
@@ -539,4 +563,5 @@ Other features:
|
||||
@@ -553,4 +577,5 @@ Other features:
|
||||
Documentation: ${enable_gtk_doc}
|
||||
GObject bindings: ${have_gobject}
|
||||
Introspection: ${have_introspection}
|
||||
+ Enable delay loading: ${enable_delay_load}
|
||||
])
|
||||
diff -rupN harfbuzz-1.7.6/src/Makefile.am harfbuzz-1.7.6-new/src/Makefile.am
|
||||
--- harfbuzz-1.7.6/src/Makefile.am 2018-03-03 22:51:25.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/src/Makefile.am 2018-05-29 18:07:02.833946432 +0200
|
||||
@@ -64,14 +64,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||
diff -rupN harfbuzz-1.8.0/src/Makefile.am harfbuzz-1.8.0-new/src/Makefile.am
|
||||
--- harfbuzz-1.8.0/src/Makefile.am 2018-06-06 00:30:53.000000000 +0200
|
||||
+++ harfbuzz-1.8.0-new/src/Makefile.am 2018-06-08 15:04:05.954353503 +0200
|
||||
@@ -52,14 +52,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||
endif
|
||||
|
||||
if HAVE_FREETYPE
|
||||
@ -72,12 +72,12 @@ diff -rupN harfbuzz-1.7.6/src/Makefile.am harfbuzz-1.7.6-new/src/Makefile.am
|
||||
HBSOURCES += $(HB_FT_sources)
|
||||
HBHEADERS += $(HB_FT_headers)
|
||||
endif
|
||||
@@ -150,9 +165,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS) $(CODE_COVERAGE_LDFLAGS)
|
||||
@@ -138,9 +153,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS)
|
||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(HBNOLIBCXXFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||
-libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols)
|
||||
+libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols) $(harfbuzz_delayload_ldflags)
|
||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||
-libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols) $(CODE_COVERAGE_LDFLAGS)
|
||||
+libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols) $(CODE_COVERAGE_LDFLAGS) $(harfbuzz_delayload_ldflags)
|
||||
libharfbuzz_la_LIBADD = $(HBLIBS)
|
||||
-EXTRA_libharfbuzz_la_DEPENDENCIES = $(harfbuzz_def_dependency)
|
||||
+EXTRA_libharfbuzz_la_DEPENDENCIES = $(harfbuzz_def_dependency) $(harfbuzz_delayload_dependency)
|
||||
|
@ -1,9 +1,9 @@
|
||||
diff -rupN harfbuzz-1.7.6/src/gen-def.py harfbuzz-1.7.6-new/src/gen-def.py
|
||||
--- harfbuzz-1.7.6/src/gen-def.py 2018-02-14 01:27:23.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/src/gen-def.py 2018-05-29 18:07:02.880946430 +0200
|
||||
diff -rupN harfbuzz-1.8.0/src/gen-def.py harfbuzz-1.8.0-new/src/gen-def.py
|
||||
--- harfbuzz-1.8.0/src/gen-def.py 2018-06-03 00:39:30.000000000 +0200
|
||||
+++ harfbuzz-1.8.0-new/src/gen-def.py 2018-06-08 15:04:06.006353500 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from __future__ import print_function
|
||||
from __future__ import print_function, division, absolute_import
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
%{?mingw_package_header}
|
||||
|
||||
Name: mingw-harfbuzz
|
||||
Version: 1.7.6
|
||||
Version: 1.8.0
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows Harfbuzz library
|
||||
|
||||
@ -142,6 +142,9 @@ find %{buildroot} -name "*.la" -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 08 2018 Sandro Mani <manisandro@gmail.com> - 1.8.0-1
|
||||
- Update to 1.8.0
|
||||
|
||||
* Tue May 29 2018 Sandro Mani <manisandro@gmail.com> - 1.7.6-1
|
||||
- Update to 1.7.6
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (harfbuzz-1.7.6.tar.bz2) = 259656574b1ec2916ada951b759a591f45c11c5c639fa29831e06320312bf951f4f5ef6306f9ffc373abf0d40dbf944db918d4c54aca3bd7eab2c3a886db7a68
|
||||
SHA512 (harfbuzz-1.8.0.tar.bz2) = 90cccdaa45bbd7b5a75c9600d49e15dea820f0db4f9e4eda2c451092000281657a2ecb281b574d339e84e72842e978f5cbf505845fa573e6b76382192d8dd4fb
|
||||
|
Loading…
Reference in New Issue
Block a user