Update to 1.7.6
This commit is contained in:
parent
9da813a4b5
commit
0530d090aa
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/harfbuzz-1.3.2.tar.bz2
|
||||
/harfbuzz-1.4.4.tar.bz2
|
||||
/harfbuzz-1.4.8.tar.bz2
|
||||
/harfbuzz-1.7.6.tar.bz2
|
||||
|
@ -1,6 +1,7 @@
|
||||
--- harfbuzz-1.1.2/configure.ac.orig 2015-12-31 15:58:04.284354714 +0100
|
||||
+++ harfbuzz-1.1.2/configure.ac 2015-12-31 16:08:46.848239317 +0100
|
||||
@@ -432,6 +432,30 @@
|
||||
diff -rupN harfbuzz-1.7.6/configure.ac harfbuzz-1.7.6-new/configure.ac
|
||||
--- harfbuzz-1.7.6/configure.ac 2018-03-07 15:56:39.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/configure.ac 2018-05-29 18:07:02.832946432 +0200
|
||||
@@ -489,6 +489,30 @@ fi
|
||||
|
||||
dnl ===========================================================================
|
||||
|
||||
@ -31,15 +32,16 @@
|
||||
AC_CONFIG_FILES([
|
||||
Makefile
|
||||
src/Makefile
|
||||
@@ -475,4 +499,5 @@
|
||||
Documentation: ${have_gtk_doc}
|
||||
@@ -539,4 +563,5 @@ Other features:
|
||||
Documentation: ${enable_gtk_doc}
|
||||
GObject bindings: ${have_gobject}
|
||||
Introspection: ${have_introspection}
|
||||
+ Enable delay loading: ${enable_delay_load}
|
||||
])
|
||||
--- harfbuzz-1.2.6/src/Makefile.am.orig 2016-03-15 23:14:32.000000000 +0100
|
||||
+++ harfbuzz-1.2.6/src/Makefile.am 2016-04-09 22:32:19.462635695 +0200
|
||||
@@ -51,14 +51,29 @@
|
||||
diff -rupN harfbuzz-1.7.6/src/Makefile.am harfbuzz-1.7.6-new/src/Makefile.am
|
||||
--- harfbuzz-1.7.6/src/Makefile.am 2018-03-03 22:51:25.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/src/Makefile.am 2018-05-29 18:07:02.833946432 +0200
|
||||
@@ -64,14 +64,29 @@ HBHEADERS += $(HB_GLIB_headers)
|
||||
endif
|
||||
|
||||
if HAVE_FREETYPE
|
||||
@ -70,15 +72,15 @@
|
||||
HBSOURCES += $(HB_FT_sources)
|
||||
HBHEADERS += $(HB_FT_headers)
|
||||
endif
|
||||
@@ -120,9 +135,9 @@
|
||||
|
||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS) $(HBNODISTHEADERS)
|
||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS)
|
||||
-libharfbuzz_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(HB_LIBTOOL_VERSION_INFO) $(export_symbols) -no-undefined
|
||||
+libharfbuzz_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(HB_LIBTOOL_VERSION_INFO) $(export_symbols) -no-undefined $(harfbuzz_delayload_ldflags)
|
||||
@@ -150,9 +165,9 @@ base_link_flags = $(AM_LDFLAGS) -lm -ver
|
||||
libharfbuzz_la_LINK = $(chosen_linker) $(libharfbuzz_la_LDFLAGS) $(CODE_COVERAGE_LDFLAGS)
|
||||
libharfbuzz_la_SOURCES = $(HBSOURCES) $(HBHEADERS)
|
||||
libharfbuzz_la_CPPFLAGS = $(HBCFLAGS) $(HBNOLIBCXXFLAGS) $(CODE_COVERAGE_CFLAGS)
|
||||
-libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols)
|
||||
+libharfbuzz_la_LDFLAGS = $(base_link_flags) $(export_symbols) $(harfbuzz_delayload_ldflags)
|
||||
libharfbuzz_la_LIBADD = $(HBLIBS)
|
||||
-EXTRA_libharfbuzz_la_DEPENDENCIES = $(harfbuzz_def_dependency)
|
||||
+EXTRA_libharfbuzz_la_DEPENDENCIES = $(harfbuzz_def_dependency) $(harfbuzz_delayload_dependency)
|
||||
pkginclude_HEADERS = $(HBHEADERS)
|
||||
nodist_pkginclude_HEADERS = $(HBNODISTHEADERS)
|
||||
nodist_pkginclude_HEADERS =
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
|
9
harfbuzz-python.patch
Normal file
9
harfbuzz-python.patch
Normal file
@ -0,0 +1,9 @@
|
||||
diff -rupN harfbuzz-1.7.6/src/gen-def.py harfbuzz-1.7.6-new/src/gen-def.py
|
||||
--- harfbuzz-1.7.6/src/gen-def.py 2018-02-14 01:27:23.000000000 +0100
|
||||
+++ harfbuzz-1.7.6-new/src/gen-def.py 2018-05-29 18:07:02.880946430 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/python3
|
||||
|
||||
from __future__ import print_function
|
||||
|
@ -1,8 +1,8 @@
|
||||
%{?mingw_package_header}
|
||||
|
||||
Name: mingw-harfbuzz
|
||||
Version: 1.4.8
|
||||
Release: 2%{?dist}
|
||||
Version: 1.7.6
|
||||
Release: 1%{?dist}
|
||||
Summary: MinGW Windows Harfbuzz library
|
||||
|
||||
License: MIT
|
||||
@ -11,9 +11,13 @@ Source0: http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-%{
|
||||
|
||||
# Allow the freetype dependency to be optional at runtime
|
||||
Patch0: harfbuzz-enable-delayload-freetype.patch
|
||||
# Invoke versioned python
|
||||
Patch1: harfbuzz-python.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
BuildRequires: python3
|
||||
|
||||
BuildRequires: mingw32-filesystem >= 95
|
||||
BuildRequires: mingw32-gcc
|
||||
BuildRequires: mingw32-glib2
|
||||
@ -72,8 +76,7 @@ Static version of the MinGW Windows Harfbuzz library.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n harfbuzz-%{version}
|
||||
%patch0 -p1
|
||||
%autosetup -p1 -n harfbuzz-%{version}
|
||||
autoreconf -i --force
|
||||
|
||||
|
||||
@ -83,10 +86,10 @@ autoreconf -i --force
|
||||
|
||||
|
||||
%install
|
||||
%mingw_make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%mingw_make install DESTDIR=%{buildroot}
|
||||
|
||||
# Drop all .la files
|
||||
find $RPM_BUILD_ROOT -name "*.la" -delete
|
||||
find %{buildroot} -name "*.la" -delete
|
||||
|
||||
|
||||
# Win32
|
||||
@ -94,39 +97,54 @@ find $RPM_BUILD_ROOT -name "*.la" -delete
|
||||
%license COPYING
|
||||
%{mingw32_bindir}/hb-ot-shape-closure.exe
|
||||
%{mingw32_bindir}/hb-shape.exe
|
||||
%{mingw32_bindir}/hb-subset.exe
|
||||
%{mingw32_bindir}/hb-view.exe
|
||||
%{mingw32_bindir}/libharfbuzz-0.dll
|
||||
%{mingw32_bindir}/libharfbuzz-icu-0.dll
|
||||
%{mingw32_bindir}/libharfbuzz-subset-0.dll
|
||||
%{mingw32_includedir}/harfbuzz/
|
||||
%{mingw32_libdir}/libharfbuzz.dll.a
|
||||
%{mingw32_libdir}/libharfbuzz-icu.dll.a
|
||||
%{mingw32_libdir}/libharfbuzz-subset.dll.a
|
||||
%{mingw32_libdir}/pkgconfig/harfbuzz.pc
|
||||
%{mingw32_libdir}/pkgconfig/harfbuzz-icu.pc
|
||||
%{mingw32_libdir}/pkgconfig/harfbuzz-subset.pc
|
||||
%{mingw32_libdir}/cmake/harfbuzz/
|
||||
|
||||
%files -n mingw32-harfbuzz-static
|
||||
%{mingw32_libdir}/libharfbuzz.a
|
||||
%{mingw32_libdir}/libharfbuzz-icu.a
|
||||
%{mingw32_libdir}/libharfbuzz-subset.a
|
||||
|
||||
# Win64
|
||||
%files -n mingw64-harfbuzz
|
||||
%license COPYING
|
||||
%{mingw64_bindir}/hb-ot-shape-closure.exe
|
||||
%{mingw64_bindir}/hb-shape.exe
|
||||
%{mingw64_bindir}/hb-subset.exe
|
||||
%{mingw64_bindir}/hb-view.exe
|
||||
%{mingw64_bindir}/libharfbuzz-0.dll
|
||||
%{mingw64_bindir}/libharfbuzz-icu-0.dll
|
||||
%{mingw64_bindir}/libharfbuzz-subset-0.dll
|
||||
%{mingw64_includedir}/harfbuzz/
|
||||
%{mingw64_libdir}/libharfbuzz.dll.a
|
||||
%{mingw64_libdir}/libharfbuzz-icu.dll.a
|
||||
%{mingw64_libdir}/libharfbuzz-subset.dll.a
|
||||
%{mingw64_libdir}/pkgconfig/harfbuzz.pc
|
||||
%{mingw64_libdir}/pkgconfig/harfbuzz-icu.pc
|
||||
%{mingw64_libdir}/pkgconfig/harfbuzz-subset.pc
|
||||
%{mingw64_libdir}/cmake/harfbuzz/
|
||||
|
||||
%files -n mingw64-harfbuzz-static
|
||||
%{mingw64_libdir}/libharfbuzz.a
|
||||
%{mingw64_libdir}/libharfbuzz-icu.a
|
||||
%{mingw64_libdir}/libharfbuzz-subset.a
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue May 29 2018 Sandro Mani <manisandro@gmail.com> - 1.7.6-1
|
||||
- Update to 1.7.6
|
||||
|
||||
* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.8-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (harfbuzz-1.4.8.tar.bz2) = 056a2c02f803439b39086e3ea988e424f5512b3213844f9008c62f5448a8ccdba525f532e7ed54641820a4ef6dc5bc4d13d4f7bfb39ff904f5939c855d294152
|
||||
SHA512 (harfbuzz-1.7.6.tar.bz2) = 259656574b1ec2916ada951b759a591f45c11c5c639fa29831e06320312bf951f4f5ef6306f9ffc373abf0d40dbf944db918d4c54aca3bd7eab2c3a886db7a68
|
||||
|
Loading…
Reference in New Issue
Block a user