Revert "Mesa 10.0 release branch git snapshot"
This reverts commit fee912ca11
.
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
fee912ca11
commit
f5c756cfd1
1
.gitignore
vendored
1
.gitignore
vendored
@ -59,4 +59,3 @@ mesa-20100720.tar.bz2
|
|||||||
/mesa-20131113.tar.xz
|
/mesa-20131113.tar.xz
|
||||||
/mesa-20131114.tar.xz
|
/mesa-20131114.tar.xz
|
||||||
/mesa-20131128.tar.xz
|
/mesa-20131128.tar.xz
|
||||||
/mesa-20131205.tar.xz
|
|
||||||
|
@ -15,11 +15,11 @@ DIRNAME=mesa-$( date +%Y%m%d )
|
|||||||
|
|
||||||
echo REF ${REF:+--reference $REF}
|
echo REF ${REF:+--reference $REF}
|
||||||
echo DIRNAME $DIRNAME
|
echo DIRNAME $DIRNAME
|
||||||
echo HEAD ${1:-10.0}
|
echo HEAD ${1:-9.2}
|
||||||
|
|
||||||
rm -rf $DIRNAME
|
rm -rf $DIRNAME
|
||||||
|
|
||||||
git clone --depth 1 ${REF:+--reference $REF} --branch 10.0 \
|
git clone --depth 1 ${REF:+--reference $REF} --branch 9.2 \
|
||||||
git://git.freedesktop.org/git/mesa/mesa $DIRNAME
|
git://git.freedesktop.org/git/mesa/mesa $DIRNAME
|
||||||
|
|
||||||
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
|
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
|
||||||
|
13
mesa.spec
13
mesa.spec
@ -48,12 +48,12 @@
|
|||||||
|
|
||||||
%define _default_patch_fuzz 2
|
%define _default_patch_fuzz 2
|
||||||
|
|
||||||
%define gitdate 20131205
|
%define gitdate 20131128
|
||||||
#% define snapshot
|
#% define snapshot
|
||||||
|
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 10.0
|
Version: 9.2.4
|
||||||
Release: 1.%{gitdate}%{?dist}
|
Release: 1.%{gitdate}%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -299,7 +299,7 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||||||
#patch12 -p1 -b .16bpp
|
#patch12 -p1 -b .16bpp
|
||||||
|
|
||||||
%patch15 -p1 -b .hwfloat
|
%patch15 -p1 -b .hwfloat
|
||||||
#patch16 -p1 -b .vdpau
|
%patch16 -p1 -b .vdpau
|
||||||
%patch20 -p1 -b .egbe
|
%patch20 -p1 -b .egbe
|
||||||
|
|
||||||
%if 0%{with_private_llvm}
|
%if 0%{with_private_llvm}
|
||||||
@ -480,11 +480,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%if 0%{?with_vmware}
|
%if 0%{?with_vmware}
|
||||||
%{_libdir}/dri/vmwgfx_dri.so
|
%{_libdir}/dri/vmwgfx_dri.so
|
||||||
%endif
|
%endif
|
||||||
|
%{_libdir}/libdricore*.so*
|
||||||
%endif
|
%endif
|
||||||
# this is funky; it doesn't get built for gallium drivers, so it doesn't
|
# this is funky; it doesn't get built for gallium drivers, so it doesn't
|
||||||
# exist on s390x where swrast is llvmpipe, but does exist on s390 where
|
# exist on s390x where swrast is llvmpipe, but does exist on s390 where
|
||||||
# swrast is classic mesa. this seems like a bug? in that it probably
|
# swrast is classic mesa. this seems like a bug? in that it probably
|
||||||
# means the gallium drivers are linking dricore statically? fixme.
|
# means the gallium drivers are linking dricore statically? fixme.
|
||||||
|
%ifarch s390
|
||||||
|
%{_libdir}/libdricore*.so*
|
||||||
|
%endif
|
||||||
%{_libdir}/dri/swrast_dri.so
|
%{_libdir}/dri/swrast_dri.so
|
||||||
|
|
||||||
%if %{with_hardware}
|
%if %{with_hardware}
|
||||||
@ -596,9 +600,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Thu Dec 05 2013 Dave Airlie <airlied@redhat.com> 10.0-1.20131205
|
|
||||||
- mesa 10.0 release branch git snapshot
|
|
||||||
|
|
||||||
* Thu Nov 28 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 9.2.4-1.20131128
|
* Thu Nov 28 2013 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 9.2.4-1.20131128
|
||||||
- 9.2.4 upstream release
|
- 9.2.4 upstream release
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up mesa-20130213/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp.rtti mesa-20130213/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp
|
diff -up mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp.rtti mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp
|
||||||
--- mesa-20130213/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp.rtti 2013-02-13 18:08:17.533677028 +1000
|
--- mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp.rtti 2013-02-13 18:08:17.533677028 +1000
|
||||||
+++ mesa-20130213/src/gallium/drivers/nouveau/codegen/nv50_ir.cpp 2013-02-13 18:08:20.496752128 +1000
|
+++ mesa-20130213/src/gallium/drivers/nv50/codegen/nv50_ir.cpp 2013-02-13 18:08:20.496752128 +1000
|
||||||
@@ -716,7 +716,7 @@ Instruction::clone(ClonePolicy<Function>
|
@@ -716,7 +716,7 @@ Instruction::clone(ClonePolicy<Function>
|
||||||
if (!i)
|
if (!i)
|
||||||
i = new_Instruction(pol.context(), op, dType);
|
i = new_Instruction(pol.context(), op, dType);
|
||||||
|
@ -20,9 +20,14 @@ pushd $dirname
|
|||||||
|
|
||||||
cat > src/gallium/auxiliary/vl/vl_mpeg12_decoder.c << EOF
|
cat > src/gallium/auxiliary/vl/vl_mpeg12_decoder.c << EOF
|
||||||
#include "vl_mpeg12_decoder.h"
|
#include "vl_mpeg12_decoder.h"
|
||||||
struct pipe_video_codec *
|
struct pipe_video_decoder *
|
||||||
vl_create_mpeg12_decoder(struct pipe_context *pipe,
|
vl_create_mpeg12_decoder(struct pipe_context *context,
|
||||||
const struct pipe_video_codec *templat)
|
enum pipe_video_profile profile,
|
||||||
|
enum pipe_video_entrypoint entrypoint,
|
||||||
|
enum pipe_video_chroma_format chroma_format,
|
||||||
|
unsigned width, unsigned height,
|
||||||
|
unsigned max_references,
|
||||||
|
bool expect_chunked_decode)
|
||||||
{
|
{
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
@ -31,14 +36,17 @@ EOF
|
|||||||
cat > src/gallium/auxiliary/vl/vl_decoder.c << EOF
|
cat > src/gallium/auxiliary/vl/vl_decoder.c << EOF
|
||||||
#include "vl_decoder.h"
|
#include "vl_decoder.h"
|
||||||
bool vl_profile_supported(struct pipe_screen *screen,
|
bool vl_profile_supported(struct pipe_screen *screen,
|
||||||
enum pipe_video_profile profile,
|
enum pipe_video_profile profile)
|
||||||
enum pipe_video_entrypoint entrypoint)
|
|
||||||
{
|
{
|
||||||
return false;
|
return false;
|
||||||
}
|
}
|
||||||
struct pipe_video_codec *
|
struct pipe_video_decoder *
|
||||||
vl_create_decoder(struct pipe_context *pipe,
|
vl_create_decoder(struct pipe_context *pipe,
|
||||||
const struct pipe_video_codec *templat)
|
enum pipe_video_profile profile,
|
||||||
|
enum pipe_video_entrypoint entrypoint,
|
||||||
|
enum pipe_video_chroma_format chroma_format,
|
||||||
|
unsigned width, unsigned height, unsigned max_references,
|
||||||
|
bool expect_chunked_decode)
|
||||||
{
|
{
|
||||||
return NULL;
|
return NULL;
|
||||||
}
|
}
|
||||||
|
Loading…
Reference in New Issue
Block a user