rebase to 20 June snapshot from upstream - new gallium config options
This commit is contained in:
parent
15630b359e
commit
d82d9c8abb
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@ mesa-20100720.tar.bz2
|
||||
/mesa-20110330.tar.xz
|
||||
/mesa-20110401.tar.xz
|
||||
/mesa-20110412.tar.xz
|
||||
/mesa-20110620.tar.xz
|
||||
|
@ -1,12 +1,12 @@
|
||||
diff -up mesa-20100529/configure.ac.nouveau mesa-20100529/configure.ac
|
||||
--- mesa-20100529/configure.ac.nouveau 2010-05-29 18:57:30.000000000 +1000
|
||||
+++ mesa-20100529/configure.ac 2010-05-29 18:58:24.000000000 +1000
|
||||
@@ -820,20 +820,20 @@ if test "$mesa_driver" = dri; then
|
||||
diff -up mesa-20110620/configure.ac.classic mesa-20110620/configure.ac
|
||||
--- mesa-20110620/configure.ac.classic 2011-06-20 13:52:52.000000000 +1000
|
||||
+++ mesa-20110620/configure.ac 2011-06-20 13:55:09.000000000 +1000
|
||||
@@ -1023,20 +1023,20 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
# x86-64 system where they could *ever* be used.
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
||||
- savage tdfx unichrome swrast"
|
||||
+ savage tdfx unichrome nouveau"
|
||||
DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
|
||||
- radeon savage tdfx unichrome swrast"
|
||||
+ radeon savage tdfx unichrome"
|
||||
fi
|
||||
;;
|
||||
powerpc*)
|
||||
@ -25,12 +25,12 @@ diff -up mesa-20100529/configure.ac.nouveau mesa-20100529/configure.ac
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
@@ -870,7 +870,7 @@ if test "$mesa_driver" = dri; then
|
||||
@@ -1080,7 +1080,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
# default drivers
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
||||
DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
|
||||
- savage sis tdfx unichrome swrast"
|
||||
+ savage sis tdfx unichrome nouveau"
|
||||
+ savage sis tdfx unichrome"
|
||||
fi
|
||||
|
||||
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
|
||||
|
@ -1,15 +1,15 @@
|
||||
diff -up mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c.dave mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c
|
||||
--- mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c.dave 2010-05-30 18:24:35.000000000 +1000
|
||||
+++ mesa-20100529/src/mesa/drivers/dri/intel/intel_fbo.c 2010-05-30 18:24:42.000000000 +1000
|
||||
@@ -558,11 +558,6 @@ intel_render_texture(GLcontext * ctx,
|
||||
diff -up mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c
|
||||
--- mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da 2011-06-20 13:51:25.000000000 +1000
|
||||
+++ mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c 2011-06-20 13:51:32.000000000 +1000
|
||||
@@ -612,11 +612,6 @@ intel_render_texture(struct gl_context *
|
||||
return;
|
||||
}
|
||||
|
||||
- DBG("Begin render texture tid %lx tex=%u w=%d h=%d refcount=%d\n",
|
||||
- _glthread_GetID(),
|
||||
- att->Texture->Name, newImage->Width, newImage->Height,
|
||||
- att->Texture->Name, image->Width, image->Height,
|
||||
- irb->Base.RefCount);
|
||||
-
|
||||
/* point the renderbufer's region to the texture image region */
|
||||
if (irb->region != intel_image->mt->region) {
|
||||
if (irb->region)
|
||||
intel_renderbuffer_set_draw_offset(irb, intel_image, att->Zoffset);
|
||||
intel_image->used_as_render_target = GL_TRUE;
|
||||
|
||||
|
@ -1,16 +1,16 @@
|
||||
diff -up mesa-20100529/configure.ac.mach64 mesa-20100529/configure.ac
|
||||
--- mesa-20100529/configure.ac.mach64 2010-05-29 11:31:22.000000000 +1000
|
||||
+++ mesa-20100529/configure.ac 2010-05-29 18:53:55.000000000 +1000
|
||||
@@ -819,7 +819,7 @@ if test "$mesa_driver" = dri; then
|
||||
diff -up mesa-20110620/configure.ac.no-mach64 mesa-20110620/configure.ac
|
||||
--- mesa-20110620/configure.ac.no-mach64 2011-06-20 12:19:16.000000000 +1000
|
||||
+++ mesa-20110620/configure.ac 2011-06-20 13:52:27.000000000 +1000
|
||||
@@ -1022,7 +1022,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
# the new interface. i810 are missing because there is no
|
||||
# x86-64 system where they could *ever* be used.
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
||||
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
||||
savage tdfx unichrome swrast"
|
||||
- DRI_DIRS="i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
|
||||
+ DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
|
||||
radeon savage tdfx unichrome swrast"
|
||||
fi
|
||||
;;
|
||||
@@ -827,13 +827,13 @@ if test "$mesa_driver" = dri; then
|
||||
@@ -1030,13 +1030,13 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
# Build only the drivers for cards that exist on PowerPC.
|
||||
# At some point MGA will be added, but not yet.
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
@ -26,21 +26,21 @@ diff -up mesa-20100529/configure.ac.mach64 mesa-20100529/configure.ac
|
||||
fi
|
||||
;;
|
||||
esac
|
||||
@@ -850,7 +850,7 @@ if test "$mesa_driver" = dri; then
|
||||
@@ -1050,7 +1050,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
fi
|
||||
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
|
||||
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
|
||||
unichrome savage sis swrast"
|
||||
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
|
||||
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 \
|
||||
radeon tdfx unichrome savage sis swrast"
|
||||
fi
|
||||
;;
|
||||
@@ -869,7 +869,7 @@ if test "$mesa_driver" = dri; then
|
||||
@@ -1079,7 +1079,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
|
||||
|
||||
# default drivers
|
||||
if test "x$DRI_DIRS" = "xyes"; then
|
||||
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
||||
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
||||
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 radeon \
|
||||
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
|
||||
savage sis tdfx unichrome swrast"
|
||||
fi
|
||||
|
||||
|
26
mesa.spec
26
mesa.spec
@ -9,13 +9,13 @@
|
||||
%define _default_patch_fuzz 2
|
||||
|
||||
%define manpages gl-manpages-1.0.1
|
||||
%define gitdate 20110412
|
||||
%define gitdate 20110620
|
||||
#% define snapshot
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.11
|
||||
Release: 0.12.%{gitdate}.0%{?dist}
|
||||
Release: 0.13.%{gitdate}.0%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -27,7 +27,6 @@ Source0: %{name}-%{gitdate}.tar.xz
|
||||
Source2: %{manpages}.tar.bz2
|
||||
Source3: make-git-snapshot.sh
|
||||
|
||||
Patch1: mesa-nouveau-fix-build.patch
|
||||
Patch2: mesa-7.1-nukeglthread-debug.patch
|
||||
Patch3: mesa-no-mach64.patch
|
||||
Patch4: legacy-drivers.patch
|
||||
@ -201,7 +200,6 @@ Requires: Xorg %(xserver-sdk-abi-requires ansic) %(xserver-sdk-abi-requires vide
|
||||
%prep
|
||||
#setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
|
||||
%setup -q -n mesa-%{gitdate} -b2
|
||||
%patch1 -p1 -b .nv-fix
|
||||
%patch2 -p1 -b .intel-glthread
|
||||
%patch3 -p1 -b .no-mach64
|
||||
%patch4 -p1 -b .classic
|
||||
@ -218,9 +216,9 @@ export CFLAGS="$RPM_OPT_FLAGS"
|
||||
export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
%ifarch %{ix86}
|
||||
# i do not have words for how much the assembly dispatch code infuriates me
|
||||
%define common_flags --enable-selinux --enable-pic --enable-udev --disable-asm
|
||||
%define common_flags --enable-selinux --enable-pic --disable-asm
|
||||
%else
|
||||
%define common_flags --enable-selinux --enable-pic --enable-udev
|
||||
%define common_flags --enable-selinux --enable-pic
|
||||
%endif
|
||||
|
||||
%configure %{common_flags} \
|
||||
@ -230,25 +228,16 @@ export CXXFLAGS="$RPM_OPT_FLAGS"
|
||||
--with-driver=dri \
|
||||
--with-osmesa-bits=8 \
|
||||
--with-dri-driverdir=%{_libdir}/dri \
|
||||
--with-state-trackers=dri,glx \
|
||||
--enable-egl \
|
||||
--enable-gles1 \
|
||||
--enable-gles2 \
|
||||
--disable-gallium-intel \
|
||||
--disable-gallium-svga \
|
||||
--disable-gallium-egl \
|
||||
%if %{with_hardware}
|
||||
--with-gallium-drivers=r300,r600,nouveau,swrast \
|
||||
--enable-gallium-llvm \
|
||||
--enable-gallium-radeon \
|
||||
--enable-gallium-r300 \
|
||||
--enable-gallium-r600 \
|
||||
--enable-gallium-nouveau \
|
||||
%else
|
||||
--disable-gallium-llvm \
|
||||
--disable-gallium-radeon \
|
||||
--disable-gallium-r300 \
|
||||
--disable-gallium-r600 \
|
||||
--disable-gallium-nouveau \
|
||||
--with-gallium-drivers=swrast \
|
||||
%endif
|
||||
%{?dri_drivers}
|
||||
|
||||
@ -444,6 +433,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/pkgconfig/osmesa.pc
|
||||
|
||||
%changelog
|
||||
* Mon Jun 20 2011 Dave Airlie <airlied@redhat.com> 7.11-0.13.20110620.0
|
||||
- rebase to 20 June snapshot from upstream - new gallium config options
|
||||
|
||||
* Mon Jun 20 2011 Dave Airlie <airlied@redhat.com> 7.11-0.12.20110412.0
|
||||
- dropping DRI1 is premature, fix swrastg upstream first.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user