- Update to 6.5.2.
This commit is contained in:
parent
0d83db9639
commit
ce9ee0c22f
@ -5,3 +5,5 @@ glu-man-pages.tar.bz2
|
|||||||
glx-man-pages.tar.bz2
|
glx-man-pages.tar.bz2
|
||||||
gl-manpages-1.0.tar.bz2
|
gl-manpages-1.0.tar.bz2
|
||||||
gl-manpages-1.0.1.tar.bz2
|
gl-manpages-1.0.1.tar.bz2
|
||||||
|
MesaDemos-6.5.2.tar.bz2
|
||||||
|
MesaLib-6.5.2.tar.bz2
|
||||||
|
@ -121,7 +121,7 @@
|
|||||||
@@ -65,4 +64,4 @@
|
@@ -65,4 +64,4 @@
|
||||||
# gamma are missing because they have not been converted to use the new
|
# gamma are missing because they have not been converted to use the new
|
||||||
# interface.
|
# interface.
|
||||||
DRI_DIRS = i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
|
DRI_DIRS = i810 i915tex i915 i965 mach64 mga r128 r200 r300 radeon s3v \
|
||||||
- savage sis tdfx trident unichrome ffb
|
- savage sis tdfx trident unichrome ffb
|
||||||
+ savage tdfx trident unichrome ffb # sis
|
+ savage tdfx trident unichrome ffb # sis
|
||||||
--- Mesa-6.5.1/configs/linux-indirect.build-config 2006-08-17 10:09:02.000000000 -0400
|
--- Mesa-6.5.1/configs/linux-indirect.build-config 2006-08-17 10:09:02.000000000 -0400
|
||||||
@ -176,12 +176,3 @@
|
|||||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||||
APP_LIB_DEPS = -lOSMesa16
|
APP_LIB_DEPS = -lOSMesa16
|
||||||
--- Mesa-6.5.1/configs/linux-dri-x86-64.build-config 2006-07-12 22:43:20.000000000 -0400
|
|
||||||
+++ Mesa-6.5.1/configs/linux-dri-x86-64 2006-09-22 18:11:30.000000000 -0400
|
|
||||||
@@ -20,5 +20,5 @@
|
|
||||||
# the new interface. i810 are missing because there is no x86-64
|
|
||||||
# system where they could *ever* be used.
|
|
||||||
#
|
|
||||||
-DRI_DIRS = i915 mach64 mga r128 r200 radeon tdfx unichrome savage r300
|
|
||||||
+DRI_DIRS = i915 i965 mach64 mga r128 r200 radeon tdfx unichrome savage r300
|
|
||||||
|
|
||||||
|
@ -227,16 +227,16 @@
|
|||||||
*/
|
*/
|
||||||
--- ./src/mesa/shader/slang/slang_execute_x86.c.selinux-awareness 2006-08-09 16:05:26.000000000 -0400
|
--- ./src/mesa/shader/slang/slang_execute_x86.c.selinux-awareness 2006-08-09 16:05:26.000000000 -0400
|
||||||
+++ ./src/mesa/shader/slang/slang_execute_x86.c 2006-08-22 21:14:45.000000000 -0400
|
+++ ./src/mesa/shader/slang/slang_execute_x86.c 2006-08-22 21:14:45.000000000 -0400
|
||||||
@@ -666,7 +666,8 @@
|
@@ -674,7 +674,8 @@
|
||||||
* The built-in library occupies 450K, so we can be safe for now.
|
* The built-in library occupies 450K, so we can be safe for now.
|
||||||
* It is going to change in the future, when we get assembly analysis running.
|
* It is going to change in the future, when we get assembly analysis running.
|
||||||
*/
|
*/
|
||||||
- x86_init_func_size (&G.f, 1048576);
|
- x86_init_func_size(&G.f, 1048576);
|
||||||
+ if (!x86_init_func_size (&G.f, 1048576))
|
+ if (!x86_init_func_size (&G.f, 1048576))
|
||||||
+ return 0;
|
+ return 0;
|
||||||
G.r_eax = x86_make_reg (file_REG32, reg_AX);
|
G.r_eax = x86_make_reg(file_REG32, reg_AX);
|
||||||
G.r_ecx = x86_make_reg (file_REG32, reg_CX);
|
G.r_ecx = x86_make_reg(file_REG32, reg_CX);
|
||||||
G.r_edx = x86_make_reg (file_REG32, reg_DX);
|
G.r_edx = x86_make_reg(file_REG32, reg_DX);
|
||||||
--- ./configs/linux-dri.selinux-awareness 2006-08-22 21:14:45.000000000 -0400
|
--- ./configs/linux-dri.selinux-awareness 2006-08-22 21:14:45.000000000 -0400
|
||||||
+++ ./configs/linux-dri 2006-08-22 21:14:45.000000000 -0400
|
+++ ./configs/linux-dri 2006-08-22 21:14:45.000000000 -0400
|
||||||
@@ -38,7 +38,8 @@
|
@@ -38,7 +38,8 @@
|
||||||
|
17
mesa.spec
17
mesa.spec
@ -46,15 +46,15 @@
|
|||||||
|
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 6.5.1
|
Version: 6.5.2
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT/X11
|
License: MIT/X11
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Source0: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaLib-6.5.1.tar.bz2
|
Source0: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaLib-%{version}.tar.bz2
|
||||||
Source1: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaDemos-6.5.1.tar.bz2
|
Source1: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaDemos-%{version}.tar.bz2
|
||||||
Source2: %{manpages}.tar.bz2
|
Source2: %{manpages}.tar.bz2
|
||||||
|
|
||||||
Source12: redhat-mesa-source-filelist-generator
|
Source12: redhat-mesa-source-filelist-generator
|
||||||
@ -65,10 +65,6 @@ Patch4: mesa-6.5-dont-libglut-me-harder-ok-thx-bye.patch
|
|||||||
|
|
||||||
Patch18: mesa-6.5.1-selinux-awareness.patch
|
Patch18: mesa-6.5.1-selinux-awareness.patch
|
||||||
|
|
||||||
# General patches from upstream go here:
|
|
||||||
Patch50: post-6.5.1-i965-fixes.patch
|
|
||||||
Patch51: i965-interleaved-arrays-fix.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
BuildRequires: libdrm-devel >= 2.0.1-4
|
BuildRequires: libdrm-devel >= 2.0.1-4
|
||||||
@ -246,8 +242,6 @@ install -m 755 %{SOURCE12} ./
|
|||||||
%patch0 -p1 -b .build-config
|
%patch0 -p1 -b .build-config
|
||||||
%patch4 -p0 -b .dont-libglut-me-harder-ok-thx-bye
|
%patch4 -p0 -b .dont-libglut-me-harder-ok-thx-bye
|
||||||
%patch18 -p1 -b .selinux-awareness
|
%patch18 -p1 -b .selinux-awareness
|
||||||
%patch50 -p1 -b .post-6.5.1-i965-fixes
|
|
||||||
%patch51 -p1 -b .i965-interleaved-arrays-fix
|
|
||||||
|
|
||||||
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
||||||
# license and are not open source/free software, so we remove them.
|
# license and are not open source/free software, so we remove them.
|
||||||
@ -417,6 +411,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_bindir}/glxinfo
|
%{_bindir}/glxinfo
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 3 2006 Kristian Høgsberg <krh@redhat.com> 6.5.2-1.fc6
|
||||||
|
- Update to 6.5.2.
|
||||||
|
|
||||||
* Mon Oct 16 2006 Kristian <krh@redhat.com> - 6.5.1-8.fc6
|
* Mon Oct 16 2006 Kristian <krh@redhat.com> - 6.5.1-8.fc6
|
||||||
- Add i965-interleaved-arrays-fix.patch to fix (#209318).
|
- Add i965-interleaved-arrays-fix.patch to fix (#209318).
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,7 +1,7 @@
|
|||||||
0f2794baf7a9d98b22caea9f78c6942d MesaDemos-6.5.1.tar.bz2
|
|
||||||
c46f2c6646a270911b791dd8e1c2d977 MesaLib-6.5.1.tar.bz2
|
|
||||||
92e3fd47f3a8a50fdf51b454867271e3 gl-man-pages.tar.bz2
|
92e3fd47f3a8a50fdf51b454867271e3 gl-man-pages.tar.bz2
|
||||||
73a8d5bc5fe2f336549b56ac3bf06911 glu-man-pages.tar.bz2
|
73a8d5bc5fe2f336549b56ac3bf06911 glu-man-pages.tar.bz2
|
||||||
f97e46b9f29dd64996c4408fbac5f8a3 glx-man-pages.tar.bz2
|
f97e46b9f29dd64996c4408fbac5f8a3 glx-man-pages.tar.bz2
|
||||||
841dd9ef3dec2f67a7faeb65bc5c78b8 gl-manpages-1.0.tar.bz2
|
841dd9ef3dec2f67a7faeb65bc5c78b8 gl-manpages-1.0.tar.bz2
|
||||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||||
|
e870efe98d3a50be01ab211b9b2e25d9 MesaDemos-6.5.2.tar.bz2
|
||||||
|
e4d894181f1859651658b3704633e10d MesaLib-6.5.2.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user