Update to mesa 23.1.0
Resolves: rhbz#2160692
This commit is contained in:
parent
a05168ce02
commit
cc436e4410
@ -1,27 +0,0 @@
|
||||
From 808c054a42fd24a1aaefaeb1d95195fea9fb6e84 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Wed, 7 Dec 2022 05:11:47 +1000
|
||||
Subject: [PATCH] glx: fix xshm check to init xshm_opcode.
|
||||
|
||||
Found and proposed by Ray Strode (halfline)
|
||||
|
||||
Fixes: 68e89401140d ("glx/drisw: use xcb instead of X to query connection")
|
||||
---
|
||||
src/glx/drisw_glx.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/glx/drisw_glx.c b/src/glx/drisw_glx.c
|
||||
index c0d1e85fdc4..d7658eaf7c1 100644
|
||||
--- a/src/glx/drisw_glx.c
|
||||
+++ b/src/glx/drisw_glx.c
|
||||
@@ -874,6 +874,7 @@ check_xshm(Display *dpy)
|
||||
|
||||
shm_cookie = xcb_query_extension(c, 7, "MIT-SHM");
|
||||
shm_reply = xcb_query_extension_reply(c, shm_cookie, NULL);
|
||||
+ xshm_opcode = shm_reply->major_opcode;
|
||||
|
||||
has_mit_shm = shm_reply->present;
|
||||
free(shm_reply);
|
||||
--
|
||||
2.38.1
|
||||
|
11
mesa.spec
11
mesa.spec
@ -52,9 +52,9 @@
|
||||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 22.3.0
|
||||
%global ver 23.1.0
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
||||
@ -65,7 +65,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
Patch10: gnome-shell-glthread-disable.patch
|
||||
Patch11: 0001-glx-fix-xshm-check-to-init-xshm_opcode.patch
|
||||
Patch12: radeonsi-turn-off-glthread.patch
|
||||
|
||||
BuildRequires: meson >= 0.45
|
||||
@ -350,6 +349,9 @@ cp %{SOURCE1} docs/
|
||||
-Dvalgrind=%{?with_valgrind:enabled}%{!?with_valgrind:disabled} \
|
||||
-Dbuild-tests=false \
|
||||
-Dselinux=true \
|
||||
-Dlibunwind=disabled \
|
||||
-Dlmsensors=disabled \
|
||||
-Dandroid-libbacktrace=disabled \
|
||||
%{nil}
|
||||
%meson_build
|
||||
|
||||
@ -603,6 +605,9 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed May 17 2023 Dave Airlie <airlied@redhat.com> - 23.1.0-1
|
||||
- Update to mesa 23.1.0
|
||||
|
||||
* Fri Jan 27 2023 Dave Airlie <airlied@redhat.com> - 22.3.0-2
|
||||
- Disable glthread, breaks gtk3/totem
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mesa-22.3.0.tar.xz) = bf4d344459f97d266a5943b33aecf062b0825e13c1617afdab71c4ba6a87a201440761c9a32a6e0060910a0917122e3f4d29f666d6b94a38a71c94b9ff3ab9da
|
||||
SHA512 (mesa-23.1.0.tar.xz) = bbcfd0dd8e5414826631e80edbbe48218115a7461ef4ac1f2e4e090a48d6c0e1ab3b51dd45e988d5f1572f29bfc03c33769263c0f3e04033138d5b1ec102e8c9
|
||||
|
Loading…
Reference in New Issue
Block a user