add patch for RHBZ #1265997
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
3851ec7962
commit
c6ea6505c2
@ -0,0 +1,14 @@
|
|||||||
|
diff --git a/src/mesa/main/extensions.c b/src/mesa/main/extensions.c
|
||||||
|
index 767c50e..b2c88c3 100644
|
||||||
|
--- a/src/mesa/main/extensions.c
|
||||||
|
+++ b/src/mesa/main/extensions.c
|
||||||
|
@@ -307,7 +307,8 @@ static const struct extension extension_table[] = {
|
||||||
|
{ "GL_OES_depth_texture_cube_map", o(OES_depth_texture_cube_map), ES2, 2012 },
|
||||||
|
{ "GL_OES_draw_texture", o(OES_draw_texture), ES1, 2004 },
|
||||||
|
{ "GL_OES_EGL_sync", o(dummy_true), ES1 | ES2, 2010 },
|
||||||
|
- { "GL_OES_EGL_image", o(OES_EGL_image), ES1 | ES2, 2006 },
|
||||||
|
+ /* FIXME: Mesa expects GL_OES_EGL_image to be available in OpenGL contexts. */
|
||||||
|
+ { "GL_OES_EGL_image", o(OES_EGL_image), GL | ES1 | ES2, 2006 },
|
||||||
|
{ "GL_OES_EGL_image_external", o(OES_EGL_image_external), ES1 | ES2, 2010 },
|
||||||
|
{ "GL_OES_element_index_uint", o(dummy_true), ES1 | ES2, 2005 },
|
||||||
|
{ "GL_OES_fbo_render_mipmap", o(dummy_true), ES1 | ES2, 2005 },
|
@ -79,6 +79,8 @@ Patch15: mesa-9.2-hardware-float.patch
|
|||||||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||||
Patch30: mesa-10.3-bigendian-assert.patch
|
Patch30: mesa-10.3-bigendian-assert.patch
|
||||||
|
|
||||||
|
Patch99: Mesa-dev-Revert-mesa-extensions-restrict-GL_OES_EGL_image-to-GLES.patch
|
||||||
|
|
||||||
# To have sha info in glxinfo
|
# To have sha info in glxinfo
|
||||||
BuildRequires: git-core
|
BuildRequires: git-core
|
||||||
|
|
||||||
@ -354,6 +356,8 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
|||||||
%patch20 -p1 -b .egbe
|
%patch20 -p1 -b .egbe
|
||||||
%patch30 -p1 -b .beassert
|
%patch30 -p1 -b .beassert
|
||||||
|
|
||||||
|
%patch99 -p1
|
||||||
|
|
||||||
%if 0%{with_private_llvm}
|
%if 0%{with_private_llvm}
|
||||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||||
|
Loading…
Reference in New Issue
Block a user