- Disable dricore for now as it conflicts with upstream vis changes
This commit is contained in:
parent
1e93fee753
commit
c18aff5a8e
@ -9,3 +9,4 @@ mesa-20090909.tar.bz2
|
|||||||
mesa-20090921.tar.bz2
|
mesa-20090921.tar.bz2
|
||||||
xdriinfo-1.0.3.tar.bz2
|
xdriinfo-1.0.3.tar.bz2
|
||||||
mesa-20091221.tar.bz2
|
mesa-20091221.tar.bz2
|
||||||
|
mesa-20100106.tar.bz2
|
||||||
|
@ -1,41 +0,0 @@
|
|||||||
From 55c43ee3158e5e83dcf51a7d6eaa35d4314c0833 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dave Airlie <airlied@redhat.com>
|
|
||||||
Date: Mon, 21 Dec 2009 09:10:21 +1000
|
|
||||||
Subject: [PATCH] glsl: make stack compile.
|
|
||||||
|
|
||||||
it would be nice if this stuff would be test built on mesa's primary
|
|
||||||
platform with mesa's primary build system.
|
|
||||||
|
|
||||||
Signed-off-by: Dave Airlie <airlied@redhat.com>
|
|
||||||
---
|
|
||||||
src/glsl/pp/sl_pp_macro.h | 1 +
|
|
||||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/glsl/pp/sl_pp_macro.h b/src/glsl/pp/sl_pp_macro.h
|
|
||||||
index 2967baf..1d21068 100644
|
|
||||||
--- a/src/glsl/pp/sl_pp_macro.h
|
|
||||||
+++ b/src/glsl/pp/sl_pp_macro.h
|
|
||||||
@@ -33,6 +33,7 @@
|
|
||||||
|
|
||||||
struct sl_pp_context;
|
|
||||||
struct sl_pp_process_state;
|
|
||||||
+struct sl_pp_token_buffer;
|
|
||||||
|
|
||||||
struct sl_pp_macro_formal_arg {
|
|
||||||
int name;
|
|
||||||
--
|
|
||||||
1.6.5.2
|
|
||||||
|
|
||||||
diff --git a/src/mesa/shader/slang/library/Makefile b/src/mesa/shader/slang/library/Makefile
|
|
||||||
index c696451..8ac7fd6 100644
|
|
||||||
--- a/src/mesa/shader/slang/library/Makefile
|
|
||||||
+++ b/src/mesa/shader/slang/library/Makefile
|
|
||||||
@@ -12,7 +12,7 @@ GLSL_CL = $(TOP)/src/glsl/apps/compile
|
|
||||||
|
|
||||||
.PHONY: default clean
|
|
||||||
|
|
||||||
-default: builtin
|
|
||||||
+default: $(GLSL_CL) builtin
|
|
||||||
|
|
||||||
clean:
|
|
||||||
-rm -f *_gc.h
|
|
@ -1,21 +0,0 @@
|
|||||||
commit 532d2051245a1d8afe7ca236f1d966d555bb121a
|
|
||||||
Author: Dave Airlie <airlied@linux.ie>
|
|
||||||
Date: Fri Sep 12 17:21:25 2008 +1000
|
|
||||||
|
|
||||||
Revert "intel: sync to vblank by default"
|
|
||||||
|
|
||||||
This reverts commit e9bf3e4cc9a7e4bcd4c45bd707541d26ecdf0409.
|
|
||||||
|
|
||||||
diff --git a/src/mesa/drivers/dri/intel/intel_screen.c b/src/mesa/drivers/dri/intel/intel_screen.c
|
|
||||||
index c193830..f02192d 100644
|
|
||||||
--- a/src/mesa/drivers/dri/intel/intel_screen.c
|
|
||||||
+++ b/src/mesa/drivers/dri/intel/intel_screen.c
|
|
||||||
@@ -55,7 +55,7 @@ PUBLIC const char __driConfigOptions[] =
|
|
||||||
DRI_CONF_BEGIN
|
|
||||||
DRI_CONF_SECTION_PERFORMANCE
|
|
||||||
DRI_CONF_FTHROTTLE_MODE(DRI_CONF_FTHROTTLE_IRQS)
|
|
||||||
- DRI_CONF_VBLANK_MODE(DRI_CONF_VBLANK_ALWAYS_SYNC)
|
|
||||||
+ DRI_CONF_VBLANK_MODE(DRI_CONF_VBLANK_DEF_INTERVAL_0)
|
|
||||||
/* Options correspond to DRI_CONF_BO_REUSE_DISABLED,
|
|
||||||
* DRI_CONF_BO_REUSE_ALL
|
|
||||||
*/
|
|
@ -264,7 +264,8 @@ make install DESTDIR=$RPM_BUILD_ROOT DRI_DIRS=
|
|||||||
|
|
||||||
# just the DRI drivers that are sane
|
# just the DRI drivers that are sane
|
||||||
install -d $RPM_BUILD_ROOT%{_libdir}/dri
|
install -d $RPM_BUILD_ROOT%{_libdir}/dri
|
||||||
install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri %{_lib}/libdricore.so >& /dev/null
|
install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri >& /dev/null
|
||||||
|
#%{_lib}/libdricore.so <- readd for dricore
|
||||||
for f in i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon savage sis swrast tdfx unichrome gallium/vmwgfx; do
|
for f in i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon savage sis swrast tdfx unichrome gallium/vmwgfx; do
|
||||||
so=%{_lib}/${f}_dri.so
|
so=%{_lib}/${f}_dri.so
|
||||||
test -e $so && echo $so
|
test -e $so && echo $so
|
||||||
@ -327,7 +328,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%files dri-drivers
|
%files dri-drivers
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%dir %{_libdir}/dri
|
%dir %{_libdir}/dri
|
||||||
%{_libdir}/dri/libdricore.so
|
#%{_libdir}/dri/libdricore.so
|
||||||
%{_libdir}/dri/*_dri.so
|
%{_libdir}/dri/*_dri.so
|
||||||
%exclude %{_libdir}/dri/vmwgfx_dri.so
|
%exclude %{_libdir}/dri/vmwgfx_dri.so
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||||
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
|
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
|
||||||
0f4bc80e7c55cff25a44c91c8657fc1a mesa-20091221.tar.bz2
|
df8781bb9df6445379917ceb935b8d9e mesa-20100106.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user