- mesa-7.3-dri-drivers-master.patch - pull in DRI drivers from master
This commit is contained in:
parent
89df165bd7
commit
b45b553169
@ -1,7 +1,8 @@
|
|||||||
diff -up Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c
|
diff --git a/src/mesa/drivers/dri/intel/intel_fbo.c b/src/mesa/drivers/dri/intel/intel_fbo.c
|
||||||
--- Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread 2008-08-25 10:49:40.000000000 -0400
|
index 787c290..be81b65 100644
|
||||||
+++ Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c 2008-08-28 14:26:17.000000000 -0400
|
--- a/src/mesa/drivers/dri/intel/intel_fbo.c
|
||||||
@@ -633,11 +633,6 @@ intel_render_texture(GLcontext * ctx,
|
+++ b/src/mesa/drivers/dri/intel/intel_fbo.c
|
||||||
|
@@ -573,11 +573,6 @@ intel_render_texture(GLcontext * ctx,
|
||||||
return;
|
return;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -13,12 +14,3 @@ diff -up Mesa-7.1/src/mesa/drivers/dri/intel/intel_fbo.c.intel-glthread Mesa-7.1
|
|||||||
/* point the renderbufer's region to the texture image region */
|
/* point the renderbufer's region to the texture image region */
|
||||||
intel_image = intel_texture_image(newImage);
|
intel_image = intel_texture_image(newImage);
|
||||||
if (irb->region != intel_image->mt->region) {
|
if (irb->region != intel_image->mt->region) {
|
||||||
@@ -674,8 +669,6 @@ intel_finish_render_texture(GLcontext *
|
|
||||||
{
|
|
||||||
struct intel_renderbuffer *irb = intel_renderbuffer(att->Renderbuffer);
|
|
||||||
|
|
||||||
- DBG("End render texture (tid %x) tex %u\n", _glthread_GetID(), att->Texture->Name);
|
|
||||||
-
|
|
||||||
if (irb) {
|
|
||||||
/* just release the region */
|
|
||||||
intel_region_release(&irb->region);
|
|
||||||
|
12618
mesa-7.3-dri-drivers-master.patch
Normal file
12618
mesa-7.3-dri-drivers-master.patch
Normal file
File diff suppressed because it is too large
Load Diff
11
mesa.spec
11
mesa.spec
@ -20,7 +20,7 @@
|
|||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.3
|
Version: 7.3
|
||||||
Release: 7%{?dist}
|
Release: 8%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
@ -37,17 +37,16 @@ Source3: make-git-snapshot.sh
|
|||||||
Source5: http://www.x.org/pub/individual/app/%{xdriinfo}.tar.bz2
|
Source5: http://www.x.org/pub/individual/app/%{xdriinfo}.tar.bz2
|
||||||
|
|
||||||
Patch0: mesa-7.1-osmesa-version.patch
|
Patch0: mesa-7.1-osmesa-version.patch
|
||||||
|
Patch1: mesa-7.3-dri-drivers-master.patch
|
||||||
Patch2: mesa-7.1-nukeglthread-debug.patch
|
Patch2: mesa-7.1-nukeglthread-debug.patch
|
||||||
Patch3: mesa-no-mach64.patch
|
Patch3: mesa-no-mach64.patch
|
||||||
|
|
||||||
Patch5: radeon-rewrite.patch
|
Patch5: radeon-rewrite.patch
|
||||||
Patch6: radeon-dri2-fixes.patch
|
|
||||||
|
|
||||||
Patch7: mesa-7.1-link-shared.patch
|
Patch7: mesa-7.1-link-shared.patch
|
||||||
Patch9: intel-revert-vbl.patch
|
Patch9: intel-revert-vbl.patch
|
||||||
|
|
||||||
Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
||||||
Patch13: mesa-7.3-965-texture-size.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig autoconf automake
|
BuildRequires: pkgconfig autoconf automake
|
||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
@ -169,14 +168,13 @@ This package provides some demo applications for testing Mesa.
|
|||||||
%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b1 -b2 -b5
|
%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b1 -b2 -b5
|
||||||
#%setup -q -n mesa-%{gitdate} -b2 -b5
|
#%setup -q -n mesa-%{gitdate} -b2 -b5
|
||||||
%patch0 -p1 -b .osmesa
|
%patch0 -p1 -b .osmesa
|
||||||
|
%patch1 -p1 -b .mesa-dri-master
|
||||||
%patch2 -p1 -b .intel-glthread
|
%patch2 -p1 -b .intel-glthread
|
||||||
%patch3 -p0 -b .no-mach64
|
%patch3 -p0 -b .no-mach64
|
||||||
%patch5 -p1 -b .radeon-rewrite
|
%patch5 -p1 -b .radeon-rewrite
|
||||||
%patch6 -p1 -b .radeon-dri2
|
|
||||||
%patch7 -p1 -b .dricore
|
%patch7 -p1 -b .dricore
|
||||||
%patch9 -p1 -b .intel-vbl
|
%patch9 -p1 -b .intel-vbl
|
||||||
%patch12 -p1 -b .intel-nowarn
|
%patch12 -p1 -b .intel-nowarn
|
||||||
%patch13 -p1 -b .965-texture
|
|
||||||
|
|
||||||
# Hack the demos to use installed data files
|
# Hack the demos to use installed data files
|
||||||
sed -i 's,../images,%{_libdir}/mesa-demos-data,' progs/demos/*.c
|
sed -i 's,../images,%{_libdir}/mesa-demos-data,' progs/demos/*.c
|
||||||
@ -425,6 +423,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/mesa-demos-data
|
%{_libdir}/mesa-demos-data
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 27 2009 Dave Airlie <airlied@redhat.com> 7.3-8
|
||||||
|
- mesa-7.3-dri-drivers-master.patch - pull in DRI drivers from master
|
||||||
|
|
||||||
* Fri Feb 27 2009 Dave Airlie <airlied@redhat.com> 7.3-7
|
* Fri Feb 27 2009 Dave Airlie <airlied@redhat.com> 7.3-7
|
||||||
- radeon-dri2-fixes.patch: add some fixes to radeon code
|
- radeon-dri2-fixes.patch: add some fixes to radeon code
|
||||||
|
|
||||||
|
File diff suppressed because it is too large
Load Diff
1487
radeon-rewrite.patch
1487
radeon-rewrite.patch
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user