new snapshot
This commit is contained in:
parent
a427a13566
commit
b30c9db361
@ -1,3 +1,2 @@
|
||||
MesaLib-7.1pre.tar.bz2
|
||||
MesaDemos-7.1pre.tar.bz2
|
||||
gl-manpages-1.0.1.tar.bz2
|
||||
mesa-20071127.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- Mesa-6.5.2/src/mesa/glapi/dispatch.h.jx 2006-12-12 18:02:22.000000000 -0500
|
||||
+++ Mesa-6.5.2/src/mesa/glapi/dispatch.h 2006-12-12 18:03:04.000000000 -0500
|
||||
@@ -3840,4 +3840,9 @@
|
||||
|
||||
#endif /* !defined(IN_DRI_DRIVER) */
|
||||
|
||||
+/* backwards compatibility for X server 1.1.1 */
|
||||
+#define CALL_IsTextureEXT(a, b) CALL_IsTexture(a, b)
|
||||
+#define CALL_GenTexturesEXT(a, b) CALL_GenTextures(a, b)
|
||||
+#define CALL_AreTexturesResidentEXT(a, b) CALL_AreTexturesResident(a, b)
|
||||
+
|
||||
#endif /* !defined( _DISPATCH_H_ ) */
|
@ -1,69 +1,6 @@
|
||||
diff -up Mesa-7.0/src/mesa/tnl/t_vertex_sse.c.jx Mesa-7.0/src/mesa/tnl/t_vertex_sse.c
|
||||
--- Mesa-7.0/src/mesa/tnl/t_vertex_sse.c.jx 2007-06-21 18:10:54.000000000 -0400
|
||||
+++ Mesa-7.0/src/mesa/tnl/t_vertex_sse.c 2007-07-23 15:59:26.000000000 -0400
|
||||
@@ -348,7 +348,8 @@ static GLboolean build_vertex_emit( stru
|
||||
struct x86_reg vp1 = x86_make_reg(file_XMM, 2);
|
||||
GLubyte *fixup, *label;
|
||||
|
||||
- x86_init_func(&p->func);
|
||||
+ if (!x86_init_func(&p->func))
|
||||
+ return GL_FALSE;
|
||||
|
||||
/* Push a few regs?
|
||||
*/
|
||||
@@ -646,7 +647,10 @@ void _tnl_generate_sse_emit( GLcontext *
|
||||
p.identity = x86_make_reg(file_XMM, 6);
|
||||
p.chan0 = x86_make_reg(file_XMM, 7);
|
||||
|
||||
- x86_init_func(&p.func);
|
||||
+ if (!x86_init_func(&p.func)) {
|
||||
+ vtx->codegen_emit = NULL;
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
if (build_vertex_emit(&p)) {
|
||||
_tnl_register_fastpath( vtx, GL_TRUE );
|
||||
diff -up Mesa-7.0/src/mesa/x86/rtasm/x86sse.h.jx Mesa-7.0/src/mesa/x86/rtasm/x86sse.h
|
||||
--- Mesa-7.0/src/mesa/x86/rtasm/x86sse.h.jx 2007-06-21 18:10:55.000000000 -0400
|
||||
+++ Mesa-7.0/src/mesa/x86/rtasm/x86sse.h 2007-07-23 15:59:23.000000000 -0400
|
||||
@@ -80,8 +80,8 @@ enum sse_cc {
|
||||
*/
|
||||
|
||||
|
||||
-void x86_init_func( struct x86_function *p );
|
||||
-void x86_init_func_size( struct x86_function *p, GLuint code_size );
|
||||
+int x86_init_func( struct x86_function *p );
|
||||
+int x86_init_func_size( struct x86_function *p, GLuint code_size );
|
||||
void x86_release_func( struct x86_function *p );
|
||||
void (*x86_get_func( struct x86_function *p ))( void );
|
||||
|
||||
diff -up Mesa-7.0/src/mesa/x86/rtasm/x86sse.c.jx Mesa-7.0/src/mesa/x86/rtasm/x86sse.c
|
||||
--- Mesa-7.0/src/mesa/x86/rtasm/x86sse.c.jx 2007-06-21 18:10:55.000000000 -0400
|
||||
+++ Mesa-7.0/src/mesa/x86/rtasm/x86sse.c 2007-07-23 15:59:23.000000000 -0400
|
||||
@@ -1063,15 +1063,17 @@ struct x86_reg x86_fn_arg( struct x86_fu
|
||||
}
|
||||
|
||||
|
||||
-void x86_init_func( struct x86_function *p )
|
||||
+int x86_init_func( struct x86_function *p )
|
||||
{
|
||||
- x86_init_func_size(p, 1024);
|
||||
+ return x86_init_func_size(p, 1024);
|
||||
}
|
||||
|
||||
-void x86_init_func_size( struct x86_function *p, GLuint code_size )
|
||||
+int x86_init_func_size( struct x86_function *p, GLuint code_size )
|
||||
{
|
||||
p->store = _mesa_exec_malloc(code_size);
|
||||
p->csr = p->store;
|
||||
+
|
||||
+ return (p->store != NULL);
|
||||
}
|
||||
|
||||
void x86_release_func( struct x86_function *p )
|
||||
diff -up Mesa-7.0/src/mesa/main/execmem.c.jx Mesa-7.0/src/mesa/main/execmem.c
|
||||
--- Mesa-7.0/src/mesa/main/execmem.c.jx 2007-06-21 18:10:54.000000000 -0400
|
||||
+++ Mesa-7.0/src/mesa/main/execmem.c 2007-07-23 16:02:30.000000000 -0400
|
||||
diff -up mesa-20071127/src/mesa/main/execmem.c.selinux-awareness mesa-20071127/src/mesa/main/execmem.c
|
||||
--- mesa-20071127/src/mesa/main/execmem.c.selinux-awareness 2007-11-27 14:33:54.000000000 -0500
|
||||
+++ mesa-20071127/src/mesa/main/execmem.c 2007-11-27 14:34:34.000000000 -0500
|
||||
@@ -46,6 +46,7 @@
|
||||
#include <unistd.h>
|
||||
#include <sys/mman.h>
|
||||
@ -119,10 +56,46 @@ diff -up Mesa-7.0/src/mesa/main/execmem.c.jx Mesa-7.0/src/mesa/main/execmem.c
|
||||
_glthread_UNLOCK_MUTEX(exec_mutex);
|
||||
|
||||
return addr;
|
||||
diff -up Mesa-7.0/configs/linux-dri.jx Mesa-7.0/configs/linux-dri
|
||||
--- Mesa-7.0/configs/linux-dri.jx 2007-07-23 15:59:07.000000000 -0400
|
||||
+++ Mesa-7.0/configs/linux-dri 2007-07-23 17:37:36.000000000 -0400
|
||||
@@ -39,7 +39,8 @@ EXTRA_LIB_PATH =
|
||||
diff -up mesa-20071127/src/mesa/x86/rtasm/x86sse.c.selinux-awareness mesa-20071127/src/mesa/x86/rtasm/x86sse.c
|
||||
diff -up mesa-20071127/src/mesa/x86/rtasm/x86sse.h.selinux-awareness mesa-20071127/src/mesa/x86/rtasm/x86sse.h
|
||||
diff -up mesa-20071127/src/mesa/tnl/t_vertex_sse.c.selinux-awareness mesa-20071127/src/mesa/tnl/t_vertex_sse.c
|
||||
diff -up mesa-20071127/configs/linux-osmesa.selinux-awareness mesa-20071127/configs/linux-osmesa
|
||||
--- mesa-20071127/configs/linux-osmesa.selinux-awareness 2007-11-27 14:33:53.000000000 -0500
|
||||
+++ mesa-20071127/configs/linux-osmesa 2007-11-27 14:34:34.000000000 -0500
|
||||
@@ -23,6 +23,6 @@ PROGRAM_DIRS = osdemos
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa -lGLU
|
||||
diff -up mesa-20071127/configs/linux-osmesa32.selinux-awareness mesa-20071127/configs/linux-osmesa32
|
||||
--- mesa-20071127/configs/linux-osmesa32.selinux-awareness 2007-11-27 14:33:53.000000000 -0500
|
||||
+++ mesa-20071127/configs/linux-osmesa32 2007-11-27 14:34:34.000000000 -0500
|
||||
@@ -26,6 +26,6 @@ PROGRAM_DIRS =
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa32
|
||||
diff -up mesa-20071127/configs/linux-osmesa16.selinux-awareness mesa-20071127/configs/linux-osmesa16
|
||||
--- mesa-20071127/configs/linux-osmesa16.selinux-awareness 2007-11-27 14:33:53.000000000 -0500
|
||||
+++ mesa-20071127/configs/linux-osmesa16 2007-11-27 14:34:34.000000000 -0500
|
||||
@@ -26,6 +26,6 @@ PROGRAM_DIRS =
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa16
|
||||
diff -up mesa-20071127/configs/linux-dri.selinux-awareness mesa-20071127/configs/linux-dri
|
||||
--- mesa-20071127/configs/linux-dri.selinux-awareness 2007-11-27 14:34:34.000000000 -0500
|
||||
+++ mesa-20071127/configs/linux-dri 2007-11-27 14:34:34.000000000 -0500
|
||||
@@ -45,7 +45,8 @@ EXTRA_LIB_PATH=-L/usr/X11R6/lib
|
||||
|
||||
LIBDRM_CFLAGS = `pkg-config --cflags libdrm`
|
||||
LIBDRM_LIB = `pkg-config --libs libdrm`
|
||||
@ -132,36 +105,3 @@ diff -up Mesa-7.0/configs/linux-dri.jx Mesa-7.0/configs/linux-dri
|
||||
GL_LIB_DEPS = $(EXTRA_LIB_PATH) -lX11 -lXext -lXxf86vm -lXdamage -lXfixes \
|
||||
-lm -lpthread -ldl \
|
||||
$(LIBDRM_LIB)
|
||||
diff -up Mesa-7.1pre/configs/linux-osmesa16.BAD Mesa-7.1pre/configs/linux-osmesa16
|
||||
--- Mesa-7.1pre/configs/linux-osmesa16.BAD 2007-11-15 14:56:18.000000000 -0500
|
||||
+++ Mesa-7.1pre/configs/linux-osmesa16 2007-11-15 14:56:35.000000000 -0500
|
||||
@@ -26,6 +26,6 @@ PROGRAM_DIRS =
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa16
|
||||
diff -up Mesa-7.1pre/configs/linux-osmesa32.BAD Mesa-7.1pre/configs/linux-osmesa32
|
||||
--- Mesa-7.1pre/configs/linux-osmesa32.BAD 2007-11-15 14:55:35.000000000 -0500
|
||||
+++ Mesa-7.1pre/configs/linux-osmesa32 2007-11-15 14:55:44.000000000 -0500
|
||||
@@ -26,6 +26,6 @@ PROGRAM_DIRS =
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa32
|
||||
diff -up Mesa-7.1pre/configs/linux-osmesa.BAD Mesa-7.1pre/configs/linux-osmesa
|
||||
--- Mesa-7.1pre/configs/linux-osmesa.BAD 2007-11-15 15:00:23.000000000 -0500
|
||||
+++ Mesa-7.1pre/configs/linux-osmesa 2007-11-15 15:00:28.000000000 -0500
|
||||
@@ -23,6 +23,6 @@ PROGRAM_DIRS = osdemos
|
||||
|
||||
|
||||
# Dependencies
|
||||
-OSMESA_LIB_DEPS = -lm -lpthread
|
||||
+OSMESA_LIB_DEPS = -lm -lpthread -lselinux
|
||||
GLU_LIB_DEPS = -L$(TOP)/$(LIB_DIR) -l$(OSMESA_LIB)
|
||||
APP_LIB_DEPS = -lOSMesa -lGLU
|
||||
|
21
mesa.spec
21
mesa.spec
@ -6,8 +6,10 @@
|
||||
%ifarch s390 s390x
|
||||
%define with_dri 0
|
||||
%define dri_target linux-indirect
|
||||
%define src_dirs SRC_DIRS="glx/x11 glu"
|
||||
%else
|
||||
%define with_dri 1
|
||||
%define src_dirs SRC_DIRS="glx/x11 mesa glu"
|
||||
%endif
|
||||
|
||||
%ifarch %{ix86}
|
||||
@ -28,18 +30,20 @@
|
||||
%endif
|
||||
|
||||
%define manpages gl-manpages-1.0.1
|
||||
%define gitdate 20071127
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.1
|
||||
Release: 0.4%{?dist}
|
||||
Release: 0.5%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Source0: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaLib-7.1pre.tar.bz2
|
||||
Source1: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaDemos-7.1pre.tar.bz2
|
||||
#Source0: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaLib-7.1pre.tar.bz2
|
||||
#Source1: http://internap.dl.sourceforge.net/sourceforge/mesa3d/MesaDemos-7.1pre.tar.bz2
|
||||
Source0: mesa-%{gitdate}.tar.bz2
|
||||
Source2: %{manpages}.tar.bz2
|
||||
|
||||
Patch1: mesa-7.1-kill-glw.patch
|
||||
@ -166,7 +170,8 @@ This package provides some demo applications for testing Mesa.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n Mesa-%{version}pre -b1 -b2
|
||||
#%setup -q -n Mesa-%{version}pre -b1 -b2
|
||||
%setup -q -n mesa-%{gitdate} -b2
|
||||
chmod a-x progs/demos/glslnoise.c
|
||||
|
||||
%patch1 -p1 -b .kill-glw
|
||||
@ -203,7 +208,8 @@ for t in osmesa osmesa16 osmesa32; do
|
||||
done
|
||||
|
||||
echo "Building %{dri_target}"
|
||||
make %{?_smp_mflags} %{dri_target} OPT_FLAGS="${OPT_FLAGS}" LIB_DIR=lib
|
||||
make %{?_smp_mflags} %{dri_target} OPT_FLAGS="${OPT_FLAGS}" LIB_DIR=lib %{src_dirs}
|
||||
# We shouldn't built this libglut, but just to make sure...
|
||||
make -C progs/xdemos glxgears glxinfo OPT_FLAGS="${OPT_FLAGS}" LIB_DIR=lib
|
||||
make -C progs/demos OPT_FLAGS="${OPT_FLAGS}" LIB_DIR=lib
|
||||
mv preserve/* lib
|
||||
@ -224,6 +230,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
# The mesa build system is broken beyond repair. The lines below just
|
||||
# handpick and manually install the parts we want.
|
||||
|
||||
rm include/GL/glut*.h
|
||||
install -d $RPM_BUILD_ROOT%{_includedir}/GL
|
||||
install -m 644 include/GL/{gl,o,x}*.h $RPM_BUILD_ROOT%{_includedir}/GL
|
||||
install -d $RPM_BUILD_ROOT%{_includedir}/GL/internal
|
||||
@ -404,6 +411,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/mesa-demos-data
|
||||
|
||||
%changelog
|
||||
* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 7.1-0.5
|
||||
- Rebase to today's git snapshot.
|
||||
- Try even harder to not build or the Mesa glut.
|
||||
|
||||
* Thu Nov 15 2007 Tom "spot" Callaway <tcallawa@redhat.com> 7.1-0.4
|
||||
- link libOSMesa* against libselinux
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user