Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/mesa.git#b465d7f1962d998e7f2de97ecf1c0391e7b7ad72
This commit is contained in:
parent
8e11421226
commit
b2d0ae164b
@ -1,45 +0,0 @@
|
||||
From dff56769b504ceb6e45d87201587201249d1d808 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Wed, 3 Feb 2021 14:17:46 +1000
|
||||
Subject: [PATCH] zink: don't pick a cpu device ever.
|
||||
|
||||
This goes down the list and picks the first gpu device, when
|
||||
we merge the CI patch we should add a forcing env var in here.
|
||||
---
|
||||
src/gallium/drivers/zink/zink_screen.c | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/zink/zink_screen.c b/src/gallium/drivers/zink/zink_screen.c
|
||||
index e190a7af672..918749b90b1 100644
|
||||
--- a/src/gallium/drivers/zink/zink_screen.c
|
||||
+++ b/src/gallium/drivers/zink/zink_screen.c
|
||||
@@ -709,7 +709,7 @@ static VkPhysicalDevice
|
||||
choose_pdev(const VkInstance instance)
|
||||
{
|
||||
uint32_t i, pdev_count;
|
||||
- VkPhysicalDevice *pdevs, pdev;
|
||||
+ VkPhysicalDevice *pdevs, pdev = NULL;
|
||||
vkEnumeratePhysicalDevices(instance, &pdev_count, NULL);
|
||||
assert(pdev_count > 0);
|
||||
|
||||
@@ -717,7 +717,6 @@ choose_pdev(const VkInstance instance)
|
||||
vkEnumeratePhysicalDevices(instance, &pdev_count, pdevs);
|
||||
assert(pdev_count > 0);
|
||||
|
||||
- pdev = pdevs[0];
|
||||
for (i = 0; i < pdev_count; ++i) {
|
||||
VkPhysicalDeviceProperties props;
|
||||
vkGetPhysicalDeviceProperties(pdevs[i], &props);
|
||||
@@ -1095,6 +1094,9 @@ zink_internal_create_screen(const struct pipe_screen_config *config)
|
||||
debug_printf("ZINK: failed to setup debug utils\n");
|
||||
|
||||
screen->pdev = choose_pdev(screen->instance);
|
||||
+ if (!screen->pdev)
|
||||
+ goto fail;
|
||||
+
|
||||
update_queue_props(screen);
|
||||
|
||||
screen->have_X8_D24_UNORM_PACK32 = zink_is_depth_format_supported(screen,
|
||||
--
|
||||
2.26.2
|
||||
|
10
mesa.spec
10
mesa.spec
@ -50,9 +50,9 @@
|
||||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 21.0.0-rc4
|
||||
%global ver 21.0.0-rc5
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: 2%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
||||
@ -62,9 +62,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
||||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# fix zink/swrast/gnome-shell
|
||||
Patch3: 0001-zink-don-t-pick-a-cpu-device-ever.patch
|
||||
|
||||
BuildRequires: meson >= 0.45
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -598,6 +595,9 @@ popd
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Feb 19 2021 Pete Walter <pwalter@fedoraproject.org> - 21.0.0~rc5-1
|
||||
- Update to 21.0.0-rc5
|
||||
|
||||
* Fri Feb 19 2021 Adam Jackson <ajax@redhat.com> - 21.0.0~rc4-2
|
||||
- Disable OpenMAX, OpenCL, and nine in RHEL
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mesa-21.0.0-rc4.tar.xz) = 4cad13181accd0ac49efcca041bcebdaeeaf0a8b62bfce064b8668fc6b5e7fe1cf01db1d1291a25fc0cf0593ec1c227fd6e23dd45d9a16b458165594690179c4
|
||||
SHA512 (mesa-21.0.0-rc5.tar.xz) = 89e212a7caf70320841551dbf937fe627e156896e9d11dc6654f91552c97800354562d5297b3a218c8c0f8261d2f32c62cb6e9445bace64f0b41eced829be7ed
|
||||
|
Loading…
Reference in New Issue
Block a user