- rebase to new upstream + r300 bufmgr code - openarena under kms works now
This commit is contained in:
parent
dfb4c30eea
commit
b0f1501626
@ -1,3 +1,3 @@
|
||||
gl-manpages-1.0.1.tar.bz2
|
||||
mesa-20080905.tar.bz2
|
||||
xdriinfo-1.0.2.tar.bz2
|
||||
gl-manpages-1.0.1.tar.bz2
|
||||
mesa-20081001.tar.bz2
|
||||
|
@ -1,57 +0,0 @@
|
||||
diff --git a/src/mesa/drivers/dri/intel/intel_context.c b/src/mesa/drivers/dri/intel/intel_context.c
|
||||
index c2ad5a0..18e7348 100644
|
||||
--- a/src/mesa/drivers/dri/intel/intel_context.c
|
||||
+++ b/src/mesa/drivers/dri/intel/intel_context.c
|
||||
@@ -409,10 +409,12 @@ static const struct dri_extension brw_extensions[] = {
|
||||
{ NULL, NULL }
|
||||
};
|
||||
|
||||
+#ifdef I915_MMIO_READ
|
||||
static const struct dri_extension arb_oc_extensions[] = {
|
||||
{"GL_ARB_occlusion_query", GL_ARB_occlusion_query_functions},
|
||||
{NULL, NULL}
|
||||
};
|
||||
+#endif
|
||||
|
||||
static const struct dri_extension ttm_extensions[] = {
|
||||
{"GL_EXT_framebuffer_object", GL_EXT_framebuffer_object_functions},
|
||||
@@ -437,10 +439,12 @@ void intelInitExtensions(GLcontext *ctx, GLboolean enable_imaging)
|
||||
if (intel == NULL || intel->ttm)
|
||||
driInitExtensions(ctx, ttm_extensions, GL_FALSE);
|
||||
|
||||
+#ifdef I915_MMIO_READ
|
||||
if (intel == NULL ||
|
||||
(IS_965(intel->intelScreen->deviceID) &&
|
||||
intel->intelScreen->drmMinor >= 8))
|
||||
driInitExtensions(ctx, arb_oc_extensions, GL_FALSE);
|
||||
+#endif
|
||||
|
||||
if (intel == NULL || IS_965(intel->intelScreen->deviceID))
|
||||
driInitExtensions(ctx, brw_extensions, GL_FALSE);
|
||||
@@ -538,6 +542,7 @@ intelFinish(GLcontext * ctx)
|
||||
}
|
||||
}
|
||||
|
||||
+#ifdef I915_MMIO_READ
|
||||
static void
|
||||
intelBeginQuery(GLcontext *ctx, GLenum target, struct gl_query_object *q)
|
||||
{
|
||||
@@ -568,6 +573,7 @@ intelEndQuery(GLcontext *ctx, GLenum target, struct gl_query_object *q)
|
||||
q->Ready = GL_TRUE;
|
||||
intel->stats_wm--;
|
||||
}
|
||||
+#endif
|
||||
|
||||
/** Driver-specific fence emit implementation for the fake memory manager. */
|
||||
static unsigned int
|
||||
@@ -684,8 +690,10 @@ intelInitDriverFunctions(struct dd_function_table *functions)
|
||||
functions->CopyConvolutionFilter1D = _swrast_CopyConvolutionFilter1D;
|
||||
functions->CopyConvolutionFilter2D = _swrast_CopyConvolutionFilter2D;
|
||||
|
||||
+#ifdef I915_MMIO_READ
|
||||
functions->BeginQuery = intelBeginQuery;
|
||||
functions->EndQuery = intelEndQuery;
|
||||
+#endif
|
||||
|
||||
intelInitTextureFuncs(functions);
|
||||
intelInitStateFuncs(functions);
|
@ -1,13 +1,15 @@
|
||||
diff -up mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c.intel-nowarn mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c
|
||||
--- mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c.intel-nowarn 2008-08-14 02:28:38.000000000 +1000
|
||||
+++ mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c 2008-08-14 16:25:23.000000000 +1000
|
||||
@@ -506,9 +506,6 @@ intel_init_bufmgr(struct intel_context *
|
||||
if (intel->bufmgr == NULL) {
|
||||
diff --git a/src/mesa/drivers/dri/intel/intel_screen.c b/src/mesa/drivers/dri/intel/intel_screen.c
|
||||
index cf09fad..572a28b 100644
|
||||
--- a/src/mesa/drivers/dri/intel/intel_screen.c
|
||||
+++ b/src/mesa/drivers/dri/intel/intel_screen.c
|
||||
@@ -583,8 +583,8 @@ intel_init_bufmgr(intelScreenPrivate *intelScreen)
|
||||
if (gem_disable) {
|
||||
fprintf(stderr, "GEM disabled. Using classic.\n");
|
||||
- } else {
|
||||
} else {
|
||||
- fprintf(stderr, "Failed to initialize GEM. "
|
||||
- "Falling back to classic.\n");
|
||||
+// fprintf(stderr, "Failed to initialize GEM. "
|
||||
+// "Falling back to classic.\n");
|
||||
}
|
||||
|
||||
if (intelScreen->tex.size == 0) {
|
||||
|
11
mesa.spec
11
mesa.spec
@ -13,12 +13,12 @@
|
||||
|
||||
%define manpages gl-manpages-1.0.1
|
||||
%define xdriinfo xdriinfo-1.0.2
|
||||
%define gitdate 20080905
|
||||
%define gitdate 20081001
|
||||
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 7.2
|
||||
Release: 0.3%{?dist}
|
||||
Release: 0.4%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -39,14 +39,13 @@ Patch3: mesa-no-mach64.patch
|
||||
Patch5: r300-bufmgr.patch
|
||||
|
||||
Patch7: mesa-7.1-link-shared.patch
|
||||
Patch8: intel-mmio-fix.patch
|
||||
Patch9: intel-revert-vbl.patch
|
||||
|
||||
Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
||||
|
||||
BuildRequires: pkgconfig autoconf automake
|
||||
%if %{with_dri}
|
||||
BuildRequires: libdrm-devel >= 2.4.0-0.19
|
||||
BuildRequires: libdrm-devel >= 2.4.0-0.21
|
||||
BuildRequires: kernel-headers >= 2.6.27-0.305.rc5.git6
|
||||
%endif
|
||||
BuildRequires: libXxf86vm-devel
|
||||
@ -174,7 +173,6 @@ This package provides some demo applications for testing Mesa.
|
||||
%patch3 -p0 -b .no-mach64
|
||||
%patch5 -p1 -b .r300-bufmgr
|
||||
%patch7 -p1 -b .dricore
|
||||
%patch8 -p1 -b .intel-mmio
|
||||
%patch9 -p1 -b .intel-vbl
|
||||
%patch12 -p1 -b .intel-nowarn
|
||||
|
||||
@ -422,6 +420,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/mesa-demos-data
|
||||
|
||||
%changelog
|
||||
* Wed Oct 01 2008 Dave Airlie <airlied@redhat.com> 7.2-0.4
|
||||
- rebase to new upstream + r300 bufmgr code - openarena under kms works now
|
||||
|
||||
* Mon Sep 29 2008 Adam Jackson <ajax@redhat.com> 7.2-0.3
|
||||
- Add xdriinfo. (#464388)
|
||||
|
||||
|
3219
r300-bufmgr.patch
3219
r300-bufmgr.patch
File diff suppressed because it is too large
Load Diff
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||
d5e2a6d63b4611ec38aaab19b8f68117 mesa-20080905.tar.bz2
|
||||
a5ec51ed9f0a55dc3462d90d52ff899c xdriinfo-1.0.2.tar.bz2
|
||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||
2a67b54e44727e83045c8778db63d28d mesa-20081001.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user