Update to 24.2.8
Related: https://issues.redhat.com/browse/RHEL-64944 Resolves: https://issues.redhat.com/browse/RHEL-53894
This commit is contained in:
parent
49e955a384
commit
9f3082b88b
@ -1,39 +0,0 @@
|
|||||||
From 17dc5b6cd96dcfe64fd71789c771ca9b96d260e5 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Andrew J. Hesford" <ajh@sideband.org>
|
|
||||||
Date: Fri, 21 Jul 2023 09:50:00 -0400
|
|
||||||
Subject: [PATCH] Fix builds with Cython 3
|
|
||||||
|
|
||||||
This is a *de minimis* fix for building with Cython 3. Recent Cython<3
|
|
||||||
releases provided `Cython.Distutils.build_ext` as an alias to
|
|
||||||
`Cython.Distutils.old_build_ext.old_build_ext`; Cython 3 drops this
|
|
||||||
alias and instead uses a wholly new `Cython.Distutils.build_ext` that
|
|
||||||
does not provide the `cython_sources` function used in `setup.py`.
|
|
||||||
|
|
||||||
Explicitly importing `old_build_ext` preserves the existing behavior for
|
|
||||||
recent Cython<3 and uses the correct behavior for Cython 3. Should the
|
|
||||||
import fail (*e.g.*, because the version of Cython available predates
|
|
||||||
the availability of `old_build_ext`), the import falls back to just
|
|
||||||
`Cython.Distutils.build_ext`.
|
|
||||||
|
|
||||||
Signed-off-by: Andrew J. Hesford <ajh@sideband.org>
|
|
||||||
---
|
|
||||||
setup.py | 6 +++++-
|
|
||||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/setup.py b/setup.py
|
|
||||||
index 944e7fa2..462b1e95 100644
|
|
||||||
--- a/setup.py
|
|
||||||
+++ b/setup.py
|
|
||||||
@@ -82,7 +82,11 @@
|
|
||||||
with_cython = True
|
|
||||||
try:
|
|
||||||
from Cython.Distutils.extension import Extension as _Extension
|
|
||||||
- from Cython.Distutils import build_ext as _build_ext
|
|
||||||
+ try:
|
|
||||||
+ from Cython.Distutils.old_build_ext import old_build_ext as _build_ext
|
|
||||||
+ except ImportError:
|
|
||||||
+ from Cython.Distutils import build_ext as _build_ext
|
|
||||||
+
|
|
||||||
with_cython = True
|
|
||||||
except ImportError:
|
|
||||||
if with_cython:
|
|
@ -66,7 +66,7 @@
|
|||||||
|
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
%global ver 24.2.6
|
%global ver 24.2.8
|
||||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||||
Release: %autorelease
|
Release: %autorelease
|
||||||
License: MIT AND BSD-3-Clause AND SGI-B-2.0
|
License: MIT AND BSD-3-Clause AND SGI-B-2.0
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (libclc-19.1.1.src.tar.xz) = 41ba80e2ed8f874d79c40cfbb1de89ad9e1ecc3709519e697617c14bc2583b2f8cdb8ca20bd2095b436afcc69144a6d88d4334de1e152d78ef3a19ec14c0733d
|
SHA512 (libclc-19.1.1.src.tar.xz) = 41ba80e2ed8f874d79c40cfbb1de89ad9e1ecc3709519e697617c14bc2583b2f8cdb8ca20bd2095b436afcc69144a6d88d4334de1e152d78ef3a19ec14c0733d
|
||||||
SHA512 (mesa-24.2.6.tar.xz) = 830a40d38200ff8b2a6bd949e1ac3bf4edc887a10d9aa92285007d138079e1fafb3568f658e777e7894e95b5ce75d2bd6836b0473fa70d32270005e482b1a2da
|
SHA512 (mesa-24.2.8.tar.xz) = 3aa1051a72e1428e42f9537d8f6a26f2ebddc78894e0f71d2cdcc9ed555ea4d6489ad8e74d4c59b8cdf7ea1c629fa725ac2fe1e385db5d3a582d8fe8186392d6
|
||||||
SHA512 (spirv-llvm-translator-90a9764.tar.gz) = c0be7326fa76927f9900a9d91ced0035aeee66cdab35baa9c708b27c5d5e423f4819f148d17c3b7b812d1e8991e1057d71d52c22df2de37efdd72f1c20dcf05e
|
SHA512 (spirv-llvm-translator-90a9764.tar.gz) = c0be7326fa76927f9900a9d91ced0035aeee66cdab35baa9c708b27c5d5e423f4819f148d17c3b7b812d1e8991e1057d71d52c22df2de37efdd72f1c20dcf05e
|
||||||
|
Loading…
Reference in New Issue
Block a user