- mesa-7.0.1-stable-branch.patch - Updated to close to 7.0.2-rc1
- This contains the fixes made to the upstream Mesa stable branch including fixes for 965 vblank interrupt issues along with a fix in the kernel - remove patches that already upstream. - mesa-6.5.2-hush-synthetic-visual-warning.patch - dropped - mesa-7.0-i-already-defined-glapi-you-twit.patch - dropped - mesa-7.0.1-965-sampler-crash.patch - dropped
This commit is contained in:
parent
bd476b00cf
commit
9cda76aa3c
@ -1,11 +0,0 @@
|
|||||||
--- Mesa-6.5.2/src/glx/x11/glxext.c.jx 2006-11-15 09:55:47.000000000 -0500
|
|
||||||
+++ Mesa-6.5.2/src/glx/x11/glxext.c 2007-01-16 10:48:15.000000000 -0500
|
|
||||||
@@ -666,6 +666,8 @@
|
|
||||||
if ( do_delete && (m->visualID != 0) ) {
|
|
||||||
do_delete = GL_FALSE;
|
|
||||||
|
|
||||||
+ if (m->visualRating != GLX_NON_CONFORMANT_VISUAL_EXT ||
|
|
||||||
+ getenv("LIBGL_DEBUG"))
|
|
||||||
fprintf(stderr, "libGL warning: 3D driver claims to not support "
|
|
||||||
"visual 0x%02x\n", m->visualID);
|
|
||||||
}
|
|
@ -1,23 +0,0 @@
|
|||||||
diff -up mesa-20070725/include/GL/glu.h.jx mesa-20070725/include/GL/glu.h
|
|
||||||
--- mesa-20070725/include/GL/glu.h.jx 2007-07-25 09:36:03.000000000 -0400
|
|
||||||
+++ mesa-20070725/include/GL/glu.h 2007-07-25 10:27:49.000000000 -0400
|
|
||||||
@@ -44,19 +44,6 @@
|
|
||||||
#define GLAPIENTRYP GLAPIENTRY *
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-#ifdef GLAPI
|
|
||||||
-#undef GLAPI
|
|
||||||
-#endif
|
|
||||||
-
|
|
||||||
-# if (defined(_MSC_VER) || defined(__MINGW32__)) && defined(BUILD_GLU32)
|
|
||||||
-# define GLAPI __declspec(dllexport)
|
|
||||||
-# elif (defined(_MSC_VER) || defined(__MINGW32__)) && defined(_DLL) /* tag specifying we're building for DLL runtime support */
|
|
||||||
-# define GLAPI __declspec(dllimport)
|
|
||||||
-# else /* for use with static link lib build of Win32 edition only */
|
|
||||||
-# define GLAPI extern
|
|
||||||
-# endif /* _STATIC_MESA support */
|
|
||||||
-
|
|
||||||
-
|
|
||||||
#ifndef GLAPI
|
|
||||||
#define GLAPI
|
|
||||||
#endif
|
|
@ -1,19 +0,0 @@
|
|||||||
commit 410d8f7cdb40889e66f5c6794878ad9a5f572ee7
|
|
||||||
Author: Xiang, Haihao <haihao.xiang@intel.com>
|
|
||||||
Date: Wed Aug 29 10:13:10 2007 -0400
|
|
||||||
|
|
||||||
i965: samplers group in fours in WM_STATE. fix bug#9415
|
|
||||||
|
|
||||||
diff --git a/src/mesa/drivers/dri/i965/brw_wm_state.c b/src/mesa/drivers/dri/i965/brw_wm_state.c
|
|
||||||
index ff5cb31..5b4f2ab 100644
|
|
||||||
--- a/src/mesa/drivers/dri/i965/brw_wm_state.c
|
|
||||||
+++ b/src/mesa/drivers/dri/i965/brw_wm_state.c
|
|
||||||
@@ -117,7 +117,7 @@ static void upload_wm_unit(struct brw_context *brw )
|
|
||||||
wm.thread1.floating_point_mode = BRW_FLOATING_POINT_NON_IEEE_754;
|
|
||||||
|
|
||||||
/* CACHE_NEW_SAMPLER */
|
|
||||||
- wm.wm4.sampler_count = brw->wm.sampler_count;
|
|
||||||
+ wm.wm4.sampler_count = (brw->wm.sampler_count + 1) / 4;
|
|
||||||
wm.wm4.sampler_state_pointer = brw->wm.sampler_gs_offset >> 5;
|
|
||||||
|
|
||||||
/* BRW_NEW_FRAGMENT_PROGRAM */
|
|
File diff suppressed because it is too large
Load Diff
17
mesa.spec
17
mesa.spec
@ -32,7 +32,7 @@
|
|||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.0.1
|
Version: 7.0.1
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
@ -46,13 +46,10 @@ Patch0: mesa-7.0-build-config.patch
|
|||||||
Patch4: mesa-6.5-dont-libglut-me-harder-ok-thx-bye.patch
|
Patch4: mesa-6.5-dont-libglut-me-harder-ok-thx-bye.patch
|
||||||
Patch5: mesa-6.5.2-xserver-1.1-source-compat.patch
|
Patch5: mesa-6.5.2-xserver-1.1-source-compat.patch
|
||||||
Patch18: mesa-7.0-selinux-awareness.patch
|
Patch18: mesa-7.0-selinux-awareness.patch
|
||||||
Patch22: mesa-6.5.2-hush-synthetic-visual-warning.patch
|
|
||||||
Patch23: mesa-6.5.2-bindcontext-paranoia.patch
|
Patch23: mesa-6.5.2-bindcontext-paranoia.patch
|
||||||
Patch24: mesa-7.0-i-already-defined-glapi-you-twit.patch
|
|
||||||
Patch25: mesa-7.0-symlinks-before-depend.patch
|
Patch25: mesa-7.0-symlinks-before-depend.patch
|
||||||
Patch26: mesa-7.0.1-stable-branch.patch
|
Patch26: mesa-7.0.1-stable-branch.patch
|
||||||
Patch27: mesa-7.0-use_master-r300.patch
|
Patch27: mesa-7.0-use_master-r300.patch
|
||||||
Patch28: mesa-7.0.1-965-sampler-crash.patch
|
|
||||||
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
@ -178,13 +175,10 @@ chmod a-x progs/demos/glslnoise.c
|
|||||||
%patch4 -p0 -b .dont-libglut-me-harder-ok-thx-bye
|
%patch4 -p0 -b .dont-libglut-me-harder-ok-thx-bye
|
||||||
%patch5 -p1 -b .xserver-1.1-compat
|
%patch5 -p1 -b .xserver-1.1-compat
|
||||||
%patch18 -p1 -b .selinux-awareness
|
%patch18 -p1 -b .selinux-awareness
|
||||||
%patch22 -p1 -b .visual-warning
|
|
||||||
%patch23 -p1 -b .bindcontext
|
%patch23 -p1 -b .bindcontext
|
||||||
%patch24 -p1 -b .glapi
|
|
||||||
%patch25 -p1 -b .makej
|
%patch25 -p1 -b .makej
|
||||||
%patch26 -p1 -b .stable
|
%patch26 -p1 -b .stable
|
||||||
%patch27 -p1 -b .r300
|
%patch27 -p1 -b .r300
|
||||||
%patch28 -p1 -b .965-sampler
|
|
||||||
|
|
||||||
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
# WARNING: The following files are copyright "Mark J. Kilgard" under the GLUT
|
||||||
# license and are not open source/free software, so we remove them.
|
# license and are not open source/free software, so we remove them.
|
||||||
@ -414,6 +408,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/mesa-demos-data
|
%{_libdir}/mesa-demos-data
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Sep 28 2007 Dave Airlie <airlied@redhat.com> 7.0.1-6
|
||||||
|
- mesa-7.0.1-stable-branch.patch - Updated to close to 7.0.2-rc1
|
||||||
|
- This contains the fixes made to the upstream Mesa stable branch
|
||||||
|
including fixes for 965 vblank interrupt issues along with a fix
|
||||||
|
in the kernel - remove patches that already upstream.
|
||||||
|
- mesa-6.5.2-hush-synthetic-visual-warning.patch - dropped
|
||||||
|
- mesa-7.0-i-already-defined-glapi-you-twit.patch - dropped
|
||||||
|
- mesa-7.0.1-965-sampler-crash.patch - dropped
|
||||||
|
|
||||||
* Thu Sep 06 2007 Adam Jackson <ajax@redhat.com> 7.0.1-5
|
* Thu Sep 06 2007 Adam Jackson <ajax@redhat.com> 7.0.1-5
|
||||||
- mesa-7.0.1-965-sampler-crash.patch: Fix a crash with 965 in Torcs. (#262941)
|
- mesa-7.0.1-965-sampler-crash.patch: Fix a crash with 965 in Torcs. (#262941)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user