latest git snapshot, seems quiet + re-enable llvmcore

This commit is contained in:
Dave Airlie 2011-03-27 19:07:15 +10:00
parent 0197c64a41
commit 9b6f314709
4 changed files with 32 additions and 25 deletions

1
.gitignore vendored
View File

@ -16,3 +16,4 @@ mesa-20100720.tar.bz2
/mesa-20101216.tar.xz /mesa-20101216.tar.xz
/mesa-20110107.tar.xz /mesa-20110107.tar.xz
/mesa-20110315.tar.xz /mesa-20110315.tar.xz
/mesa-20110327.tar.xz

View File

@ -1,7 +1,8 @@
diff -up mesa-20110107/configs/autoconf.in.llvmcore mesa-20110107/configs/autoconf.in diff --git a/configs/autoconf.in b/configs/autoconf.in
--- mesa-20110107/configs/autoconf.in.llvmcore 2011-01-06 19:51:14.000000000 -0500 index 4e931a3..fec8e42 100644
+++ mesa-20110107/configs/autoconf.in 2011-01-18 19:34:49.000000000 -0500 --- a/configs/autoconf.in
@@ -29,8 +29,8 @@ INTEL_CFLAGS = @INTEL_CFLAGS@ +++ b/configs/autoconf.in
@@ -31,8 +31,8 @@ INTEL_CFLAGS = @INTEL_CFLAGS@
X11_LIBS = @X11_LIBS@ X11_LIBS = @X11_LIBS@
X11_CFLAGS = @X11_CFLAGS@ X11_CFLAGS = @X11_CFLAGS@
LLVM_CFLAGS = @LLVM_CFLAGS@ LLVM_CFLAGS = @LLVM_CFLAGS@
@ -11,25 +12,27 @@ diff -up mesa-20110107/configs/autoconf.in.llvmcore mesa-20110107/configs/autoco
+LLVM_LIBS = -lllvmcore-$(shell llvm-config --version) +LLVM_LIBS = -lllvmcore-$(shell llvm-config --version)
GLW_CFLAGS = @GLW_CFLAGS@ GLW_CFLAGS = @GLW_CFLAGS@
GLUT_CFLAGS = @GLUT_CFLAGS@ GLUT_CFLAGS = @GLUT_CFLAGS@
GLX_TLS = @GLX_TLS@
diff -up mesa-20110107/configs/linux-llvm.llvmcore mesa-20110107/configs/linux-llvm diff --git a/configs/linux-llvm b/configs/linux-llvm
--- mesa-20110107/configs/linux-llvm.llvmcore 2011-01-06 19:51:14.000000000 -0500 index 359bee2..0de094d 100644
+++ mesa-20110107/configs/linux-llvm 2011-01-18 19:19:14.000000000 -0500 --- a/configs/linux-llvm
+++ b/configs/linux-llvm
@@ -32,8 +32,8 @@ endif @@ -32,8 +32,8 @@ endif
ifeq ($(MESA_LLVM),1) ifeq ($(MESA_LLVM),1)
LLVM_CFLAGS=`llvm-config --cppflags` LLVM_CFLAGS=`llvm-config --cppflags`
LLVM_CXXFLAGS=`llvm-config --cxxflags backend bitreader engine ipo interpreter instrumentation` -Wno-long-long LLVM_CXXFLAGS=`llvm-config --cxxflags` -Wno-long-long
- LLVM_LDFLAGS = $(shell llvm-config --ldflags backend bitreader engine ipo interpreter instrumentation) - LLVM_LDFLAGS = $(shell llvm-config --ldflags)
- LLVM_LIBS = $(shell llvm-config --libs backend bitwriter bitreader engine ipo interpreter instrumentation) - LLVM_LIBS = $(shell llvm-config --libs)
+ LLVM_LDFLAGS = -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -lllvmcore-$(shell llvm-config --version) + LLVM_LDFLAGS = -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -lllvmcore-$(shell llvm-config --version)
+ LLVM_LIBS = -lllvmcore-$(shell llvm-config --version) + LLVM_LIBS = -lllvmcore-$(shell llvm-config --version)
MKLIB_OPTIONS=-cplusplus MKLIB_OPTIONS=-cplusplus
else else
LLVM_CFLAGS= LLVM_CFLAGS=
diff -up mesa-20110107/configure.ac.llvmcore mesa-20110107/configure.ac diff --git a/configure.ac b/configure.ac
--- mesa-20110107/configure.ac.llvmcore 2011-01-18 19:19:14.000000000 -0500 index b510151..e872f2e 100644
+++ mesa-20110107/configure.ac 2011-01-18 20:40:01.000000000 -0500 --- a/configure.ac
@@ -1333,8 +1333,6 @@ if test "x$enable_gallium" = xyes; then +++ b/configure.ac
@@ -1404,8 +1404,6 @@ if test "x$enable_gallium" = xyes; then
fi fi
AC_SUBST([LLVM_CFLAGS]) AC_SUBST([LLVM_CFLAGS])
@ -38,11 +41,11 @@ diff -up mesa-20110107/configure.ac.llvmcore mesa-20110107/configure.ac
AC_SUBST([LLVM_VERSION]) AC_SUBST([LLVM_VERSION])
dnl dnl
@@ -1555,7 +1553,6 @@ if test "x$enable_gallium_llvm" = xyes; @@ -1649,7 +1647,6 @@ if test "x$enable_gallium_llvm" = xyes; then
if test "x$LLVM_CONFIG" != xno; then if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version` LLVM_VERSION=`$LLVM_CONFIG --version`
LLVM_CFLAGS=`$LLVM_CONFIG --cppflags` LLVM_CFLAGS=`$LLVM_CONFIG --cppflags`
- LLVM_LIBS="`$LLVM_CONFIG --libs jit interpreter nativecodegen bitwriter` -lstdc++" - LLVM_LIBS="`$LLVM_CONFIG --libs` -lstdc++"
if test "x$HAS_UDIS86" != xno; then LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_LIBS="$LLVM_LIBS -ludis86" GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"

View File

@ -7,18 +7,18 @@
%endif %endif
# broken atm, sorry. fix before any f15 merge. # broken atm, sorry. fix before any f15 merge.
%define with_llvmcore 0 %define with_llvmcore 1
%define _default_patch_fuzz 2 %define _default_patch_fuzz 2
%define manpages gl-manpages-1.0.1 %define manpages gl-manpages-1.0.1
%define gitdate 20110315 %define gitdate 20110327
#% define snapshot #% define snapshot
Summary: Mesa graphics libraries Summary: Mesa graphics libraries
Name: mesa Name: mesa
Version: 7.11 Version: 7.11
Release: 0.%{gitdate}.0%{?dist} Release: 0.1.%{gitdate}.0%{?dist}
License: MIT License: MIT
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.mesa3d.org URL: http://www.mesa3d.org
@ -298,7 +298,7 @@ make install DESTDIR=$RPM_BUILD_ROOT DRI_DIRS=
# just the DRI drivers that are sane # just the DRI drivers that are sane
install -d $RPM_BUILD_ROOT%{_libdir}/dri install -d $RPM_BUILD_ROOT%{_libdir}/dri
%if %{with_llvmcore} %if %{with_llvmcore}
install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri %{_lib}/libllvmcore-2.8.so >& /dev/null install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri %{_lib}/libllvmcore-2*.so >& /dev/null
%endif %endif
# use gallium driver iff built # use gallium driver iff built
[ -f %{_lib}/gallium/r300_dri.so ] && cp %{_lib}/gallium/r300_dri.so %{_lib}/r300_dri.so [ -f %{_lib}/gallium/r300_dri.so ] && cp %{_lib}/gallium/r300_dri.so %{_lib}/r300_dri.so
@ -380,7 +380,7 @@ rm -rf $RPM_BUILD_ROOT
%if %{with_llvmcore} %if %{with_llvmcore}
%files dri-llvmcore %files dri-llvmcore
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_libdir}/dri/libllvmcore-2.8.so %{_libdir}/dri/libllvmcore-2.*.so
%endif %endif
%files dri-drivers %files dri-drivers
@ -477,6 +477,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/libOSMesa.so %{_libdir}/libOSMesa.so
%changelog %changelog
* Sun Mar 27 2011 Dave Airlie <airlied@redhat.com> 7.11-0.1.20110327.0
- latest git snapshot, seems quiet + re-enable llvmcore
* Tue Mar 15 2011 Adam Jackson <ajax@redhat.com> 7.11-0.20110315.0 * Tue Mar 15 2011 Adam Jackson <ajax@redhat.com> 7.11-0.20110315.0
- Today's git snap - Today's git snap
- Add with_llvmcore macro, and turn it off momentarily - Add with_llvmcore macro, and turn it off momentarily

View File

@ -1,2 +1,2 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2 6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
1884f6929207763aab7a907c7e9bf75c mesa-20110315.tar.xz 3ad97eb2b70c9cd1ec8483e826f02b01 mesa-20110327.tar.xz