- r300-bufmgr.patch: make radeon/r200 work
This commit is contained in:
parent
e3c23c336b
commit
981a0d7018
@ -18,7 +18,7 @@
|
|||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.3
|
Version: 7.3
|
||||||
Release: 0.2%{?dist}
|
Release: 0.3%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
@ -173,7 +173,7 @@ This package provides some demo applications for testing Mesa.
|
|||||||
%patch0 -p1 -b .osmesa
|
%patch0 -p1 -b .osmesa
|
||||||
%patch2 -p1 -b .intel-glthread
|
%patch2 -p1 -b .intel-glthread
|
||||||
%patch3 -p0 -b .no-mach64
|
%patch3 -p0 -b .no-mach64
|
||||||
#patch5 -p1 -b .r300-bufmgr
|
%patch5 -p1 -b .r300-bufmgr
|
||||||
%patch7 -p1 -b .dricore
|
%patch7 -p1 -b .dricore
|
||||||
%patch9 -p1 -b .intel-vbl
|
%patch9 -p1 -b .intel-vbl
|
||||||
%patch12 -p1 -b .intel-nowarn
|
%patch12 -p1 -b .intel-nowarn
|
||||||
@ -430,6 +430,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/mesa-demos-data
|
%{_libdir}/mesa-demos-data
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Dec 21 2008 Dave Airlie <airlied@redhat.com> 7.3-0.3
|
||||||
|
- r300-bufmgr.patch: make radeon/r200 work
|
||||||
|
|
||||||
* Sun Dec 21 2008 Dave Airlie <airlied@redhat.com> 7.3-0.2
|
* Sun Dec 21 2008 Dave Airlie <airlied@redhat.com> 7.3-0.2
|
||||||
- intel-fix-sarea-define.patch - workaround wrong define
|
- intel-fix-sarea-define.patch - workaround wrong define
|
||||||
- intel-triple-remove.patch - remove triple buffering
|
- intel-triple-remove.patch - remove triple buffering
|
||||||
|
@ -1,3 +1,18 @@
|
|||||||
|
diff --git a/src/mesa/drivers/dri/r200/Makefile b/src/mesa/drivers/dri/r200/Makefile
|
||||||
|
index e9144ac..7064f42 100644
|
||||||
|
--- a/src/mesa/drivers/dri/r200/Makefile
|
||||||
|
+++ b/src/mesa/drivers/dri/r200/Makefile
|
||||||
|
@@ -48,7 +48,9 @@ SYMLINKS = \
|
||||||
|
COMMON_SYMLINKS = \
|
||||||
|
radeon_chipset.h \
|
||||||
|
radeon_screen.c \
|
||||||
|
- radeon_screen.h
|
||||||
|
+ radeon_screen.h \
|
||||||
|
+ radeon_bo_legacy.h \
|
||||||
|
+ radeon_buffer.h
|
||||||
|
|
||||||
|
##### TARGETS #####
|
||||||
|
|
||||||
diff --git a/src/mesa/drivers/dri/r300/Makefile b/src/mesa/drivers/dri/r300/Makefile
|
diff --git a/src/mesa/drivers/dri/r300/Makefile b/src/mesa/drivers/dri/r300/Makefile
|
||||||
index 6ca9342..cbb09e6 100644
|
index 6ca9342..cbb09e6 100644
|
||||||
--- a/src/mesa/drivers/dri/r300/Makefile
|
--- a/src/mesa/drivers/dri/r300/Makefile
|
||||||
@ -9894,7 +9909,7 @@ index 0000000..71a4dad
|
|||||||
+
|
+
|
||||||
+#endif
|
+#endif
|
||||||
diff --git a/src/mesa/drivers/dri/radeon/radeon_screen.c b/src/mesa/drivers/dri/radeon/radeon_screen.c
|
diff --git a/src/mesa/drivers/dri/radeon/radeon_screen.c b/src/mesa/drivers/dri/radeon/radeon_screen.c
|
||||||
index 5f32dd5..0dda28e 100644
|
index 5f32dd5..d579509 100644
|
||||||
--- a/src/mesa/drivers/dri/radeon/radeon_screen.c
|
--- a/src/mesa/drivers/dri/radeon/radeon_screen.c
|
||||||
+++ b/src/mesa/drivers/dri/radeon/radeon_screen.c
|
+++ b/src/mesa/drivers/dri/radeon/radeon_screen.c
|
||||||
@@ -35,6 +35,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
@@ -35,6 +35,7 @@ WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
|
||||||
@ -10404,7 +10419,7 @@ index 5f32dd5..0dda28e 100644
|
|||||||
radeonSetSpanFunctions(depthRb, mesaVis);
|
radeonSetSpanFunctions(depthRb, mesaVis);
|
||||||
_mesa_add_renderbuffer(fb, BUFFER_DEPTH, &depthRb->Base);
|
_mesa_add_renderbuffer(fb, BUFFER_DEPTH, &depthRb->Base);
|
||||||
- depthRb->depthHasSurface = screen->depthHasSurface;
|
- depthRb->depthHasSurface = screen->depthHasSurface;
|
||||||
+ depthRb->has_surface = screen->depthHasSurface;
|
+ // depthRb->has_surface = screen->depthHasSurface;
|
||||||
}
|
}
|
||||||
else if (mesaVis->depthBits == 24) {
|
else if (mesaVis->depthBits == 24) {
|
||||||
driRenderbuffer *depthRb
|
driRenderbuffer *depthRb
|
||||||
@ -10413,7 +10428,7 @@ index 5f32dd5..0dda28e 100644
|
|||||||
radeonSetSpanFunctions(depthRb, mesaVis);
|
radeonSetSpanFunctions(depthRb, mesaVis);
|
||||||
_mesa_add_renderbuffer(fb, BUFFER_DEPTH, &depthRb->Base);
|
_mesa_add_renderbuffer(fb, BUFFER_DEPTH, &depthRb->Base);
|
||||||
- depthRb->depthHasSurface = screen->depthHasSurface;
|
- depthRb->depthHasSurface = screen->depthHasSurface;
|
||||||
+ depthRb->has_surface = screen->depthHasSurface;
|
+ // depthRb->has_surface = screen->depthHasSurface;
|
||||||
}
|
}
|
||||||
|
|
||||||
/* stencil renderbuffer */
|
/* stencil renderbuffer */
|
||||||
@ -10422,7 +10437,7 @@ index 5f32dd5..0dda28e 100644
|
|||||||
radeonSetSpanFunctions(stencilRb, mesaVis);
|
radeonSetSpanFunctions(stencilRb, mesaVis);
|
||||||
_mesa_add_renderbuffer(fb, BUFFER_STENCIL, &stencilRb->Base);
|
_mesa_add_renderbuffer(fb, BUFFER_STENCIL, &stencilRb->Base);
|
||||||
- stencilRb->depthHasSurface = screen->depthHasSurface;
|
- stencilRb->depthHasSurface = screen->depthHasSurface;
|
||||||
+ stencilRb->has_surface = screen->depthHasSurface;
|
+ //stencilRb->has_surface = screen->depthHasSurface;
|
||||||
}
|
}
|
||||||
|
|
||||||
_mesa_add_soft_renderbuffers(fb,
|
_mesa_add_soft_renderbuffers(fb,
|
||||||
@ -10577,17 +10592,3 @@ index 9abe086..1650a9b 100644
|
|||||||
+extern void radeonSetSpanFunctions(driRenderbuffer * rb, const GLvisual * vis);
|
+extern void radeonSetSpanFunctions(driRenderbuffer * rb, const GLvisual * vis);
|
||||||
+#endif
|
+#endif
|
||||||
#endif
|
#endif
|
||||||
diff -up mesa-20081220/src/mesa/drivers/dri/r200/Makefile.dave mesa-20081220/src/mesa/drivers/dri/r200/Makefile
|
|
||||||
--- mesa-20081220/src/mesa/drivers/dri/r200/Makefile.dave 2008-12-21 09:24:58.000000000 +1000
|
|
||||||
+++ mesa-20081220/src/mesa/drivers/dri/r200/Makefile 2008-12-21 09:26:11.000000000 +1000
|
|
||||||
@@ -48,7 +48,9 @@ SYMLINKS = \
|
|
||||||
COMMON_SYMLINKS = \
|
|
||||||
radeon_chipset.h \
|
|
||||||
radeon_screen.c \
|
|
||||||
- radeon_screen.h
|
|
||||||
+ radeon_screen.h \
|
|
||||||
+ radeon_bo_legacy.h \
|
|
||||||
+ radeon_buffer.h
|
|
||||||
|
|
||||||
##### TARGETS #####
|
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user