- resnapshot from upstream for libdrm_radeon changes

This commit is contained in:
Dave Airlie 2009-12-20 22:50:28 +00:00
parent b9986d793d
commit 9636c0fb79
7 changed files with 36 additions and 82 deletions

View File

@ -8,3 +8,4 @@ mesa-20090813.tar.bz2
mesa-20090909.tar.bz2
mesa-20090921.tar.bz2
xdriinfo-1.0.3.tar.bz2
mesa-20091221.tar.bz2

View File

@ -1,6 +1,6 @@
diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.dricore mesa-20080814/src/mesa/drivers/dri/Makefile
--- mesa-20080814/src/mesa/drivers/dri/Makefile.dricore 2008-08-14 02:28:38.000000000 +1000
+++ mesa-20080814/src/mesa/drivers/dri/Makefile 2008-08-14 16:18:20.000000000 +1000
diff -up mesa-20091221/src/mesa/drivers/dri/Makefile.da mesa-20091221/src/mesa/drivers/dri/Makefile
--- mesa-20091221/src/mesa/drivers/dri/Makefile.da 2009-12-21 08:09:11.000000000 +1000
+++ mesa-20091221/src/mesa/drivers/dri/Makefile 2009-12-21 08:43:03.000000000 +1000
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
@ -20,7 +20,7 @@ diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.dricore mesa-20080814/src/m
subdirs:
@for dir in $(DRI_DIRS) ; do \
@@ -31,12 +36,14 @@ dri.pc: dri.pc.in
@@ -32,12 +37,14 @@ dri.pc: dri.pc.in
$(pcedit) $< > $@
@ -36,38 +36,36 @@ diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.dricore mesa-20080814/src/m
$(INSTALL) -d $(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h \
$(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
@@ -52,5 +59,6 @@ clean:
@@ -51,5 +58,6 @@ clean:
(cd $$dir && $(MAKE) clean) ; \
fi \
done
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
-rm -f common/*.o
-rm -f *.pc
diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080814/src/mesa/drivers/dri/Makefile.template
--- mesa-20080814/src/mesa/drivers/dri/Makefile.template.dricore 2008-08-14 02:28:38.000000000 +1000
+++ mesa-20080814/src/mesa/drivers/dri/Makefile.template 2008-08-14 16:19:37.000000000 +1000
diff -up mesa-20091221/src/mesa/drivers/dri/Makefile.template.da mesa-20091221/src/mesa/drivers/dri/Makefile.template
--- mesa-20091221/src/mesa/drivers/dri/Makefile.template.da 2009-12-21 08:09:11.000000000 +1000
+++ mesa-20091221/src/mesa/drivers/dri/Makefile.template 2009-12-21 08:43:40.000000000 +1000
@@ -1,6 +1,6 @@
# -*-makefile-*-
-MESA_MODULES = $(TOP)/src/mesa/libmesa.a
+MESA_MODULES = $(TOP)/$(LIB_DIR)/libdricore.so
COMMON_SOURCES = \
COMMON_GALLIUM_SOURCES = \
../common/utils.c \
@@ -64,7 +64,9 @@ default: symlinks depend $(LIBNAME) $(TO
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
@@ -70,7 +70,7 @@ lib: symlinks subdirs depend
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(EXTRA_MODULES) $(WINOBJ) Makefile \
$(TOP)/src/mesa/drivers/dri/Makefile.template
$(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \
- $(OBJECTS) $(PIPE_DRIVERS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
+ $(OBJECTS) $(PIPE_DRIVERS) $(WINOBJ) \
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
+ $(DRI_LIB_DEPS)
- $(OBJECTS) $(MESA_MODULES) $(EXTRA_MODULES) $(WINOBJ) \
+ $(OBJECTS) $(EXTRA_MODULES) $(WINOBJ) \
$(DRI_LIB_DEPS)
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
diff -up mesa-20080814/src/mesa/x86/read_rgba_span_x86.S.dricore mesa-20080814/src/mesa/x86/read_rgba_span_x86.S
--- mesa-20080814/src/mesa/x86/read_rgba_span_x86.S.dricore 2008-08-14 02:28:38.000000000 +1000
+++ mesa-20080814/src/mesa/x86/read_rgba_span_x86.S 2008-08-14 16:16:49.000000000 +1000
diff -up mesa-20091221/src/mesa/x86/read_rgba_span_x86.S.da mesa-20091221/src/mesa/x86/read_rgba_span_x86.S
--- mesa-20091221/src/mesa/x86/read_rgba_span_x86.S.da 2009-12-21 08:09:11.000000000 +1000
+++ mesa-20091221/src/mesa/x86/read_rgba_span_x86.S 2009-12-21 08:43:03.000000000 +1000
@@ -77,7 +77,6 @@
*/

View File

@ -1,11 +0,0 @@
--- mesa-20090322/src/mesa/sparc/xform.S.BAD 2009-04-10 17:19:53.000000000 -0500
+++ mesa-20090322/src/mesa/sparc/xform.S 2009-04-10 17:20:57.000000000 -0500
@@ -17,7 +17,7 @@
#include "sparc_matrix.h"
-#if defined(SVR4) || defined(__SVR4) || defined(__svr4__)
+#if defined(SVR4) || defined(__SVR4) || defined(__svr4__) || defined(__arch64__)
/* Solaris requires this for 64-bit. */
.register %g2, #scratch
.register %g3, #scratch

View File

@ -1,7 +1,7 @@
diff -up mesa-20090723/configure.ac.mach64 mesa-20090723/configure.ac
--- mesa-20090723/configure.ac.mach64 2009-07-23 12:11:01.000000000 +1000
+++ mesa-20090723/configure.ac 2009-07-23 12:11:22.000000000 +1000
@@ -713,7 +713,7 @@ if test "$mesa_driver" = dri; then
diff -up mesa-20091221/configure.ac.da mesa-20091221/configure.ac
--- mesa-20091221/configure.ac.da 2009-12-21 08:09:11.000000000 +1000
+++ mesa-20091221/configure.ac 2009-12-21 08:41:04.000000000 +1000
@@ -723,7 +723,7 @@ if test "$mesa_driver" = dri; then
# because there is no x86-64 system where they could *ever*
# be used.
if test "x$DRI_DIRS" = "xyes"; then
@ -10,7 +10,7 @@ diff -up mesa-20090723/configure.ac.mach64 mesa-20090723/configure.ac
savage tdfx unichrome swrast"
fi
;;
@@ -721,13 +721,13 @@ if test "$mesa_driver" = dri; then
@@ -731,13 +731,13 @@ if test "$mesa_driver" = dri; then
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
@ -26,7 +26,7 @@ diff -up mesa-20090723/configure.ac.mach64 mesa-20090723/configure.ac
fi
;;
esac
@@ -746,7 +746,7 @@ if test "$mesa_driver" = dri; then
@@ -756,7 +756,7 @@ if test "$mesa_driver" = dri; then
# ffb and gamma are missing because they have not been converted
# to use the new interface.
if test "x$DRI_DIRS" = "xyes"; then
@ -35,12 +35,12 @@ diff -up mesa-20090723/configure.ac.mach64 mesa-20090723/configure.ac
unichrome savage sis swrast"
fi
;;
@@ -765,7 +765,7 @@ if test "$mesa_driver" = dri; then
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon s3v \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon s3v \
savage sis tdfx trident unichrome ffb swrast"
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
savage sis tdfx unichrome ffb swrast"
fi

View File

@ -13,15 +13,15 @@
%define manpages gl-manpages-1.0.1
%define xdriinfo xdriinfo-1.0.3
%define gitdate 20090921
%define gitdate 20091221
#% define snapshot
%define demodir %{_libdir}/mesa
Summary: Mesa graphics libraries
Name: mesa
Version: 7.6
Release: 0.13%{?dist}
Version: 7.8
Release: 0.1%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -43,9 +43,6 @@ Patch3: mesa-no-mach64.patch
Patch7: mesa-7.1-link-shared.patch
Patch9: intel-revert-vbl.patch
Patch10: r600-fix-tfp.patch
Patch13: mesa-7.5-sparc64.patch
Patch30: mesa-7.6-hush-vblank-warning.patch
@ -178,8 +175,6 @@ This package provides some demo applications for testing Mesa.
%patch3 -p1 -b .no-mach64
%patch7 -p1 -b .dricore
%patch9 -p1 -b .intel-vbl
%patch10 -p1 -b .r600_tfp
%patch13 -p1 -b .sparc64
%patch30 -p1 -b .vblank-warning
# Hack the demos to use installed data files
@ -387,6 +382,9 @@ rm -rf $RPM_BUILD_ROOT
%{demodir}
%changelog
* Mon Dec 21 2009 Dave Airlie <airlied@redhat.com> 7.8-0.1
- resnapshot from upstream for libdrm_radeon changes
* Mon Oct 19 2009 Adam Jackson <ajax@redhat.com>
- xdriinfo 1.0.3

View File

@ -1,31 +0,0 @@
From 5aaa45de4c367dd6ec5daa6f4a54504b0aff1aca Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@linux.ie>
Date: Wed, 9 Sep 2009 15:02:16 +1000
Subject: [PATCH] r600: don't setup hardware state if TFP
if we have a BO here it means TFP and we should have set it
up already.
tested by b0le on #radeon
---
src/mesa/drivers/dri/r600/r600_texstate.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/src/mesa/drivers/dri/r600/r600_texstate.c b/src/mesa/drivers/dri/r600/r600_texstate.c
index fff6e74..ff4ef1e 100644
--- a/src/mesa/drivers/dri/r600/r600_texstate.c
+++ b/src/mesa/drivers/dri/r600/r600_texstate.c
@@ -608,6 +608,10 @@ static void setup_hardware_state(context_t *rmesa, struct gl_texture_object *tex
int firstlevel = t->mt ? t->mt->firstLevel : 0;
GLuint uTexelPitch, row_align;
+ if ( t->bo ) {
+ return GL_TRUE;
+ }
+
firstImage = t->base.Image[0][firstlevel];
if (!t->image_override) {
--
1.6.2.5

View File

@ -1,4 +1,3 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
a5ec51ed9f0a55dc3462d90d52ff899c xdriinfo-1.0.2.tar.bz2
0bbe19a02cacc7c48e5c79bd533b8e29 mesa-20090921.tar.bz2
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
0f4bc80e7c55cff25a44c91c8657fc1a mesa-20091221.tar.bz2