- Fix build on powerpc and amd64.

This commit is contained in:
Adam Jackson 2008-02-21 02:31:49 +00:00
parent 3e8621714a
commit 831986639f
2 changed files with 13 additions and 4 deletions

View File

@ -1,6 +1,15 @@
diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
--- mesa-20080218/configure.ac.jx 2008-02-18 12:01:51.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-20 20:54:55.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-20 21:30:47.000000000 -0500
@@ -475,7 +475,7 @@ if test "$mesa_driver" = dri; then
fi
case "$host_cpu" in
- x86_64)
+ x86_64*)
# ffb, gamma, and sis are missing because they have not be
# converted to use the new interface. i810 are missing
# because there is no x86-64 system where they could *ever*
@@ -484,6 +484,7 @@ if test "$mesa_driver" = dri; then
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
savage tdfx unichrome"

View File

@ -195,7 +195,7 @@ make clean
--with-dri-driverdir=%{_libdir}/dri
echo "--- MESA CONFIGURATION ---"
cat configs/default
cat configs/current
echo "--- END MESA CONFIGURATION ---"
make %{?_smp_mflags}
@ -218,7 +218,7 @@ make install DESTDIR=$RPM_BUILD_ROOT DRI_DIRS=
%if %{with_dri}
install -d $RPM_BUILD_ROOT%{_libdir}/dri
for f in i810 i915 i965 mach64 mga r128 r200 r300 radeon savage sis tdfx unichrome; do
so=lib/${f}_dri.so
so=%{_lib}/${f}_dri.so
test -e $so && echo $so
done | xargs install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri >& /dev/null || :
%endif
@ -399,7 +399,7 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Feb 20 2008 Adam Jackson <ajax@redhat.com> 7.1-0.16
- Fix build on powerpc.
- Fix build on powerpc and amd64.
* Mon Feb 18 2008 Adam Jackson <ajax@redhat.com> 7.1-0.15
- Today's git snapshot, additional headers for DRI2 love.