Update to 21.0.0-rc3
This commit is contained in:
parent
e4ffbf1534
commit
81d729955c
@ -1,33 +0,0 @@
|
|||||||
From b905acfbdcd63067b017494ea6fb405753de9a23 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dave Airlie <airlied@redhat.com>
|
|
||||||
Date: Fri, 15 Jan 2021 09:19:03 +1000
|
|
||||||
Subject: [PATCH] device-select-layer: update for vulkan 1.2
|
|
||||||
|
|
||||||
The vulkan loader doesn't load layers for apps that require a newer
|
|
||||||
version of vulkan, so this layer didn't get loaded for vulkan 1.2 apps.
|
|
||||||
|
|
||||||
I would like to just stick 1.09 in there but it might be worth
|
|
||||||
validating it works at new version of vulkan I suppose and the major
|
|
||||||
doesn't revise that often
|
|
||||||
|
|
||||||
Fixes: 9bc5b2d169d3 ("vulkan: add initial device selection layer. (v6)")
|
|
||||||
---
|
|
||||||
src/vulkan/device-select-layer/VkLayer_MESA_device_select.json | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/vulkan/device-select-layer/VkLayer_MESA_device_select.json b/src/vulkan/device-select-layer/VkLayer_MESA_device_select.json
|
|
||||||
index 1d5fffd0135..361ae9fe74e 100644
|
|
||||||
--- a/src/vulkan/device-select-layer/VkLayer_MESA_device_select.json
|
|
||||||
+++ b/src/vulkan/device-select-layer/VkLayer_MESA_device_select.json
|
|
||||||
@@ -4,7 +4,7 @@
|
|
||||||
"name": "VK_LAYER_MESA_device_select",
|
|
||||||
"type": "GLOBAL",
|
|
||||||
"library_path": "libVkLayer_MESA_device_select.so",
|
|
||||||
- "api_version": "1.1.73",
|
|
||||||
+ "api_version": "1.2.73",
|
|
||||||
"implementation_version": "1",
|
|
||||||
"description": "Linux device selection layer",
|
|
||||||
"functions": {
|
|
||||||
--
|
|
||||||
2.26.2
|
|
||||||
|
|
@ -1,86 +0,0 @@
|
|||||||
From 3306a3395b36d3ebddaa0ed28c58ca1272196695 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Dave Airlie <airlied@gmail.com>
|
|
||||||
Date: Fri, 15 Jan 2021 09:57:52 +1000
|
|
||||||
Subject: [PATCH] lavapipe: fix missing piece of
|
|
||||||
VK_KHR_get_physical_device_properties2
|
|
||||||
|
|
||||||
I missed two parts of the APIs for this, so add them, should fix
|
|
||||||
crashes in gstreamer vulkan when it tries to load lvp.
|
|
||||||
|
|
||||||
Cc: "20.3" <mesa-stable@lists.freedesktop.org>
|
|
||||||
---
|
|
||||||
src/gallium/frontends/lavapipe/lvp_device.c | 43 +++++++++++++++++----
|
|
||||||
1 file changed, 35 insertions(+), 8 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/gallium/frontends/lavapipe/lvp_device.c b/src/gallium/frontends/lavapipe/lvp_device.c
|
|
||||||
index 0eaf278679c..3d05e424278 100644
|
|
||||||
--- a/src/gallium/frontends/lavapipe/lvp_device.c
|
|
||||||
+++ b/src/gallium/frontends/lavapipe/lvp_device.c
|
|
||||||
@@ -631,6 +631,19 @@ void lvp_GetPhysicalDeviceProperties2(
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+static void lvp_get_physical_device_queue_family_properties(
|
|
||||||
+ VkQueueFamilyProperties* pQueueFamilyProperties)
|
|
||||||
+{
|
|
||||||
+ *pQueueFamilyProperties = (VkQueueFamilyProperties) {
|
|
||||||
+ .queueFlags = VK_QUEUE_GRAPHICS_BIT |
|
|
||||||
+ VK_QUEUE_COMPUTE_BIT |
|
|
||||||
+ VK_QUEUE_TRANSFER_BIT,
|
|
||||||
+ .queueCount = 1,
|
|
||||||
+ .timestampValidBits = 64,
|
|
||||||
+ .minImageTransferGranularity = (VkExtent3D) { 1, 1, 1 },
|
|
||||||
+ };
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
void lvp_GetPhysicalDeviceQueueFamilyProperties(
|
|
||||||
VkPhysicalDevice physicalDevice,
|
|
||||||
uint32_t* pCount,
|
|
||||||
@@ -642,15 +655,21 @@ void lvp_GetPhysicalDeviceQueueFamilyProperties(
|
|
||||||
}
|
|
||||||
|
|
||||||
assert(*pCount >= 1);
|
|
||||||
+ lvp_get_physical_device_queue_family_properties(pQueueFamilyProperties);
|
|
||||||
+}
|
|
||||||
|
|
||||||
- *pQueueFamilyProperties = (VkQueueFamilyProperties) {
|
|
||||||
- .queueFlags = VK_QUEUE_GRAPHICS_BIT |
|
|
||||||
- VK_QUEUE_COMPUTE_BIT |
|
|
||||||
- VK_QUEUE_TRANSFER_BIT,
|
|
||||||
- .queueCount = 1,
|
|
||||||
- .timestampValidBits = 64,
|
|
||||||
- .minImageTransferGranularity = (VkExtent3D) { 1, 1, 1 },
|
|
||||||
- };
|
|
||||||
+void lvp_GetPhysicalDeviceQueueFamilyProperties2(
|
|
||||||
+ VkPhysicalDevice physicalDevice,
|
|
||||||
+ uint32_t* pCount,
|
|
||||||
+ VkQueueFamilyProperties2 *pQueueFamilyProperties)
|
|
||||||
+{
|
|
||||||
+ if (pQueueFamilyProperties == NULL) {
|
|
||||||
+ *pCount = 1;
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ assert(*pCount >= 1);
|
|
||||||
+ lvp_get_physical_device_queue_family_properties(&pQueueFamilyProperties->queueFamilyProperties);
|
|
||||||
}
|
|
||||||
|
|
||||||
void lvp_GetPhysicalDeviceMemoryProperties(
|
|
||||||
@@ -673,6 +692,14 @@ void lvp_GetPhysicalDeviceMemoryProperties(
|
|
||||||
};
|
|
||||||
}
|
|
||||||
|
|
||||||
+void lvp_GetPhysicalDeviceMemoryProperties2(
|
|
||||||
+ VkPhysicalDevice physicalDevice,
|
|
||||||
+ VkPhysicalDeviceMemoryProperties2 *pMemoryProperties)
|
|
||||||
+{
|
|
||||||
+ lvp_GetPhysicalDeviceMemoryProperties(physicalDevice,
|
|
||||||
+ &pMemoryProperties->memoryProperties);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
PFN_vkVoidFunction lvp_GetInstanceProcAddr(
|
|
||||||
VkInstance _instance,
|
|
||||||
const char* pName)
|
|
||||||
--
|
|
||||||
2.29.2
|
|
||||||
|
|
20
mesa.spec
20
mesa.spec
@ -35,10 +35,6 @@
|
|||||||
%global with_radeonsi 1
|
%global with_radeonsi 1
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%ifnarch %{x86}
|
|
||||||
%global with_asm 1
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%ifarch %{valgrind_arches}
|
%ifarch %{valgrind_arches}
|
||||||
%bcond_without valgrind
|
%bcond_without valgrind
|
||||||
%else
|
%else
|
||||||
@ -52,9 +48,9 @@
|
|||||||
|
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
%global ver 20.3.3
|
%global ver 21.0.0-rc3
|
||||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
|
||||||
@ -64,11 +60,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
|||||||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||||
|
|
||||||
# fix device selection layer
|
|
||||||
Patch0: 0001-device-select-layer-update-for-vulkan-1.2.patch
|
|
||||||
# fix lvp extension missing
|
|
||||||
Patch1: 0001-lavapipe-fix-missing-piece-of-VK_KHR_get_physical_de.patch
|
|
||||||
|
|
||||||
# fix qemu/egl issue
|
# fix qemu/egl issue
|
||||||
Patch2: fix-egl.patch
|
Patch2: fix-egl.patch
|
||||||
|
|
||||||
@ -333,7 +324,7 @@ cp %{SOURCE1} docs/
|
|||||||
-Dplatforms=x11,wayland \
|
-Dplatforms=x11,wayland \
|
||||||
-Ddri3=enabled \
|
-Ddri3=enabled \
|
||||||
-Ddri-drivers=%{?dri_drivers} \
|
-Ddri-drivers=%{?dri_drivers} \
|
||||||
-Dosmesa=gallium \
|
-Dosmesa=true \
|
||||||
%if 0%{?with_hardware}
|
%if 0%{?with_hardware}
|
||||||
-Dgallium-drivers=swrast,virgl,r300,nouveau%{?with_iris:,iris}%{?with_vmware:,svga}%{?with_radeonsi:,radeonsi,r600}%{?with_freedreno:,freedreno}%{?with_etnaviv:,etnaviv}%{?with_tegra:,tegra}%{?with_vc4:,vc4}%{?with_v3d:,v3d}%{?with_kmsro:,kmsro}%{?with_lima:,lima}%{?with_panfrost:,panfrost}%{?with_vulkan_hw:,zink} \
|
-Dgallium-drivers=swrast,virgl,r300,nouveau%{?with_iris:,iris}%{?with_vmware:,svga}%{?with_radeonsi:,radeonsi,r600}%{?with_freedreno:,freedreno}%{?with_etnaviv:,etnaviv}%{?with_tegra:,tegra}%{?with_vc4:,vc4}%{?with_v3d:,v3d}%{?with_kmsro:,kmsro}%{?with_lima:,lima}%{?with_panfrost:,panfrost}%{?with_vulkan_hw:,zink} \
|
||||||
%else
|
%else
|
||||||
@ -356,7 +347,7 @@ cp %{SOURCE1} docs/
|
|||||||
-Dglx=dri \
|
-Dglx=dri \
|
||||||
-Degl=enabled \
|
-Degl=enabled \
|
||||||
-Dglvnd=true \
|
-Dglvnd=true \
|
||||||
-Dasm=%{?with_asm:true}%{!?with_asm:false} \
|
-Dmicrosoft-clc=disabled \
|
||||||
-Dllvm=enabled \
|
-Dllvm=enabled \
|
||||||
-Dshared-llvm=enabled \
|
-Dshared-llvm=enabled \
|
||||||
-Dvalgrind=%{?with_valgrind:enabled}%{!?with_valgrind:disabled} \
|
-Dvalgrind=%{?with_valgrind:enabled}%{!?with_valgrind:disabled} \
|
||||||
@ -605,6 +596,9 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jan 29 2021 Pete Walter <pwalter@fedoraproject.org> - 21.0.0~rc3-1
|
||||||
|
- Update to 21.0.0-rc3
|
||||||
|
|
||||||
* Fri Jan 29 2021 Dave Airlie <airlied@redhat.com> - 20.3.3-7
|
* Fri Jan 29 2021 Dave Airlie <airlied@redhat.com> - 20.3.3-7
|
||||||
- Backport upstream fix for EGL issues with qemu
|
- Backport upstream fix for EGL issues with qemu
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mesa-20.3.3.tar.xz) = 77735462f4ccbe865d0cf7e9db47c42f8bc2600b9a030dca11066d29e43f73c18ca0422e6356129fc14ac1b1018ed752ae4ee45bd31ae706fea58f573a14d346
|
SHA512 (mesa-21.0.0-rc3.tar.xz) = b51495e8ef3a4a2f1b98ad3c4f5037c21b4b7df375138bcc02b24cb4b7ffd7b807d76ac0853d0ecc81c09ceca2a97e5c402352700f297ed7f4369f98d03a0810
|
||||||
|
Loading…
Reference in New Issue
Block a user