Enable experimental SWR rasterizer
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
This commit is contained in:
parent
5492fe6e75
commit
7777524ef9
6428
0001-Initial-public-Mesa-SWR.patch
Normal file
6428
0001-Initial-public-Mesa-SWR.patch
Normal file
File diff suppressed because it is too large
Load Diff
46197
0002-swr-484541-Initial-public-SWR.patch
Normal file
46197
0002-swr-484541-Initial-public-SWR.patch
Normal file
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,42 @@
|
||||
From fe9e5f557953d3c4b9c3cac6be0ff29d97c3f2c7 Mon Sep 17 00:00:00 2001
|
||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
Date: Thu, 22 Oct 2015 17:08:04 +0200
|
||||
Subject: [PATCH 3/3] gallium/swr: add flags parameter to
|
||||
pipe_screen::context_create
|
||||
|
||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
||||
---
|
||||
src/gallium/drivers/swr/swr_context.cpp | 3 ++-
|
||||
src/gallium/drivers/swr/swr_context.h | 2 +-
|
||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/drivers/swr/swr_context.cpp b/src/gallium/drivers/swr/swr_context.cpp
|
||||
index 6269cd0..2dd3443 100644
|
||||
--- a/src/gallium/drivers/swr/swr_context.cpp
|
||||
+++ b/src/gallium/drivers/swr/swr_context.cpp
|
||||
@@ -336,7 +336,8 @@ swr_render_condition(struct pipe_context *pipe,
|
||||
|
||||
|
||||
struct pipe_context *
|
||||
-swr_create_context(struct pipe_screen *screen, void *priv)
|
||||
+swr_create_context(struct pipe_screen *screen, void *priv,
|
||||
+ unsigned flags)
|
||||
{
|
||||
struct swr_context *ctx = CALLOC_STRUCT(swr_context);
|
||||
ctx->blendJIT =
|
||||
diff --git a/src/gallium/drivers/swr/swr_context.h b/src/gallium/drivers/swr/swr_context.h
|
||||
index 9d93a6d..5271eac 100644
|
||||
--- a/src/gallium/drivers/swr/swr_context.h
|
||||
+++ b/src/gallium/drivers/swr/swr_context.h
|
||||
@@ -160,7 +160,7 @@ swr_context(struct pipe_context *pipe)
|
||||
return (struct swr_context *)pipe;
|
||||
}
|
||||
|
||||
-struct pipe_context *swr_create_context(struct pipe_screen *, void *priv);
|
||||
+struct pipe_context *swr_create_context(struct pipe_screen *, void *priv, unsigned flags);
|
||||
|
||||
void swr_state_init(struct pipe_context *pipe);
|
||||
|
||||
--
|
||||
2.6.2
|
||||
|
17
mesa.spec
17
mesa.spec
@ -17,6 +17,7 @@
|
||||
%define min_wayland_version 1.0
|
||||
%if 0%{?with_llvm}
|
||||
%define with_radeonsi 1
|
||||
%define with_swr 1
|
||||
%endif
|
||||
|
||||
%ifarch s390 s390x ppc
|
||||
@ -55,7 +56,7 @@
|
||||
Summary: Mesa graphics libraries
|
||||
Name: mesa
|
||||
Version: 11.1.0
|
||||
Release: 0.devel.8.%{git}%{?dist}
|
||||
Release: 0.devel.9.%{git}%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Libraries
|
||||
URL: http://www.mesa3d.org
|
||||
@ -74,6 +75,10 @@ Patch15: mesa-9.2-hardware-float.patch
|
||||
Patch20: mesa-10.2-evergreen-big-endian.patch
|
||||
Patch30: mesa-10.3-bigendian-assert.patch
|
||||
|
||||
Patch101: 0001-Initial-public-Mesa-SWR.patch
|
||||
Patch102: 0002-swr-484541-Initial-public-SWR.patch
|
||||
Patch103: 0003-gallium-swr-add-flags-parameter-to-pipe_screen-conte.patch
|
||||
|
||||
# To have sha info in glxinfo
|
||||
BuildRequires: git-core
|
||||
|
||||
@ -348,6 +353,10 @@ grep -q ^/ src/gallium/auxiliary/vl/vl_decoder.c && exit 1
|
||||
%patch20 -p1 -b .egbe
|
||||
%patch30 -p1 -b .beassert
|
||||
|
||||
%patch101 -p1
|
||||
%patch102 -p1
|
||||
%patch103 -p1
|
||||
|
||||
%if 0%{with_private_llvm}
|
||||
sed -i 's/llvm-config/mesa-private-llvm-config-%{__isa_bits}/g' configure.ac
|
||||
sed -i 's/`$LLVM_CONFIG --version`/&-mesa/' configure.ac
|
||||
@ -395,7 +404,8 @@ export CXXFLAGS="$RPM_OPT_FLAGS %{?with_opencl:-frtti -fexceptions} %{!?with_ope
|
||||
%if %{with_hardware}
|
||||
%{?with_xa:--enable-xa} \
|
||||
%{?with_nine:--enable-nine} \
|
||||
--with-gallium-drivers=%{?with_vmware:svga,}%{?with_radeonsi:radeonsi,}%{?with_llvm:swrast,r600,}%{?with_freedreno:freedreno,}%{?with_vc4:vc4,}%{?with_ilo:ilo,}r300,nouveau \
|
||||
--with-gallium-drivers=%{?with_vmware:svga,}%{?with_radeonsi:radeonsi,}%{?with_llvm:swrast,r600,}%{?with_freedreno:freedreno,}%{?with_vc4:vc4,}%{?with_ilo:ilo,}%{?with_swr:swr,}r300,nouveau \
|
||||
%{?with_swr:--enable-swr-native} \
|
||||
%else
|
||||
--with-gallium-drivers=%{?with_llvm:swrast} \
|
||||
%endif
|
||||
@ -675,6 +685,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Oct 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 11.1.0-0.devel.9.4a168ad
|
||||
- Enable experimental SWR rasterizer
|
||||
|
||||
* Wed Oct 14 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 11.1.0-0.devel.8.4a168ad
|
||||
- 4a168ad
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user