Update to mesa 21.1.3 to fix wl_drm
Resolves: rhbz#1970253
This commit is contained in:
parent
5e5fe8f135
commit
76a2897ad3
@ -1,72 +0,0 @@
|
||||
From 70259f75a5546d331b0d687227341f653a4bf544 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Thu, 25 Mar 2021 08:34:28 +1000
|
||||
Subject: [PATCH] drisw: move zink down the list below the sw drivers.
|
||||
|
||||
We don't ever want drisw path picking zink as the driver,
|
||||
we can revisit this when the penny wrapper work gets further
|
||||
along.
|
||||
|
||||
This selection causes systems with nvidia/intel dual-gpus
|
||||
to try and pick the intel gpu for rendering in the nvidia
|
||||
context if there is no nvidia GL driver or accel doesn't work.
|
||||
|
||||
This is a partial revert of the original commit.
|
||||
|
||||
Fixes: 4a3b42a717ce ("drisw: Prefer hardware-layered sw-winsys drivers over pure sw")
|
||||
---
|
||||
src/gallium/auxiliary/target-helpers/inline_sw_helper.h | 6 +++---
|
||||
src/gallium/auxiliary/target-helpers/sw_helper.h | 6 +++---
|
||||
2 files changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/auxiliary/target-helpers/inline_sw_helper.h b/src/gallium/auxiliary/target-helpers/inline_sw_helper.h
|
||||
index c494840c44e..76eda8467b8 100644
|
||||
--- a/src/gallium/auxiliary/target-helpers/inline_sw_helper.h
|
||||
+++ b/src/gallium/auxiliary/target-helpers/inline_sw_helper.h
|
||||
@@ -81,9 +81,6 @@ sw_screen_create(struct sw_winsys *winsys)
|
||||
UNUSED bool only_sw = env_var_as_boolean("LIBGL_ALWAYS_SOFTWARE", false);
|
||||
const char *drivers[] = {
|
||||
debug_get_option("GALLIUM_DRIVER", ""),
|
||||
-#if defined(GALLIUM_ZINK)
|
||||
- only_sw ? "" : "zink",
|
||||
-#endif
|
||||
#if defined(GALLIUM_D3D12)
|
||||
only_sw ? "" : "d3d12",
|
||||
#endif
|
||||
@@ -95,6 +92,9 @@ sw_screen_create(struct sw_winsys *winsys)
|
||||
#endif
|
||||
#if defined(GALLIUM_SWR)
|
||||
"swr",
|
||||
+#endif
|
||||
+#if defined(GALLIUM_ZINK)
|
||||
+ only_sw ? "" : "zink",
|
||||
#endif
|
||||
};
|
||||
|
||||
diff --git a/src/gallium/auxiliary/target-helpers/sw_helper.h b/src/gallium/auxiliary/target-helpers/sw_helper.h
|
||||
index d9469d9f5e3..88a5086d261 100644
|
||||
--- a/src/gallium/auxiliary/target-helpers/sw_helper.h
|
||||
+++ b/src/gallium/auxiliary/target-helpers/sw_helper.h
|
||||
@@ -86,9 +86,6 @@ sw_screen_create(struct sw_winsys *winsys)
|
||||
UNUSED bool only_sw = env_var_as_boolean("LIBGL_ALWAYS_SOFTWARE", false);
|
||||
const char *drivers[] = {
|
||||
debug_get_option("GALLIUM_DRIVER", ""),
|
||||
-#if defined(GALLIUM_ZINK)
|
||||
- only_sw ? "" : "zink",
|
||||
-#endif
|
||||
#if defined(GALLIUM_D3D12)
|
||||
only_sw ? "" : "d3d12",
|
||||
#endif
|
||||
@@ -100,6 +97,9 @@ sw_screen_create(struct sw_winsys *winsys)
|
||||
#endif
|
||||
#if defined(GALLIUM_SWR)
|
||||
"swr",
|
||||
+#endif
|
||||
+#if defined(GALLIUM_ZINK)
|
||||
+ only_sw ? "" : "zink",
|
||||
#endif
|
||||
};
|
||||
|
||||
--
|
||||
2.29.2
|
||||
|
@ -1,118 +0,0 @@
|
||||
From d1eab2b1eb1dec10197db7d25e27d97f6ca1a2ea Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Wed, 24 Feb 2021 12:44:41 +0100
|
||||
Subject: [PATCH] clover: Fix build with llvm-12.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Fix build error after LLVM commit c495dfe0268b ("[clang][cli] NFC:
|
||||
Decrease the scope of ParseLangArgs parameters").
|
||||
|
||||
../src/gallium/frontends/clover/llvm/invocation.cpp: In function ‘std::unique_ptr<clang::CompilerInstance> {anonymous}::create_compiler_instance(const clover::device&, const string&, const std::vector<std::__cxx11::basic_string<char> >&, std::string&)’:
|
||||
../src/gallium/frontends/clover/llvm/invocation.cpp:252:55: error: cannot convert ‘clang::PreprocessorOptions’ to ‘std::vector<std::__cxx11::basic_string<char> >&’
|
||||
252 | c->getPreprocessorOpts(),
|
||||
| ~~~~~~~~~~~~~~~~~~~~~~^~
|
||||
| |
|
||||
| clang::PreprocessorOptions
|
||||
|
||||
Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/4114
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Francisco Jerez <currojerez@riseup.net>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/8543>
|
||||
---
|
||||
src/gallium/frontends/clover/llvm/compat.hpp | 22 +++++++++++++++----
|
||||
.../frontends/clover/llvm/invocation.cpp | 5 ++---
|
||||
2 files changed, 20 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/gallium/frontends/clover/llvm/compat.hpp b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
index 78eb8c982a8..d537819f292 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
@@ -38,14 +38,14 @@
|
||||
|
||||
#include <llvm/Config/llvm-config.h>
|
||||
|
||||
+#include <llvm/ADT/Triple.h>
|
||||
+#include <llvm/Analysis/TargetLibraryInfo.h>
|
||||
+#include <llvm/IR/LegacyPassManager.h>
|
||||
#include <llvm/IR/LLVMContext.h>
|
||||
#include <llvm/Linker/Linker.h>
|
||||
+#include <llvm/Target/TargetMachine.h>
|
||||
#include <llvm/Transforms/IPO.h>
|
||||
#include <llvm/Transforms/Utils/Cloning.h>
|
||||
-#include <llvm/Target/TargetMachine.h>
|
||||
-
|
||||
-#include <llvm/IR/LegacyPassManager.h>
|
||||
-#include <llvm/Analysis/TargetLibraryInfo.h>
|
||||
|
||||
#include <clang/Basic/TargetInfo.h>
|
||||
#include <clang/Frontend/CompilerInstance.h>
|
||||
@@ -88,6 +88,20 @@ namespace clover {
|
||||
cinv, copts.data(), copts.data() + copts.size(), diag);
|
||||
#endif
|
||||
}
|
||||
+
|
||||
+ static inline void
|
||||
+ compiler_set_lang_defaults(std::unique_ptr<clang::CompilerInstance> &c,
|
||||
+ clang::InputKind ik, const ::llvm::Triple& triple,
|
||||
+ clang::LangStandard::Kind d)
|
||||
+ {
|
||||
+ c->getInvocation().setLangDefaults(c->getLangOpts(), ik, triple,
|
||||
+#if LLVM_VERSION_MAJOR >= 12
|
||||
+ c->getPreprocessorOpts().Includes,
|
||||
+#else
|
||||
+ c->getPreprocessorOpts(),
|
||||
+#endif
|
||||
+ d);
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
||||
diff --git a/src/gallium/frontends/clover/llvm/invocation.cpp b/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
index 536e952b100..30592e4343b 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/invocation.cpp
|
||||
@@ -247,9 +247,8 @@ namespace {
|
||||
// http://www.llvm.org/bugs/show_bug.cgi?id=19735
|
||||
c->getDiagnosticOpts().ShowCarets = false;
|
||||
|
||||
- c->getInvocation().setLangDefaults(c->getLangOpts(),
|
||||
- compat::ik_opencl, ::llvm::Triple(target.triple),
|
||||
- c->getPreprocessorOpts(),
|
||||
+ compat::compiler_set_lang_defaults(c, compat::ik_opencl,
|
||||
+ ::llvm::Triple(target.triple),
|
||||
get_language_version(opts, device_clc_version));
|
||||
|
||||
c->createDiagnostics(new clang::TextDiagnosticPrinter(
|
||||
--
|
||||
GitLab
|
||||
|
||||
From f0dccd957879ff642cfd921dda6e8b04dd35fec4 Mon Sep 17 00:00:00 2001
|
||||
From: Karol Herbst <kherbst@redhat.com>
|
||||
Date: Tue, 2 Mar 2021 20:09:39 +0100
|
||||
Subject: [PATCH] clover: Add missing include for llvm-12 build fix
|
||||
|
||||
Fixes: d1eab2b1eb1 ("clover: Fix build with llvm-12.")
|
||||
Signed-off-by: Karol Herbst <kherbst@redhat.com>
|
||||
Reviewed-by: Francisco Jerez <currojerez@riseup.net>
|
||||
Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/9372>
|
||||
---
|
||||
src/gallium/frontends/clover/llvm/compat.hpp | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/gallium/frontends/clover/llvm/compat.hpp b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
index d537819f292..380d16a8346 100644
|
||||
--- a/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
+++ b/src/gallium/frontends/clover/llvm/compat.hpp
|
||||
@@ -49,6 +49,7 @@
|
||||
|
||||
#include <clang/Basic/TargetInfo.h>
|
||||
#include <clang/Frontend/CompilerInstance.h>
|
||||
+#include <clang/Lex/PreprocessorOptions.h>
|
||||
|
||||
#if LLVM_VERSION_MAJOR >= 10
|
||||
#include <llvm/Support/CodeGen.h>
|
||||
--
|
||||
GitLab
|
||||
|
17
mesa.spec
17
mesa.spec
@ -56,9 +56,9 @@
|
||||
|
||||
Name: mesa
|
||||
Summary: Mesa graphics libraries
|
||||
%global ver 21.0.1
|
||||
%global ver 21.1.3
|
||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||
Release: 5%{?dist}
|
||||
Release: 1%{?dist}
|
||||
License: MIT
|
||||
URL: http://www.mesa3d.org
|
||||
|
||||
@ -68,11 +68,6 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
||||
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
|
||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||
|
||||
# https://gitlab.freedesktop.org/mesa/mesa/-/issues/4442
|
||||
Patch0: mesa-llvm12.patch
|
||||
|
||||
Patch1: 0001-drisw-move-zink-down-the-list-below-the-sw-drivers.patch
|
||||
|
||||
BuildRequires: meson >= 0.45
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
@ -348,7 +343,7 @@ cp %{SOURCE1} docs/
|
||||
-Dgallium-nine=%{?with_nine:true}%{!?with_nine:false} \
|
||||
-Dgallium-opencl=%{?with_opencl:icd}%{!?with_opencl:disabled} \
|
||||
-Dvulkan-drivers=%{?vulkan_drivers} \
|
||||
-Dvulkan-device-select-layer=true \
|
||||
-Dvulkan-layers=device-select \
|
||||
-Dshared-glapi=enabled \
|
||||
-Dgles1=disabled \
|
||||
-Dgles2=enabled \
|
||||
@ -608,12 +603,14 @@ popd
|
||||
%endif
|
||||
%endif
|
||||
|
||||
%files vulkan-devel
|
||||
%ifarch %{ix86} x86_64
|
||||
%{_includedir}/vulkan/vulkan_intel.h
|
||||
%files vulkan-devel
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Jul 09 2021 Dave Airlie <airlied@redhat.com> - 21.1.3-1
|
||||
- Update to mesa 21.1.3 to fix wl_drm
|
||||
|
||||
* Tue Apr 20 2021 Dave Airlie <airlied@redhat.com> - 21.0.1-5
|
||||
- Fix FTBFS (#1951279)
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (mesa-21.0.1.tar.xz) = b31b78778b6092dfaf0712f90de3074217574389c4236f8379c127739874f6bd1b47883140a26445d25e58df87e6207278efd048453096ee710d334b1dcfe419
|
||||
SHA512 (mesa-21.1.3.tar.xz) = 8ca6d5516035484ea2a63bc6338794003ef167239ab0c220f8d3693f97f9725b46fc9d9a704c4ba11b83197d4b8e5f658d65ef0cce1e0957f5e58bd13726b9e0
|
||||
|
Loading…
Reference in New Issue
Block a user