Update to 18.3.0 RC2
Re-enable 10bpc fbconfigs, clutter apps seem to work now Drop now-unnecessary big-endian compilation fix
This commit is contained in:
parent
dd7e950818
commit
652f89b81e
@ -1,27 +0,0 @@
|
|||||||
From 6ccae713acc457d7df6ab15e124a7d77c5093213 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
Date: Sun, 20 Mar 2016 13:28:07 +0100
|
|
||||||
Subject: [PATCH 4/4] bigendian assert
|
|
||||||
|
|
||||||
Signed-off-by: Igor Gnatenko <i.gnatenko.brain@gmail.com>
|
|
||||||
---
|
|
||||||
src/gallium/auxiliary/util/u_math.h | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/src/gallium/auxiliary/util/u_math.h b/src/gallium/auxiliary/util/u_math.h
|
|
||||||
index ecb1d63..90ada14 100644
|
|
||||||
--- a/src/gallium/auxiliary/util/u_math.h
|
|
||||||
+++ b/src/gallium/auxiliary/util/u_math.h
|
|
||||||
@@ -59,6 +59,9 @@
|
|
||||||
extern "C" {
|
|
||||||
#endif
|
|
||||||
|
|
||||||
+#ifdef PIPE_ARCH_BIG_ENDIAN
|
|
||||||
+#include <assert.h>
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
#ifndef M_SQRT2
|
|
||||||
#define M_SQRT2 1.41421356237309504880
|
|
||||||
--
|
|
||||||
2.7.4
|
|
||||||
|
|
19
mesa.spec
19
mesa.spec
@ -41,9 +41,9 @@
|
|||||||
|
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
%global ver 18.2.4
|
%global ver 18.3.0-rc2
|
||||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
|
||||||
@ -59,11 +59,10 @@ Source4: Mesa-MLAA-License-Clarification-Email.txt
|
|||||||
|
|
||||||
Patch1: 0001-llvm-SONAME-without-version.patch
|
Patch1: 0001-llvm-SONAME-without-version.patch
|
||||||
Patch3: 0003-evergreen-big-endian.patch
|
Patch3: 0003-evergreen-big-endian.patch
|
||||||
Patch4: 0004-bigendian-assert.patch
|
|
||||||
|
|
||||||
# Disable rgb10 configs by default:
|
# Disable rgb10 configs by default:
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1560481
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1560481
|
||||||
Patch7: 0001-gallium-Disable-rgb10-configs-by-default.patch
|
#Patch7: 0001-gallium-Disable-rgb10-configs-by-default.patch
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -388,10 +387,6 @@ autoreconf -vfi
|
|||||||
%install
|
%install
|
||||||
%make_install
|
%make_install
|
||||||
|
|
||||||
%if !%{with_hardware}
|
|
||||||
rm -f %{buildroot}%{_sysconfdir}/drirc
|
|
||||||
%endif
|
|
||||||
|
|
||||||
# libvdpau opens the versioned name, don't bother including the unversioned
|
# libvdpau opens the versioned name, don't bother including the unversioned
|
||||||
rm -f %{buildroot}%{_libdir}/vdpau/*.so
|
rm -f %{buildroot}%{_libdir}/vdpau/*.so
|
||||||
# likewise glvnd
|
# likewise glvnd
|
||||||
@ -539,8 +534,9 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%files dri-drivers
|
%files dri-drivers
|
||||||
|
%dir %{_datadir}/drirc.d
|
||||||
|
%{_datadir}/drirc.d/00-mesa-defaults.conf
|
||||||
%if %{with_hardware}
|
%if %{with_hardware}
|
||||||
%config(noreplace) %{_sysconfdir}/drirc
|
|
||||||
%{_libdir}/dri/radeon_dri.so
|
%{_libdir}/dri/radeon_dri.so
|
||||||
%{_libdir}/dri/r200_dri.so
|
%{_libdir}/dri/r200_dri.so
|
||||||
%{_libdir}/dri/nouveau_vieux_dri.so
|
%{_libdir}/dri/nouveau_vieux_dri.so
|
||||||
@ -618,6 +614,11 @@ popd
|
|||||||
%{_includedir}/vulkan/
|
%{_includedir}/vulkan/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 14 2018 Adam Jackson <ajax@redhat.com> 18.3.0~rc2.1
|
||||||
|
- Update to 18.3.0 RC2
|
||||||
|
- Re-enable 10bpc fbconfigs, clutter apps seem to work now
|
||||||
|
- Drop now-unnecessary big-endian compilation fix
|
||||||
|
|
||||||
* Tue Nov 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 18.2.4-3
|
* Tue Nov 06 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 18.2.4-3
|
||||||
- Remove workaround
|
- Remove workaround
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (mesa-18.2.4.tar.xz) = 287950e9e1265c53d50f50b84de38cbea2ad1a027604fc7c4b6896481e9ad265ed8bd68c5bb1030dcf36a03d064ac41561064787f251521c63caa46c9e4d2273
|
SHA512 (mesa-18.3.0-rc2.tar.xz) = 57970fcfc9a99c826283759acb681c7db7287704e874d5e4c0b38172acf92165068360030f435aa01df3a74f73f1e3a9f72d26fbe91101bbb1a9a2b0cafa8b11
|
||||||
|
Loading…
Reference in New Issue
Block a user