import UBI mesa-23.1.4-1.el8

This commit is contained in:
eabdullin 2023-11-15 03:40:14 +00:00
parent f9b2a21c37
commit 5ab9b5bf34
6 changed files with 60 additions and 36 deletions

4
.gitignore vendored
View File

@ -1 +1,3 @@
SOURCES/mesa-22.3.0.tar.xz
SOURCES/dataclasses-0.8.tar.gz
SOURCES/mesa-23.1.4.tar.xz
SOURCES/meson-0.61.4.tar.gz

View File

@ -1 +1,3 @@
331db7d4590f10c99b79e801bb40fa6de491d572 SOURCES/mesa-22.3.0.tar.xz
ef25d3e9e2523805baa314a4adcb915ae901740e SOURCES/dataclasses-0.8.tar.gz
8a48c0e1fbda2c9563ddcf95b05012ab00a8a692 SOURCES/mesa-23.1.4.tar.xz
b0ab169abd8ec87ce773a02b2c7d6a8664b8db00 SOURCES/meson-0.61.4.tar.gz

View File

@ -1,27 +0,0 @@
From 808c054a42fd24a1aaefaeb1d95195fea9fb6e84 Mon Sep 17 00:00:00 2001
From: Dave Airlie <airlied@redhat.com>
Date: Wed, 7 Dec 2022 05:11:47 +1000
Subject: [PATCH] glx: fix xshm check to init xshm_opcode.
Found and proposed by Ray Strode (halfline)
Fixes: 68e89401140d ("glx/drisw: use xcb instead of X to query connection")
---
src/glx/drisw_glx.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/glx/drisw_glx.c b/src/glx/drisw_glx.c
index c0d1e85fdc4..d7658eaf7c1 100644
--- a/src/glx/drisw_glx.c
+++ b/src/glx/drisw_glx.c
@@ -874,6 +874,7 @@ check_xshm(Display *dpy)
shm_cookie = xcb_query_extension(c, 7, "MIT-SHM");
shm_reply = xcb_query_extension_reply(c, shm_cookie, NULL);
+ xshm_opcode = shm_reply->major_opcode;
has_mit_shm = shm_reply->present;
free(shm_reply);
--
2.38.1

View File

@ -1,4 +1,4 @@
VERSION ?= 22.3.0
VERSION ?= 23.1.4
SANITIZE ?= 1
DIRNAME = mesa-${VERSION}

12
SOURCES/fix-py-ver.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up mesa-23.1.4/meson.build.dma mesa-23.1.4/meson.build
--- mesa-23.1.4/meson.build.dma 2023-07-28 10:15:41.807945483 +1000
+++ mesa-23.1.4/meson.build 2023-07-28 10:15:46.465030794 +1000
@@ -835,7 +835,7 @@ if get_option('allow-kcmp') \
pre_args += '-DALLOW_KCMP'
endif
-prog_python = import('python').find_installation('python3')
+prog_python = import('python').find_installation('python3.6')
has_mako = run_command(
prog_python, '-c',
'''

View File

@ -37,8 +37,8 @@
Name: mesa
Summary: Mesa graphics libraries
Version: 22.3.0
Release: 2%{?rctag:.%{rctag}}%{?dist}
Version: 23.1.4
Release: 1%{?rctag:.%{rctag}}%{?dist}
License: MIT
URL: http://www.mesa3d.org
@ -52,16 +52,20 @@ Source3: Makefile
# Fedora opts to ignore the optional part of clause 2 and treat that code as 2 clause BSD.
Source4: Mesa-MLAA-License-Clarification-Email.txt
# build our own newer meson
Source5: meson-0.61.4.tar.gz
Source6: dataclasses-0.8.tar.gz
Patch0: lavapipe-disable-env-var.patch
Patch1: fix-py-ver.patch
Patch10: gnome-shell-glthread-disable.patch
Patch11: 0001-glx-fix-xshm-check-to-init-xshm_opcode.patch
Patch12: radeonsi-turn-off-glthread.patch
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: meson >= 0.45
BuildRequires: meson
%if %{with_hardware}
BuildRequires: kernel-headers
%endif
@ -315,15 +319,27 @@ Headers for development with the Vulkan API.
cp %{SOURCE4} docs/
tar -xvf %{SOURCE5}
tar -xvf %{SOURCE6}
pathfix.py -i %{__python3} -pn bin/*.py src/egl/generate/*.py \
src/gallium/tools/trace/*.py \
src/compiler/glsl/tests/*.py \
src/compiler/glsl/glcpp/tests/*.py
%build
cd meson-0.61.4
%py3_build
%py3_install
cd -
cd dataclasses-0.8
%py3_build
%py3_install
cd -
export ASFLAGS="--generate-missing-build-notes=yes"
%meson -Dcpp_std=gnu++14 \
%global __meson %{buildroot}/usr/bin/meson
export PYTHONPATH=/usr/lib/python3.6/site-packages/:%{buildroot}/usr/lib/python3.6/site-packages/
%meson -Dcpp_std=gnu++17 \
-Db_ndebug=true \
-Dplatforms=x11,wayland \
-Ddri3=enabled \
@ -355,12 +371,25 @@ export ASFLAGS="--generate-missing-build-notes=yes"
-Dvalgrind=%{?with_valgrind:true}%{!?with_valgrind:false} \
-Dbuild-tests=false \
-Dselinux=true \
-Dlibunwind=disabled \
-Dlmsensors=disabled \
-Dandroid-libbacktrace=disabled \
%{nil}
%meson_build
%install
cd meson-0.61.4
%py3_install
cd -
export PYTHONPATH=%{buildroot}/usr/lib/python3.6/site-packages/
%meson_install
#nuke the meson install bits
rm -rf %{buildroot}/usr/lib/python3.6/
rm -f %{buildroot}/usr/bin/meson
rm -rf %{buildroot}/usr/share/man/
rm -f %{buildroot}/usr/share/polkit-1/actions/com.mesonbuild.install.policy
# libvdpau opens the versioned name, don't bother including the unversioned
rm -vf %{buildroot}%{_libdir}/vdpau/*.so
# likewise glvnd
@ -554,6 +583,12 @@ done
%endif
%changelog
* Thu Jul 27 2023 Dave Airlie <airlied@redhat.com> - 23.1.4-1
- Update to 23.1.4
* Mon May 22 2023 Dave Airlie <airlied@redhat.com> - 23.1.0-1
- Update to 23.1.0
* Fri Jan 27 2023 Dave Airlie <airlied@redhat.com> - 22.3.0-2
- disable glthread for radeonsi (breaks totem)