Today's git snapshot
enable-xcb mesa-7.1-nukeglthread-debug.patch: Drop
This commit is contained in:
parent
183b339882
commit
4ed76b074d
1
.gitignore
vendored
1
.gitignore
vendored
@ -27,3 +27,4 @@ mesa-20100720.tar.bz2
|
|||||||
/MesaLib-7.11.tar.bz2
|
/MesaLib-7.11.tar.bz2
|
||||||
/mesa-20111103.tar.xz
|
/mesa-20111103.tar.xz
|
||||||
/mesa-20111114.tar.xz
|
/mesa-20111114.tar.xz
|
||||||
|
/mesa-20111129.tar.xz
|
||||||
|
@ -1,15 +0,0 @@
|
|||||||
diff -up mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c
|
|
||||||
--- mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c.da 2011-06-20 13:51:25.000000000 +1000
|
|
||||||
+++ mesa-20110620/src/mesa/drivers/dri/intel/intel_fbo.c 2011-06-20 13:51:32.000000000 +1000
|
|
||||||
@@ -612,11 +612,6 @@ intel_render_texture(struct gl_context *
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
- DBG("Begin render texture tid %lx tex=%u w=%d h=%d refcount=%d\n",
|
|
||||||
- _glthread_GetID(),
|
|
||||||
- att->Texture->Name, image->Width, image->Height,
|
|
||||||
- irb->Base.RefCount);
|
|
||||||
-
|
|
||||||
intel_renderbuffer_set_draw_offset(irb, intel_image, att->Zoffset);
|
|
||||||
intel_image->used_as_render_target = GL_TRUE;
|
|
||||||
|
|
15
mesa.spec
15
mesa.spec
@ -20,13 +20,13 @@
|
|||||||
%define _default_patch_fuzz 2
|
%define _default_patch_fuzz 2
|
||||||
|
|
||||||
%define manpages gl-manpages-1.0.1
|
%define manpages gl-manpages-1.0.1
|
||||||
%define gitdate 20111114
|
%define gitdate 20111129
|
||||||
#% define snapshot
|
#% define snapshot
|
||||||
|
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.12
|
Version: 7.12
|
||||||
Release: 0.3%{?dist}
|
Release: 0.4%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
@ -38,8 +38,6 @@ Source0: %{name}-%{gitdate}.tar.xz
|
|||||||
Source2: %{manpages}.tar.bz2
|
Source2: %{manpages}.tar.bz2
|
||||||
Source3: make-git-snapshot.sh
|
Source3: make-git-snapshot.sh
|
||||||
|
|
||||||
Patch2: mesa-7.1-nukeglthread-debug.patch
|
|
||||||
|
|
||||||
#Patch7: mesa-7.1-link-shared.patch
|
#Patch7: mesa-7.1-link-shared.patch
|
||||||
Patch8: mesa-7.10-llvmcore.patch
|
Patch8: mesa-7.10-llvmcore.patch
|
||||||
|
|
||||||
@ -61,7 +59,7 @@ BuildRequires: libXi-devel
|
|||||||
BuildRequires: libXmu-devel
|
BuildRequires: libXmu-devel
|
||||||
BuildRequires: elfutils
|
BuildRequires: elfutils
|
||||||
BuildRequires: python
|
BuildRequires: python
|
||||||
BuildRequires: llvm-static >= 3.0
|
BuildRequires: llvm-devel >= 3.0
|
||||||
BuildRequires: libxml2-python
|
BuildRequires: libxml2-python
|
||||||
BuildRequires: libudev-devel
|
BuildRequires: libudev-devel
|
||||||
BuildRequires: libtalloc-devel
|
BuildRequires: libtalloc-devel
|
||||||
@ -196,7 +194,6 @@ Mesa offscreen rendering development package
|
|||||||
%prep
|
%prep
|
||||||
#%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
|
#%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
|
||||||
%setup -q -n mesa-%{gitdate} -b2
|
%setup -q -n mesa-%{gitdate} -b2
|
||||||
%patch2 -p1 -b .intel-glthread
|
|
||||||
#patch7 -p1 -b .dricore
|
#patch7 -p1 -b .dricore
|
||||||
%patch8 -p1 -b .llvmcore
|
%patch8 -p1 -b .llvmcore
|
||||||
|
|
||||||
@ -215,6 +212,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS"
|
|||||||
|
|
||||||
%configure %{common_flags} \
|
%configure %{common_flags} \
|
||||||
--enable-osmesa \
|
--enable-osmesa \
|
||||||
|
--enable-xcb \
|
||||||
--with-dri-driverdir=%{_libdir}/dri \
|
--with-dri-driverdir=%{_libdir}/dri \
|
||||||
--enable-egl \
|
--enable-egl \
|
||||||
--enable-gles1 \
|
--enable-gles1 \
|
||||||
@ -415,6 +413,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/pkgconfig/osmesa.pc
|
%{_libdir}/pkgconfig/osmesa.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Nov 29 2011 Adam Jackson <ajax@redhat.com> 7.12-0.4
|
||||||
|
- Today's git snapshot
|
||||||
|
- --enable-xcb
|
||||||
|
- mesa-7.1-nukeglthread-debug.patch: Drop
|
||||||
|
|
||||||
* Thu Nov 17 2011 Adam Jackson <ajax@redhat.com> 7.12-0.3
|
* Thu Nov 17 2011 Adam Jackson <ajax@redhat.com> 7.12-0.3
|
||||||
- mesa-dri-drivers Obsoletes: mesa-dri-drivers-dri1 < 7.12
|
- mesa-dri-drivers Obsoletes: mesa-dri-drivers-dri1 < 7.12
|
||||||
|
|
||||||
|
1
sources
1
sources
@ -1,2 +1,3 @@
|
|||||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||||
fdf17b0823514116454371e4967d62ab mesa-20111114.tar.xz
|
fdf17b0823514116454371e4967d62ab mesa-20111114.tar.xz
|
||||||
|
b57f38f88ba615abf9a2049ce5b20e6e mesa-20111129.tar.xz
|
||||||
|
Loading…
Reference in New Issue
Block a user