rebase to upstream snapshot of 7.12

This commit is contained in:
Dave Airlie 2011-11-14 16:21:07 +00:00
parent be5a5a8430
commit 3c65592ff9
10 changed files with 23 additions and 210 deletions

1
.gitignore vendored
View File

@ -26,3 +26,4 @@ mesa-20100720.tar.bz2
/mesa-20110730.tar.xz
/MesaLib-7.11.tar.bz2
/mesa-20111103.tar.xz
/mesa-20111114.tar.xz

View File

@ -1,18 +0,0 @@
diff -up Mesa-7.11/src/gallium/drivers/nv50/nv50_screen.c.jx Mesa-7.11/src/gallium/drivers/nv50/nv50_screen.c
--- Mesa-7.11/src/gallium/drivers/nv50/nv50_screen.c.jx 2011-07-08 21:37:09.000000000 -0400
+++ Mesa-7.11/src/gallium/drivers/nv50/nv50_screen.c 2011-10-25 13:20:36.605408094 -0400
@@ -76,11 +76,11 @@ nv50_screen_get_param(struct pipe_screen
case PIPE_CAP_MAX_COMBINED_SAMPLERS:
return 64;
case PIPE_CAP_MAX_TEXTURE_2D_LEVELS:
- return 13;
+ return 14;
case PIPE_CAP_MAX_TEXTURE_3D_LEVELS:
- return 10;
+ return 12;
case PIPE_CAP_MAX_TEXTURE_CUBE_LEVELS:
- return 13;
+ return 14;
case PIPE_CAP_ARRAY_TEXTURES: /* shader support missing */
return 0;
case PIPE_CAP_TEXTURE_MIRROR_CLAMP:

View File

@ -1,36 +0,0 @@
diff -up mesa-20110620/configure.ac.classic mesa-20110620/configure.ac
--- mesa-20110620/configure.ac.classic 2011-06-20 13:52:52.000000000 +1000
+++ mesa-20110620/configure.ac 2011-06-20 13:55:09.000000000 +1000
@@ -1023,20 +1023,20 @@ if test "$mesa_driver" = dri -o "$mesa_d
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
- radeon savage tdfx unichrome swrast"
+ radeon savage tdfx unichrome"
fi
;;
powerpc*)
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon tdfx nouveau"
fi
;;
sparc*)
# Build only the drivers for cards that exist on sparc`
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="r128 r200 r300 r600 radeon swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon nouveau"
fi
;;
esac
@@ -1080,7 +1080,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
- savage sis tdfx unichrome swrast"
+ savage sis tdfx unichrome"
fi
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`

View File

@ -1,12 +1,12 @@
diff -up mesa-20110412/configure.ac.jx mesa-20110412/configure.ac
--- mesa-20110412/configure.ac.jx 2011-05-09 15:04:19.000000000 -0400
+++ mesa-20110412/configure.ac 2011-05-09 15:05:11.000000000 -0400
@@ -1679,7 +1679,7 @@ if test "x$enable_gallium_llvm" = xyes;
diff -up mesa-20111114/configure.ac.dma mesa-20111114/configure.ac
--- mesa-20111114/configure.ac.dma 2011-11-14 15:57:16.783162469 +0000
+++ mesa-20111114/configure.ac 2011-11-14 15:58:07.877159762 +0000
@@ -1742,7 +1742,7 @@ if test "x$enable_gallium_llvm" = xyes;
if test "x$LLVM_CONFIG" != xno; then
LLVM_VERSION=`$LLVM_CONFIG --version`
LLVM_CFLAGS=`$LLVM_CONFIG --cppflags`
- LLVM_LIBS="`$LLVM_CONFIG --libs` -lstdc++"
+ LLVM_LIBS="-lLLVM-`llvm-config --version` -lstdc++"
LLVM_CFLAGS=`$LLVM_CONFIG --cppflags|sed 's/-DNDEBUG\>//g'`
- LLVM_LIBS="`$LLVM_CONFIG --libs`"
+ LLVM_LIBS=-lLLVM-`llvm-config --version` -lstdc++
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
GALLIUM_DRIVERS_DIRS="$GALLIUM_DRIVERS_DIRS llvmpipe"
DEFINES="$DEFINES -D__STDC_CONSTANT_MACROS"

View File

@ -1,32 +0,0 @@
From 4258e9b3a5eeaa90f2a0485576d7d17d6d8e4d6f Mon Sep 17 00:00:00 2001
From: Marc Pignat <marc@pignat.org>
Date: Tue, 28 Jun 2011 13:21:58 +0000
Subject: drisw: Fix 24bpp software rendering, take 2
This patch add the support for 24bpp in the dri/swrast implementation.
See http://bugs.freedesktop.org/show_bug.cgi?id=23525
Signed-off-by: Marc Pignat <marc at pignat.org>
Signed-off-by: Brian Paul <brianp@vmware.com>
(cherry picked from commit cfec000e7514342fd51859906e173ba2d474a55c)
---
diff --git a/src/glx/drisw_glx.c b/src/glx/drisw_glx.c
index 07d4955..a57b327 100644
--- a/src/glx/drisw_glx.c
+++ b/src/glx/drisw_glx.c
@@ -100,6 +100,13 @@ XCreateDrawable(struct drisw_drawable * pdp,
32, /* bitmap_pad */
0); /* bytes_per_line */
+ /**
+ * swrast does not handle 24-bit depth with 24 bpp, so let X do the
+ * the conversion for us.
+ */
+ if (pdp->ximage->bits_per_pixel == 24)
+ pdp->ximage->bits_per_pixel = 32;
+
return True;
}
--
cgit v0.9.0.2-2-gbebe

View File

@ -1,12 +0,0 @@
diff -up Mesa-7.11/src/mesa/drivers/dri/sis/sis_context.h.jx Mesa-7.11/src/mesa/drivers/dri/sis/sis_context.h
--- Mesa-7.11/src/mesa/drivers/dri/sis/sis_context.h.jx 2010-12-14 16:43:15.000000000 -0500
+++ Mesa-7.11/src/mesa/drivers/dri/sis/sis_context.h 2011-09-09 11:47:56.454465358 -0400
@@ -405,7 +405,7 @@ struct sis_context
#elif defined(__ia64__)
#define MMIO_WMB() __asm __volatile("mf" : : : "memory")
#else
-#error platform needs WMB
+#define MMIO_WMB() __sync_synchronize()
#endif
#define mEndPrimitive() \

View File

@ -1,12 +0,0 @@
diff -up mesa-20090813/src/mesa/drivers/dri/common/vblank.c.jx mesa-20090813/src/mesa/drivers/dri/common/vblank.c
--- mesa-20090813/src/mesa/drivers/dri/common/vblank.c.jx 2009-08-13 09:28:01.000000000 -0400
+++ mesa-20090813/src/mesa/drivers/dri/common/vblank.c 2009-09-08 14:07:51.000000000 -0400
@@ -256,7 +256,7 @@ static int do_wait( drmVBlank * vbl, GLu
if ( ret != 0 ) {
static GLboolean first_time = GL_TRUE;
- if ( first_time ) {
+ if (0) {
fprintf(stderr,
"%s: drmWaitVBlank returned %d, IRQs don't seem to be"
" working correctly.\nTry adjusting the vblank_mode"

View File

@ -1,46 +0,0 @@
diff -up mesa-20110620/configure.ac.no-mach64 mesa-20110620/configure.ac
--- mesa-20110620/configure.ac.no-mach64 2011-06-20 12:19:16.000000000 +1000
+++ mesa-20110620/configure.ac 2011-06-20 13:52:27.000000000 +1000
@@ -1022,7 +1022,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# the new interface. i810 are missing because there is no
# x86-64 system where they could *ever* be used.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
+ DRI_DIRS="i915 i965 mga nouveau r128 r200 r300 r600 \
radeon savage tdfx unichrome swrast"
fi
;;
@@ -1030,13 +1030,13 @@ if test "$mesa_driver" = dri -o "$mesa_d
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon tdfx swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast"
fi
;;
sparc*)
# Build only the drivers for cards that exist on sparc`
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon swrast"
+ DRI_DIRS="r128 r200 r300 r600 radeon swrast"
fi
;;
esac
@@ -1050,7 +1050,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
fi
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 \
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 \
radeon tdfx unichrome savage sis swrast"
fi
;;
@@ -1079,7 +1079,7 @@ if test "$mesa_driver" = dri -o "$mesa_d
# default drivers
if test "x$DRI_DIRS" = "xyes"; then
- DRI_DIRS="i810 i915 i965 mach64 mga nouveau r128 r200 r300 r600 radeon \
+ DRI_DIRS="i810 i915 i965 mga nouveau r128 r200 r300 r600 radeon \
savage sis tdfx unichrome swrast"
fi

View File

@ -4,12 +4,12 @@
%define dri_drivers --with-dri-drivers=swrast
%else
%define with_hardware 1
%define base_drivers mga,nouveau,r128,radeon,r200,savage,tdfx
%define base_drivers nouveau,radeon,r200
%ifarch %{ix86}
%define ix86_drivers ,i810,i915,i965,sis,unichrome
%define ix86_drivers ,i915,i965
%endif
%ifarch x86_64
%define amd64_drivers ,i915,i965,unichrome
%define amd64_drivers ,i915,i965
%endif
%ifarch ia64
%define ia64_drivers ,i915
@ -20,13 +20,13 @@
%define _default_patch_fuzz 2
%define manpages gl-manpages-1.0.1
%define gitdate 20111103
%define gitdate 20111114
#% define snapshot
Summary: Mesa graphics libraries
Name: mesa
Version: 7.11
Release: 12%{?dist}
Version: 7.12
Release: 0.1%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://www.mesa3d.org
@ -39,17 +39,10 @@ Source2: %{manpages}.tar.bz2
Source3: make-git-snapshot.sh
Patch2: mesa-7.1-nukeglthread-debug.patch
Patch3: mesa-no-mach64.patch
Patch4: legacy-drivers.patch
#Patch7: mesa-7.1-link-shared.patch
Patch8: mesa-7.10-llvmcore.patch
Patch30: mesa-7.6-hush-vblank-warning.patch
Patch31: mesa-7.10-swrastg.patch
Patch32: mesa-7.11-generic-wmb.patch
Patch34: 0001-nv50-fix-max-texture-levels.patch
BuildRequires: pkgconfig autoconf automake libtool
%if %{with_hardware}
BuildRequires: kernel-headers >= 2.6.27-0.305.rc5.git6
@ -216,14 +209,8 @@ Mesa offscreen rendering development package
#%setup -q -n Mesa-%{version}%{?snapshot} -b0 -b2
%setup -q -n mesa-%{gitdate} -b2
%patch2 -p1 -b .intel-glthread
%patch3 -p1 -b .no-mach64
%patch4 -p1 -b .classic
#patch7 -p1 -b .dricore
%patch8 -p1 -b .llvmcore
%patch30 -p1 -b .vblank-warning
#patch31 -p1 -b .swrastg
%patch32 -p1 -b .wmb
%patch34 -p1 -b .nv50-texlevel
%build
@ -239,11 +226,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS"
%endif
%configure %{common_flags} \
--disable-glw \
--disable-glut \
--enable-gl-osmesa \
--with-driver=dri \
--with-osmesa-bits=8 \
--enable-osmesa \
--with-dri-driverdir=%{_libdir}/dri \
--enable-egl \
--enable-gles1 \
@ -258,7 +241,7 @@ export CXXFLAGS="$RPM_OPT_FLAGS"
%endif
%{?dri_drivers}
make %{?_smp_mflags}
make %{?_smp_mflags} MKDEP=/bin/true
pushd ../%{manpages}
autoreconf -v --install
@ -281,9 +264,9 @@ install -d $RPM_BUILD_ROOT%{_libdir}/dri
# use gallium driver iff built
[ -f %{_lib}/gallium/r300_dri.so ] && cp %{_lib}/gallium/r300_dri.so %{_lib}/r300_dri.so
[ -f %{_lib}/gallium/r600_dri.so ] && cp %{_lib}/gallium/r600_dri.so %{_lib}/r600_dri.so
[ -f %{_lib}/gallium/swrastg_dri.so ] && mv %{_lib}/gallium/swrastg_dri.so %{_lib}/swrast_dri.so
[ -f %{_lib}/gallium/swrast_dri.so ] && mv %{_lib}/gallium/swrast_dri.so %{_lib}/swrast_dri.so
for f in i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon savage sis swrast tdfx unichrome nouveau_vieux gallium/vmwgfx ; do
for f in i915 i965 r200 r300 r600 radeon swrast nouveau_vieux gallium/vmwgfx ; do
so=%{_lib}/${f}_dri.so
test -e $so && echo $so
done | xargs install -m 0755 -t $RPM_BUILD_ROOT%{_libdir}/dri >& /dev/null || :
@ -369,24 +352,6 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/dri/nouveau_vieux_dri.so
%endif
%{_libdir}/dri/swrast_dri.so
%exclude %{_libdir}/dri/swrastg_dri.so
%files dri-drivers-dri1
%defattr(-,root,root,-)
%doc docs/COPYING
%if %{with_hardware}
%ifarch %{ix86} x86_64
%{_libdir}/dri/unichrome_dri.so
%ifarch %{ix86}
%{_libdir}/dri/i810_dri.so
%{_libdir}/dri/sis_dri.so
%endif
%endif
%{_libdir}/dri/r128_dri.so
%{_libdir}/dri/mga_dri.so
%{_libdir}/dri/savage_dri.so
%{_libdir}/dri/tdfx_dri.so
%endif
%files -n khrplatform-devel
%defattr(-,root,root,-)
@ -462,6 +427,9 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/pkgconfig/osmesa.pc
%changelog
* Mon Nov 14 2011 Dave Airlie <airlied@redhat.com> 7.12-0.1
- rebase to upstream snapshot of 7.12
* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 7.11-12
- Rebuild for new libllvm soname

View File

@ -1,2 +1,2 @@
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
333f61aac5367c8b7b9ea22943c448b1 mesa-20111103.tar.xz
fdf17b0823514116454371e4967d62ab mesa-20111114.tar.xz