(victorious trombone noise)

This commit is contained in:
Adam Jackson 2008-02-21 20:05:41 +00:00
parent b6264c378a
commit 2c6d81999d
2 changed files with 5 additions and 25 deletions

View File

@ -1,16 +1,7 @@
diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
--- mesa-20080218/configure.ac.jx 2008-02-18 12:01:51.000000000 -0500
+++ mesa-20080218/configure.ac 2008-02-21 13:09:44.000000000 -0500
@@ -448,6 +448,8 @@ dnl Just default to no EGL for now
USING_EGL=0
AC_SUBST(USING_EGL)
+echo ajax hates ppc
+
dnl Set DRI_DIRS, DEFINES and LIB_DEPS
if test "$mesa_driver" = dri; then
# Use TLS in GLX?
@@ -459,15 +461,12 @@ if test "$mesa_driver" = dri; then
@@ -459,12 +459,7 @@
PROGRAM_DIRS="egl"
fi
@ -19,16 +10,11 @@ diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 radeon s3v \
- savage sis tdfx trident unichrome ffb"
- fi
+ echo host_os $host_os host_cpu $host_cpu
# Platform specific settings and drivers to build
case "$host_os" in
linux*)
+ echo OMG LINUX
DEFINES="$DEFINES -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER"
DEFINES="$DEFINES -DGLX_INDIRECT_RENDERING -DHAVE_ALIAS"
if test "x$driglx_direct" = xyes; then
@@ -475,7 +474,7 @@ if test "$mesa_driver" = dri; then
@@ -475,7 +470,7 @@
fi
case "$host_cpu" in
@ -37,14 +23,13 @@ diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
# ffb, gamma, and sis are missing because they have not be
# converted to use the new interface. i810 are missing
# because there is no x86-64 system where they could *ever*
@@ -484,13 +483,16 @@ if test "$mesa_driver" = dri; then
@@ -484,13 +479,15 @@
DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 radeon \
savage tdfx unichrome"
fi
+ DRI_DIRS="`echo $DRI_DIRS | sed 's/i810//g'`"
;;
powerpc*)
+ echo OMG PPC
# Build only the drivers for cards that exist on PowerPC.
# At some point MGA will be added, but not yet.
if test "x$DRI_DIRS" = x; then
@ -55,7 +40,7 @@ diff -up mesa-20080218/configure.ac.jx mesa-20080218/configure.ac
;;
esac
;;
@@ -513,6 +515,12 @@ if test "$mesa_driver" = dri; then
@@ -513,6 +510,12 @@
fi
;;
esac

View File

@ -30,7 +30,6 @@ Source3: make-git-snapshot.sh
Patch0: mesa-7.1pre-osmesa-version.patch
Patch1: mesa-7.1-dri-drivers.patch
BuildRequires: pkgconfig autoconf automake
%if %{with_dri}
BuildRequires: libdrm-devel >= 2.4.0-0.4
@ -185,7 +184,7 @@ mv %{_lib} osmesa32
make clean
# just to be sure...
[ `find . -name \*.o | wc -l` -eq 0 ] || exit "make cleaner dammit"
[ `find . -name \*.o | wc -l` -eq 0 ] || exit "make cleaner plz"
# now build the rest of mesa
%configure \
@ -195,10 +194,6 @@ make clean
--with-driver=%{driver} \
--with-dri-driverdir=%{_libdir}/dri
#echo "--- MESA CONFIGURATION ---"
#cat configs/current
#echo "--- END MESA CONFIGURATION ---"
make #{?_smp_mflags}
make -C progs/xdemos glxgears glxinfo