Link against libclang-cpp.so
https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
This commit is contained in:
parent
dfa8e8664d
commit
2208aa87d7
37
0001-Link-with-libclang-cpp.patch
Normal file
37
0001-Link-with-libclang-cpp.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
From c9987fca1fa611e48f85644493edd8d5a30cf403 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Tom Stellard <tstellar@redhat.com>
|
||||||
|
Date: Fri, 13 Dec 2019 17:42:17 +0000
|
||||||
|
Subject: [PATCH] Link with libclang-cpp
|
||||||
|
|
||||||
|
---
|
||||||
|
src/gallium/targets/opencl/meson.build | 14 +-------------
|
||||||
|
1 file changed, 1 insertion(+), 13 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/gallium/targets/opencl/meson.build b/src/gallium/targets/opencl/meson.build
|
||||||
|
index 907cc74337d..031d35b9716 100644
|
||||||
|
--- a/src/gallium/targets/opencl/meson.build
|
||||||
|
+++ b/src/gallium/targets/opencl/meson.build
|
||||||
|
@@ -43,19 +43,7 @@ libopencl = shared_library(
|
||||||
|
dependencies : [
|
||||||
|
idep_mesautil,
|
||||||
|
dep_clock, dep_dl, dep_unwind, dep_elf,
|
||||||
|
- cpp.find_library('clangCodeGen', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangFrontendTool', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangFrontend', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangDriver', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangSerialization', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangParse', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangSema', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangAnalysis', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangAST', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangASTMatchers', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangEdit', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangLex', dirs : llvm_libdir),
|
||||||
|
- cpp.find_library('clangBasic', dirs : llvm_libdir),
|
||||||
|
+ cpp.find_library('clang-cpp', dirs : llvm_libdir),
|
||||||
|
],
|
||||||
|
version : '@0@.0.0'.format(opencl_version),
|
||||||
|
install : true,
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
@ -52,7 +52,7 @@ Name: mesa
|
|||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
%global ver 19.3.2
|
%global ver 19.3.2
|
||||||
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
Version: %{lua:ver = string.gsub(rpm.expand("%{ver}"), "-", "~"); print(ver)}
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
|
|
||||||
@ -63,6 +63,8 @@ Source0: https://mesa.freedesktop.org/archive/%{name}-%{ver}.tar.xz
|
|||||||
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
Source1: Mesa-MLAA-License-Clarification-Email.txt
|
||||||
|
|
||||||
Patch3: 0003-evergreen-big-endian.patch
|
Patch3: 0003-evergreen-big-endian.patch
|
||||||
|
# https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
|
||||||
|
Patch4: 0001-Link-with-libclang-cpp.patch
|
||||||
|
|
||||||
BuildRequires: meson >= 0.45
|
BuildRequires: meson >= 0.45
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -585,6 +587,10 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 23 2020 Tom Stellard <tstellar@redhat.com> - 19.3.2-3
|
||||||
|
- Link against libclang-cpp.so
|
||||||
|
- https://fedoraproject.org/wiki/Changes/Stop-Shipping-Individual-Component-Libraries-In-clang-lib-Package
|
||||||
|
|
||||||
* Thu Jan 23 2020 Tom Stellard <tstellar@redhat.com> - 19.3.2-2
|
* Thu Jan 23 2020 Tom Stellard <tstellar@redhat.com> - 19.3.2-2
|
||||||
- Build with -fcommon until upstream fixes omx build with gcc10
|
- Build with -fcommon until upstream fixes omx build with gcc10
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user