- latest Mesa snapshot - re-enable tex offset
- add r300 command buffer support on top of snapshot - disable osmesa version patch -- (ajax???)
This commit is contained in:
parent
a2ea5378b5
commit
1ee2a96a85
@ -1,2 +1,2 @@
|
|||||||
gl-manpages-1.0.1.tar.bz2
|
gl-manpages-1.0.1.tar.bz2
|
||||||
mesa-20080627.tar.bz2
|
mesa-20080814.tar.bz2
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
diff -up mesa-20080311/src/mesa/drivers/dri/intel/intel_screen.c.disable-tex-offset mesa-20080311/src/mesa/drivers/dri/intel/intel_screen.c
|
|
||||||
--- mesa-20080311/src/mesa/drivers/dri/intel/intel_screen.c.disable-tex-offset 2008-03-11 20:05:30.000000000 -0400
|
|
||||||
+++ mesa-20080311/src/mesa/drivers/dri/intel/intel_screen.c 2008-03-11 20:04:08.000000000 -0400
|
|
||||||
@@ -384,10 +384,12 @@ intelHandleBufferAttach(__DRIdrawablePri
|
|
||||||
intel_renderbuffer_set_region(rb, region);
|
|
||||||
}
|
|
||||||
|
|
||||||
+#if 0
|
|
||||||
static const __DRItexOffsetExtension intelTexOffsetExtension = {
|
|
||||||
{ __DRI_TEX_OFFSET },
|
|
||||||
intelSetTexOffset,
|
|
||||||
};
|
|
||||||
+#endif
|
|
||||||
|
|
||||||
static const __DRItexBufferExtension intelTexBufferExtension = {
|
|
||||||
{ __DRI_TEX_BUFFER, __DRI_TEX_BUFFER_VERSION },
|
|
||||||
@@ -400,7 +402,9 @@ static const __DRIextension *intelExtens
|
|
||||||
&driSwapControlExtension.base,
|
|
||||||
&driFrameTrackingExtension.base,
|
|
||||||
&driMediaStreamCounterExtension.base,
|
|
||||||
+#if 0
|
|
||||||
&intelTexOffsetExtension.base,
|
|
||||||
+#endif
|
|
||||||
&intelTexBufferExtension.base,
|
|
||||||
NULL
|
|
||||||
};
|
|
@ -1,14 +1,13 @@
|
|||||||
diff -up mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c
|
diff -up mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c.intel-nowarn mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c
|
||||||
--- mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c.nowarn 2008-05-07 10:11:10.000000000 +1000
|
--- mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c.intel-nowarn 2008-08-14 02:28:38.000000000 +1000
|
||||||
+++ mesa-20080415/src/mesa/drivers/dri/intel/intel_context.c 2008-05-07 10:11:21.000000000 +1000
|
+++ mesa-20080814/src/mesa/drivers/dri/intel/intel_context.c 2008-08-14 16:25:23.000000000 +1000
|
||||||
@@ -479,8 +479,8 @@ intel_init_bufmgr(struct intel_context *
|
@@ -506,9 +506,6 @@ intel_init_bufmgr(struct intel_context *
|
||||||
if (ttm_disable) {
|
if (intel->bufmgr == NULL) {
|
||||||
fprintf(stderr, "TTM buffer manager disabled. Using classic.\n");
|
if (gem_disable) {
|
||||||
} else {
|
fprintf(stderr, "GEM disabled. Using classic.\n");
|
||||||
- fprintf(stderr, "Failed to initialize TTM buffer manager. "
|
- } else {
|
||||||
|
- fprintf(stderr, "Failed to initialize GEM. "
|
||||||
- "Falling back to classic.\n");
|
- "Falling back to classic.\n");
|
||||||
+ //fprintf(stderr, "Failed to initialize TTM buffer manager. "
|
|
||||||
+ // "Falling back to classic.\n");
|
|
||||||
}
|
}
|
||||||
|
|
||||||
if (intelScreen->tex.size == 0) {
|
if (intelScreen->tex.size == 0) {
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/mesa/drivers/dri/Makefile
|
diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.dricore mesa-20080814/src/mesa/drivers/dri/Makefile
|
||||||
--- mesa-20080612/src/mesa/drivers/dri/Makefile.dricore 2008-06-12 12:06:50.000000000 +1000
|
--- mesa-20080814/src/mesa/drivers/dri/Makefile.dricore 2008-08-14 02:28:38.000000000 +1000
|
||||||
+++ mesa-20080612/src/mesa/drivers/dri/Makefile 2008-06-12 13:25:58.000000000 +1000
|
+++ mesa-20080814/src/mesa/drivers/dri/Makefile 2008-08-14 16:18:20.000000000 +1000
|
||||||
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
|
@@ -6,12 +6,17 @@ include $(TOP)/configs/current
|
||||||
|
|
||||||
|
|
||||||
@ -20,12 +20,12 @@ diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/m
|
|||||||
|
|
||||||
subdirs:
|
subdirs:
|
||||||
@for dir in $(DRI_DIRS) ; do \
|
@for dir in $(DRI_DIRS) ; do \
|
||||||
@@ -21,12 +26,14 @@ subdirs:
|
@@ -31,12 +36,14 @@ dri.pc: dri.pc.in
|
||||||
done
|
$(pcedit) $< > $@
|
||||||
|
|
||||||
|
|
||||||
-install:
|
-install: dri.pc
|
||||||
+install: $(TOP)/$(LIB_DIR)/libdricore.so
|
+install: dri.pc $(TOP)/$(LIB_DIR)/libdricore.so
|
||||||
@for dir in $(DRI_DIRS) ; do \
|
@for dir in $(DRI_DIRS) ; do \
|
||||||
if [ -d $$dir ] ; then \
|
if [ -d $$dir ] ; then \
|
||||||
(cd $$dir && $(MAKE) install) || exit 1 ; \
|
(cd $$dir && $(MAKE) install) || exit 1 ; \
|
||||||
@ -33,18 +33,19 @@ diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.dricore mesa-20080612/src/m
|
|||||||
done
|
done
|
||||||
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
+ $(INSTALL) -d $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||||
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
+ $(INSTALL) -m 755 $(TOP)/$(LIB_DIR)/libdricore.so $(DESTDIR)$(DRI_DRIVER_INSTALL_DIR)
|
||||||
$(INSTALL) -d $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
$(INSTALL) -d $(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
|
||||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_interface.h \
|
||||||
$(INSTALL) -m 0644 $(TOP)/include/GL/internal/dri_sarea.h $(DESTDIR)$(INSTALL_DIR)/include/GL/internal
|
$(DESTDIR)$(INSTALL_INC_DIR)/GL/internal
|
||||||
@@ -38,4 +45,5 @@ clean:
|
@@ -52,5 +59,6 @@ clean:
|
||||||
(cd $$dir && $(MAKE) clean) ; \
|
(cd $$dir && $(MAKE) clean) ; \
|
||||||
fi \
|
fi \
|
||||||
done
|
done
|
||||||
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
|
+ -rm -f libdricore.so $(TOP)/$(LIB_DIR)/libdricore.so
|
||||||
-rm -f common/*.o
|
-rm -f common/*.o
|
||||||
diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080612/src/mesa/drivers/dri/Makefile.template
|
-rm -f *.pc
|
||||||
--- mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore 2008-06-12 12:06:50.000000000 +1000
|
diff -up mesa-20080814/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080814/src/mesa/drivers/dri/Makefile.template
|
||||||
+++ mesa-20080612/src/mesa/drivers/dri/Makefile.template 2008-06-12 13:15:34.000000000 +1000
|
--- mesa-20080814/src/mesa/drivers/dri/Makefile.template.dricore 2008-08-14 02:28:38.000000000 +1000
|
||||||
|
+++ mesa-20080814/src/mesa/drivers/dri/Makefile.template 2008-08-14 16:19:37.000000000 +1000
|
||||||
@@ -1,6 +1,6 @@
|
@@ -1,6 +1,6 @@
|
||||||
# -*-makefile-*-
|
# -*-makefile-*-
|
||||||
|
|
||||||
@ -53,10 +54,10 @@ diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080
|
|||||||
|
|
||||||
COMMON_SOURCES = \
|
COMMON_SOURCES = \
|
||||||
../common/utils.c \
|
../common/utils.c \
|
||||||
@@ -69,7 +69,9 @@ default: symlinks depend $(LIBNAME) $(TO
|
@@ -64,7 +64,9 @@ default: symlinks depend $(LIBNAME) $(TO
|
||||||
|
|
||||||
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
|
$(LIBNAME): $(OBJECTS) $(MESA_MODULES) $(WINOBJ) Makefile $(TOP)/src/mesa/drivers/dri/Makefile.template
|
||||||
$(TOP)/bin/mklib -ldflags '$(LDFLAGS)' -noprefix -o $@ \
|
$(MKLIB) -o $@ -noprefix -linker '$(CC)' -ldflags '$(LDFLAGS)' \
|
||||||
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
|
- $(OBJECTS) $(MESA_MODULES) $(WINOBJ) $(DRI_LIB_DEPS)
|
||||||
+ $(OBJECTS) $(WINOBJ) \
|
+ $(OBJECTS) $(WINOBJ) \
|
||||||
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
|
+ -L$(TOP)/$(LIB_DIR) -Wl,-R$(DRI_DRIVER_INSTALL_DIR) -ldricore \
|
||||||
@ -64,9 +65,9 @@ diff -up mesa-20080612/src/mesa/drivers/dri/Makefile.template.dricore mesa-20080
|
|||||||
|
|
||||||
|
|
||||||
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
|
$(TOP)/$(LIB_DIR)/$(LIBNAME): $(LIBNAME)
|
||||||
diff -up mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore mesa-20080612/src/mesa/x86/read_rgba_span_x86.S
|
diff -up mesa-20080814/src/mesa/x86/read_rgba_span_x86.S.dricore mesa-20080814/src/mesa/x86/read_rgba_span_x86.S
|
||||||
--- mesa-20080612/src/mesa/x86/read_rgba_span_x86.S.dricore 2008-06-12 12:06:50.000000000 +1000
|
--- mesa-20080814/src/mesa/x86/read_rgba_span_x86.S.dricore 2008-08-14 02:28:38.000000000 +1000
|
||||||
+++ mesa-20080612/src/mesa/x86/read_rgba_span_x86.S 2008-06-12 13:15:34.000000000 +1000
|
+++ mesa-20080814/src/mesa/x86/read_rgba_span_x86.S 2008-08-14 16:16:49.000000000 +1000
|
||||||
@@ -77,7 +77,6 @@
|
@@ -77,7 +77,6 @@
|
||||||
*/
|
*/
|
||||||
|
|
||||||
|
18
mesa.spec
18
mesa.spec
@ -10,12 +10,12 @@
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%define manpages gl-manpages-1.0.1
|
%define manpages gl-manpages-1.0.1
|
||||||
%define gitdate 20080627
|
%define gitdate 20080814
|
||||||
|
|
||||||
Summary: Mesa graphics libraries
|
Summary: Mesa graphics libraries
|
||||||
Name: mesa
|
Name: mesa
|
||||||
Version: 7.1
|
Version: 7.1
|
||||||
Release: 0.37%{?dist}
|
Release: 0.38%{?dist}
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://www.mesa3d.org
|
URL: http://www.mesa3d.org
|
||||||
@ -30,8 +30,7 @@ Source3: make-git-snapshot.sh
|
|||||||
Patch0: mesa-7.1pre-osmesa-version.patch
|
Patch0: mesa-7.1pre-osmesa-version.patch
|
||||||
Patch2: mesa-7.1pre-nukeglthread-debug.patch
|
Patch2: mesa-7.1pre-nukeglthread-debug.patch
|
||||||
|
|
||||||
# This doesn't work, disable for now.
|
Patch5: r300-cmdbuf.patch
|
||||||
Patch4: disable-tex-offset.patch
|
|
||||||
|
|
||||||
Patch7: mesa-7.1-link-shared.patch
|
Patch7: mesa-7.1-link-shared.patch
|
||||||
|
|
||||||
@ -39,7 +38,7 @@ Patch12: mesa-7.1-disable-intel-classic-warn.patch
|
|||||||
|
|
||||||
BuildRequires: pkgconfig autoconf automake
|
BuildRequires: pkgconfig autoconf automake
|
||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
BuildRequires: libdrm-devel >= 2.4.0-0.12
|
BuildRequires: libdrm-devel >= 2.4.0-0.19
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
BuildRequires: expat-devel >= 2.0
|
BuildRequires: expat-devel >= 2.0
|
||||||
@ -161,9 +160,9 @@ This package provides some demo applications for testing Mesa.
|
|||||||
%prep
|
%prep
|
||||||
#%setup -q -n Mesa-%{version}pre -b1 -b2
|
#%setup -q -n Mesa-%{version}pre -b1 -b2
|
||||||
%setup -q -n mesa-%{gitdate} -b2
|
%setup -q -n mesa-%{gitdate} -b2
|
||||||
%patch0 -p1 -b .osmesa
|
#patch0 -p1 -b .osmesa
|
||||||
%patch2 -p1 -b .intel-glthread
|
%patch2 -p1 -b .intel-glthread
|
||||||
%patch4 -p1 -b .disable-tex-offset
|
%patch5 -p1 -b .r300cmdbuf
|
||||||
%patch7 -p1 -b .dricore
|
%patch7 -p1 -b .dricore
|
||||||
%patch12 -p1 -b .intel-nowarn
|
%patch12 -p1 -b .intel-nowarn
|
||||||
|
|
||||||
@ -399,6 +398,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/mesa-demos-data
|
%{_libdir}/mesa-demos-data
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 14 2008 Dave Airlie <airlied@redhat.com> 7.1-0.38
|
||||||
|
- latest Mesa snapshot - re-enable tex offset
|
||||||
|
- add r300 command buffer support on top of snapshot
|
||||||
|
- disable osmesa version patch -- (ajax???)
|
||||||
|
|
||||||
* Fri Jun 27 2008 Adam Jackson <ajax@redhat.com> 7.1-0.37
|
* Fri Jun 27 2008 Adam Jackson <ajax@redhat.com> 7.1-0.37
|
||||||
- Drop mesa-source subpackage. Man that feels good.
|
- Drop mesa-source subpackage. Man that feels good.
|
||||||
|
|
||||||
|
7669
r300-cmdbuf.patch
Normal file
7669
r300-cmdbuf.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user