- rebase to a git snapshot - disable vmwgfx
This commit is contained in:
parent
1c43d7f454
commit
0b15b14e4b
@ -1,3 +1,5 @@
|
|||||||
mesa-20100208.tar.bz2
|
mesa-20100208.tar.bz2
|
||||||
gl-manpages-1.0.1.tar.bz2
|
gl-manpages-1.0.1.tar.bz2
|
||||||
xdriinfo-1.0.3.tar.bz2
|
xdriinfo-1.0.3.tar.bz2
|
||||||
|
mesa-demos-20100529.tar.bz2
|
||||||
|
mesa-20100529.tar.bz2
|
||||||
|
22
make-demo-snapshot.sh
Executable file
22
make-demo-snapshot.sh
Executable file
@ -0,0 +1,22 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
# Usage: ./make-git-snapshot.sh [COMMIT]
|
||||||
|
#
|
||||||
|
# to make a snapshot of the given tag/branch. Defaults to HEAD.
|
||||||
|
# Point env var REF to a local mesa repo to reduce clone time.
|
||||||
|
|
||||||
|
DIRNAME=mesa-demos-$( date +%Y%m%d )
|
||||||
|
|
||||||
|
echo REF ${REF:+--reference $REF}
|
||||||
|
echo DIRNAME $DIRNAME
|
||||||
|
echo HEAD ${1:-HEAD}
|
||||||
|
|
||||||
|
rm -rf $DIRNAME
|
||||||
|
|
||||||
|
git clone ${REF:+--reference $REF} \
|
||||||
|
git://git.freedesktop.org/git/mesa/demos $DIRNAME
|
||||||
|
|
||||||
|
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
|
||||||
|
| bzip2 > $DIRNAME.tar.bz2
|
||||||
|
|
||||||
|
# rm -rf $DIRNAME
|
11
mesa-demos-fix-add-needed.patch
Normal file
11
mesa-demos-fix-add-needed.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up mesa-demos-20100529/src/tests/Makefile.am.orig mesa-demos-20100529/src/tests/Makefile.am
|
||||||
|
--- mesa-demos-20100529/src/tests/Makefile.am.orig 2010-05-30 09:11:04.000000000 +1000
|
||||||
|
+++ mesa-demos-20100529/src/tests/Makefile.am 2010-05-30 09:11:09.000000000 +1000
|
||||||
|
@@ -169,6 +169,7 @@ endif
|
||||||
|
|
||||||
|
afsmultiarb_LDADD = ../util/libutil.la
|
||||||
|
arraytexture_LDADD = ../util/libutil.la
|
||||||
|
+auxbuffer_LDADD = -lX11
|
||||||
|
bug_3195_LDADD = ../util/libutil.la
|
||||||
|
bumpmap_LDADD = ../util/libutil.la
|
||||||
|
floattex_LDADD = ../util/libutil.la
|
@ -1,16 +1,16 @@
|
|||||||
diff -up mesa-20091221/configure.ac.da mesa-20091221/configure.ac
|
diff -up mesa-20100529/configure.ac.mach64 mesa-20100529/configure.ac
|
||||||
--- mesa-20091221/configure.ac.da 2009-12-21 08:09:11.000000000 +1000
|
--- mesa-20100529/configure.ac.mach64 2010-05-29 11:31:22.000000000 +1000
|
||||||
+++ mesa-20091221/configure.ac 2009-12-21 08:41:04.000000000 +1000
|
+++ mesa-20100529/configure.ac 2010-05-29 18:53:55.000000000 +1000
|
||||||
@@ -723,7 +723,7 @@ if test "$mesa_driver" = dri; then
|
@@ -819,7 +819,7 @@ if test "$mesa_driver" = dri; then
|
||||||
# because there is no x86-64 system where they could *ever*
|
# the new interface. i810 are missing because there is no
|
||||||
# be used.
|
# x86-64 system where they could *ever* be used.
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
- DRI_DIRS="i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
||||||
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
+ DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
||||||
savage tdfx unichrome swrast"
|
savage tdfx unichrome swrast"
|
||||||
fi
|
fi
|
||||||
;;
|
;;
|
||||||
@@ -731,13 +731,13 @@ if test "$mesa_driver" = dri; then
|
@@ -827,13 +827,13 @@ if test "$mesa_driver" = dri; then
|
||||||
# Build only the drivers for cards that exist on PowerPC.
|
# Build only the drivers for cards that exist on PowerPC.
|
||||||
# At some point MGA will be added, but not yet.
|
# At some point MGA will be added, but not yet.
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
@ -21,26 +21,26 @@ diff -up mesa-20091221/configure.ac.da mesa-20091221/configure.ac
|
|||||||
sparc*)
|
sparc*)
|
||||||
# Build only the drivers for cards that exist on sparc`
|
# Build only the drivers for cards that exist on sparc`
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon ffb swrast"
|
- DRI_DIRS="mach64 r128 r200 r300 r600 radeon swrast"
|
||||||
+ DRI_DIRS="r128 r200 r300 r600 radeon ffb swrast"
|
+ DRI_DIRS="r128 r200 r300 r600 radeon swrast"
|
||||||
fi
|
fi
|
||||||
;;
|
;;
|
||||||
esac
|
esac
|
||||||
@@ -756,7 +756,7 @@ if test "$mesa_driver" = dri; then
|
@@ -850,7 +850,7 @@ if test "$mesa_driver" = dri; then
|
||||||
# ffb and gamma are missing because they have not been converted
|
fi
|
||||||
# to use the new interface.
|
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
|
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon tdfx \
|
||||||
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
|
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon tdfx \
|
||||||
unichrome savage sis swrast"
|
unichrome savage sis swrast"
|
||||||
fi
|
fi
|
||||||
;;
|
;;
|
||||||
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
|
@@ -869,7 +869,7 @@ if test "$mesa_driver" = dri; then
|
||||||
|
|
||||||
# default drivers
|
# default drivers
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
- DRI_DIRS="i810 i915 i965 mach64 mga r128 r200 r300 r600 radeon \
|
||||||
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
+ DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
||||||
savage sis tdfx unichrome ffb swrast"
|
savage sis tdfx unichrome swrast"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -44,6 +44,7 @@ Patch1: mesa-7.1-osmesa-version.patch
|
|||||||
Patch2: mesa-7.1-nukeglthread-debug.patch
|
Patch2: mesa-7.1-nukeglthread-debug.patch
|
||||||
Patch3: mesa-no-mach64.patch
|
Patch3: mesa-no-mach64.patch
|
||||||
Patch4: nouveau-legacy-enable.patch
|
Patch4: nouveau-legacy-enable.patch
|
||||||
|
Patch5: mesa-demos-fix-add-needed.patch
|
||||||
|
|
||||||
#Patch7: mesa-7.1-link-shared.patch
|
#Patch7: mesa-7.1-link-shared.patch
|
||||||
|
|
||||||
@ -193,6 +194,7 @@ Group: User Interface/X Hardware Support
|
|||||||
|
|
||||||
# Hack the demos to use installed data files
|
# Hack the demos to use installed data files
|
||||||
cd ../%{demopkg}
|
cd ../%{demopkg}
|
||||||
|
%patch5 -p1 -b .add
|
||||||
sed -i 's,../images,%{_libdir}/mesa,' src/demos/*.c
|
sed -i 's,../images,%{_libdir}/mesa,' src/demos/*.c
|
||||||
sed -i 's,geartrain.dat,%{_libdir}/mesa/&,' src/demos/geartrain.c
|
sed -i 's,geartrain.dat,%{_libdir}/mesa/&,' src/demos/geartrain.c
|
||||||
sed -i 's,isosurf.dat,%{_libdir}/mesa/&,' src/demos/isosurf.c
|
sed -i 's,isosurf.dat,%{_libdir}/mesa/&,' src/demos/isosurf.c
|
||||||
|
@ -1,9 +1,8 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
diff -up mesa-20100529/configure.ac.nouveau mesa-20100529/configure.ac
|
||||||
index b6c6535..589b97c 100644
|
--- mesa-20100529/configure.ac.nouveau 2010-05-29 18:57:30.000000000 +1000
|
||||||
--- a/configure.ac
|
+++ mesa-20100529/configure.ac 2010-05-29 18:58:24.000000000 +1000
|
||||||
+++ b/configure.ac
|
@@ -820,20 +820,20 @@ if test "$mesa_driver" = dri; then
|
||||||
@@ -723,7 +723,7 @@ if test "$mesa_driver" = dri; then
|
# x86-64 system where they could *ever* be used.
|
||||||
# be used.
|
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
DRI_DIRS="i915 i965 mga r128 r200 r300 r600 radeon \
|
||||||
- savage tdfx unichrome swrast"
|
- savage tdfx unichrome swrast"
|
||||||
@ -11,12 +10,27 @@ index b6c6535..589b97c 100644
|
|||||||
fi
|
fi
|
||||||
;;
|
;;
|
||||||
powerpc*)
|
powerpc*)
|
||||||
@@ -775,7 +775,7 @@ if test "$mesa_driver" = dri; then
|
# Build only the drivers for cards that exist on PowerPC.
|
||||||
|
# At some point MGA will be added, but not yet.
|
||||||
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
|
- DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast"
|
||||||
|
+ DRI_DIRS="r128 r200 r300 r600 radeon tdfx swrast nouveau"
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
sparc*)
|
||||||
|
# Build only the drivers for cards that exist on sparc`
|
||||||
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
|
- DRI_DIRS="r128 r200 r300 r600 radeon swrast"
|
||||||
|
+ DRI_DIRS="r128 r200 r300 r600 radeon swrast nouveau"
|
||||||
|
fi
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
@@ -870,7 +870,7 @@ if test "$mesa_driver" = dri; then
|
||||||
# default drivers
|
# default drivers
|
||||||
if test "x$DRI_DIRS" = "xyes"; then
|
if test "x$DRI_DIRS" = "xyes"; then
|
||||||
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
DRI_DIRS="i810 i915 i965 mga r128 r200 r300 r600 radeon \
|
||||||
- savage sis tdfx unichrome ffb swrast"
|
- savage sis tdfx unichrome swrast"
|
||||||
+ savage sis tdfx unichrome ffb swrast nouveau"
|
+ savage sis tdfx unichrome swrast nouveau"
|
||||||
fi
|
fi
|
||||||
|
|
||||||
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
|
DRI_DIRS=`echo "$DRI_DIRS" | $SED 's/ */ /g'`
|
||||||
|
3
sources
3
sources
@ -1,3 +1,4 @@
|
|||||||
f20b37608e92e6add5984c804c92d85f mesa-20100208.tar.bz2
|
|
||||||
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
6ae05158e678f4594343f32c2ca50515 gl-manpages-1.0.1.tar.bz2
|
||||||
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
|
cb304d1ce562ac48b68eedeba38c662f xdriinfo-1.0.3.tar.bz2
|
||||||
|
b4d32564ccc411bbfcfe657f42d3632d mesa-demos-20100529.tar.bz2
|
||||||
|
3a15d8b0e80616cc9f1f3507f7b66b11 mesa-20100529.tar.bz2
|
||||||
|
Loading…
Reference in New Issue
Block a user